Follow-me&RingGroups not working on IncomingRoute

Discussion in 'General' started by eNoisy, Mar 22, 2011.

  1. eNoisy

    Joined:
    Jul 24, 2010
    Messages:
    59
    Likes Received:
    0
    Hi!

    I have the following scenario:
    Elastix 2.03 virtual machine running on a datacentre.

    Currently, only two remote IAX extensions 221 and 260.
    Trunk: IAX trunk (Faktortel - Australian provider)

    Follow me settings for 260:

    Initial ring time: 20

    Ring Strategy: ringallv2

    Ring Time: 20

    Follow-me list: 260
    mymobilenumber#

    Destination if no answer: Voicemail for 260

    1. If I configure an incoming route to direct all the calls to extension 260, the follow me option does not work. It rings extension 260 for those 20 seconds, then it rings my mobile number (only for like 5 seconds) and finally, instead of sending the caller to voicemail it starts again the loop of ringing 260(20seconds)+mobile(5seconds)...

    2. I tested calling extension 260 from extension 221 and for my surprise the follow-me does work as it's been setup.

    3. Another solution that i tested for incoming calls was to create an initial ringgroup containing only extension 260, if no answer i had another ringgroup for my mobile number and finally it should have been sent to voicemail if no anser. Again, same result as 1.

    I also tried replacing my mobile number on ring group 2 for extension 221, and again it didn't work.
    On my local PBX I have several ring groups and they all work (with local SIP extansions).

    Could it be a problem with remote extensions, the IAX protocol?
    I'm not sure if this is a bug or I'm just missing something.

    I'm attaching below the CLI results
    http://forum.elastix.org/old_files/EMS_PBX_followme_CLI__2011_03_22.txt

    TIA
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Follow-me&RingGroups not working on IncomingRoute

    contexts!!!!
     
  3. eNoisy

    Joined:
    Jul 24, 2010
    Messages:
    59
    Likes Received:
    0
    Re: Follow-me&RingGroups not working on IncomingRoute

    Hi Fernando, once again thanks for your reply.

    May I ask you to be a little bit more specific? Do I need to write a new context for external calls or modify an existent one?

    I'm reading about contexts right now and hopefully will understand the whole thing soon, however I need a little push at this stage as this PBX needs to be fixed asap.
     

Share This Page