Flash Operator Panel

Discussion in 'General' started by adil, Dec 12, 2007.

  1. adil

    Joined:
    Dec 11, 2007
    Messages:
    10
    Likes Received:
    0
    Hello,

    I just installed Elastix today. I don't see my extensions in the flash operator panel.

    Any ideas???
     
  2. blapoint

    Joined:
    Jun 11, 2007
    Messages:
    34
    Likes Received:
    0
    I know its not a great option and I had the same issue. What I did to resolve it was install a fresh copy of 0.8-5 and then did a yum update and it work fine now. For some reason I only had the issue when doing a fresh install from the 0.9.1.iso.
     
  3. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    Confirmed - issue exists installing from recent ISO, yet machines that were installed with 0.90beta and yum updated - no issues.

    Even with the Zapata-channels.conf correction, it still does not see trunks or extensions.

    Regards

    Bob
     
  4. adil

    Joined:
    Dec 11, 2007
    Messages:
    10
    Likes Received:
    0
    The issue was /var/www/html/panel/op_buttons_additional.cfg had a permission issue.

    chmod 777 /var/www/html/panel/op_buttons_additional.cfg
    fixed the problem
     
  5. jnickel

    Joined:
    Dec 7, 2007
    Messages:
    15
    Likes Received:
    0
    Thanks! This did fix the Extensions and Queues!

    However, the Trunks are still empty. :(

    Jim
     
  6. CleveJ

    Joined:
    Nov 12, 2007
    Messages:
    100
    Likes Received:
    0
    The only way I could get it to show all the Trunks and Extensions was to do the following.

    1. Install Elastix 0.9.1-4
    2. Do all the freePBX updates (dont worry about the symlink error)
    3. Configure Trunks & Extensions
    4. Follow the instructions from this link to get rid of the symlink error. http://www.elastix.org/component/option ... 6/lang,en/
    5. Amportal stop the Amportal start.

    now it comes up with this error, which I still have to find what this is. But if you now go to FOP you can see all your trunks and extensions

    SETTING FILE PERMISSIONS
    chown: cannot access `/var/www/html/recordings': No such file or directory
    chmod: cannot access `/var/www/html/recordings': No such file or directory
    chown: cannot access `/var/www/html/_asterisk': No such file or directory
    Permissions OK

    EDIT

    For the "SETTING FILE PERMISSIONS" error's I had to create the recordings & _asterisk folders in /var/www/html

    Post edited by: Stilllearning, at: 2007/12/13 00:42<br><br>Post edited by: Stilllearning, at: 2007/12/13 15:56
     
  7. gmaoret

    Joined:
    Nov 13, 2007
    Messages:
    50
    Likes Received:
    0
    And how may I do the FreePBX update?
     
  8. CleveJ

    Joined:
    Nov 12, 2007
    Messages:
    100
    Likes Received:
    0
    Goto unembedded FreePBX select the Modules Admin do your update
     
  9. jnickel

    Joined:
    Dec 7, 2007
    Messages:
    15
    Likes Received:
    0
    I performed all the updates from the unembedded FreePBX on all modules.

    Made those two directories and set the ownership on them to be asterisk:asterisk

    Then I restarted asterisk and fop by doing a service asterisk restart and a amportal restart

    I also tried rebooting the machine.

    No Luck...I still don't have trunks - all my extensions and queues show up fine, but not the trunks.

    :(

    Jim
     
  10. gmaoret

    Joined:
    Nov 13, 2007
    Messages:
    50
    Likes Received:
    0
  11. jnickel

    Joined:
    Dec 7, 2007
    Messages:
    15
    Likes Received:
    0
    Got it!

    to fix it =>

    edit the file retrieve_op_conf_from_mysql.pl under the directory: /var/lib/asterisk/bin

    $ vi /var/lib/asterisk/bin/retrieve_op_conf_from_mysql.pl

    in line 21 and 26 change the file name zapata-auto.conf to zapata-channels.conf

    before change:

    if (scalar @ARGV == 2)
    {
    $amportalconf = $ARGV[0];
    $zapataconf = $ARGV[1]."/zapata.conf";
    $zapataautoconf = $ARGV[1]."/zapata-auto.conf";
    } else
    {
    $amportalconf = "/etc/amportal.conf";
    $zapataconf="/etc/asterisk/zapata.conf";
    $zapataautoconf="/etc/asterisk/zapata-auto.conf";
    }

    after change:

    if (scalar @ARGV == 2)
    {
    $amportalconf = $ARGV[0];
    $zapataconf = $ARGV[1]."/zapata.conf";
    $zapataautoconf = $ARGV[1]."/zapata-channels.conf";
    } else
    {
    $amportalconf = "/etc/amportal.conf";
    $zapataconf="/etc/asterisk/zapata.conf";
    $zapataautoconf="/etc/asterisk/zapata-channels.conf";
    }

    I then edited my ZAP trunk in FreePBX and saved it without actually making any changes and they now show up in the FOP!

    Jim
     
  12. lfhuhn

    Joined:
    Oct 30, 2007
    Messages:
    11
    Likes Received:
    0
    Great Job Jim! Worked like a charm. Thanks Larry
     

Share This Page