FIXED - yum update error - Header is not complete

Joined
Jun 11, 2007
Messages
34
Points
0
Re:FIXED - yum update error - Header is not comple

Hi Edgar

Here are my logs after doing a yum update and before rebooting which is when I normally get the Kernel Panic. I noticed that netconfig is being removed during the yum update, is there a reason for this? http://forum.elastix.org/old_files/Logs.zip
 

lek

Guest
Re:FIXED - yum update error - Header is not comple

blapoint,

Can i access your box? You can send me access information to info at elastix dot org
 
Joined
Jun 11, 2007
Messages
34
Points
0
Re:FIXED - yum update error - Header is not comple

Hi Edgar, thanks for all your help but I think I just got it working. In a previose posting you told me to

P.S. If you uninstalled the kernel-module-rhino packages run a "yum install kernel-module-rhino" and "yum install kernel-module-rhino-xen".

I had not removed it but I deceided to install them before doing the yum update and low and behold my system now works. Below are the steps exacly as I did them.

1. Installed Elastix 9.0-14 from ISO.
2. Configured my system as if it were in production.
3. yum install kernel-module-rhino
4. yum install kernel-module-rhino-xen
5. yum -y update
6. reboot
7. system comes up with no Kernel Errors but my R4FXO channels are not working.
8. I looked at the previously configured Zaptel.conf file and it had been changed back to the pre configured state.
8. Reconfigured Zaptel.conf and rebooted.
9. Everything seems fine now.

You are very welcome to access my server if you still need to just let me know and I will send you my credentials.

I am thinking the problem was that kernel-module-rhino and kernel-module-rhino-xen were not installed by default in 0.9.0 - 14.
 

lek

Guest
Re:FIXED - yum update error - Header is not comple

Good!!!

So, everything is working now. Right?
 
Joined
Jun 11, 2007
Messages
34
Points
0
Re:FIXED - yum update error - Header is not comple

I have not tested every aspect yet but this is what I am seeing so far.

1. Voice mail configuration was removed during the yum update and I had to reconfigure voice mail on all extensions.
2. from the monitor page I cannot play the recordings but I can download them.
3. There are symlink errors which were reported in a different thread.
4. Every now and then Asterisk shuts down and is complaining about MP123: No process Killed. I don't know what causes this yet but it has something to do with committing changes made in freepbx. This happened 4 times in about an hour and I was able to restart asterisk using asterisk -r but it has not happened since fixing the symlink errors.
5. Netconfig no longer works, I get the following errors when I try to run it. netconfig: command not found
 
Joined
Nov 27, 2007
Messages
38
Points
0
Re:FIXED - yum update error - Header is not comple

I have similar problems after the update and it almost took me out of commission. This symlink thing and the re-adding the extensions is a pain.

Every update this has happened to me also!
 

Members online

No members online now.

Forum statistics

Threads
30,996
Messages
131,114
Members
17,716
Latest member
Orbit114
Top