fixed problem - trouble receiving voicemail:email

coryjsanders

Joined
Mar 25, 2010
Messages
181
Likes
0
Points
0
#1
I changed my relayhost to relayhost = smtp.west.cox.net
And I changed my Host setting in the Networking tab on the GUI to elastix.cox.net
When I had the Host name set to elastix.myhomeconnection.local, maillog showed that the emails were going out, but out of 3 email addresses I have -- a cox.net and a private domain hosted at 1&1 -- only my hotmail address was receiving the emails. The From address was showing vm@asterisk.myhomeconnection.local and root@myhomeconnection.local, and I figured that 1&1 and Cox would not send them on to me because there is no such domain as a .local. So I changed my Host name in the GUI to elastix.cox.net, and viola, it works. They come to me as Voicemail System [vm@asterisk.cox.net]. Hope this helps someone.
 

magoc

Joined
Mar 11, 2010
Messages
83
Likes
0
Points
0
#2
can u explain how did u fix the problem please ?

thanks
 

coryjsanders

Joined
Mar 25, 2010
Messages
181
Likes
0
Points
0
#3
Sure. In EWT there are three ways described on how to fix your vm:em troubles. p 120-21. What I've done is edit the main.cf file as follows:
relayhost=smpt.west.cox.net ; this is the outgoing server info on my Outlook.
I've also set my Host name under the Networks tab in the GUI to elastix.cox.net
That's it. every time you change your main.cf file in postfix you need to do type

service postfix restart

It will shut down and restart.

I am assuming you know how to use vi. Let me know if not and I'll walk you through it. I also recommend buying linux for dummies. You don't have to read the whole thing. Speed read through P116 and then pay close attention to the layout of the file system. Then pay close attention to p128-168.

Make sure you have an email set on the Extension.

If you can, open up a second SSH session so you can do two things. If you can only open one, or just have a terminal, do this first:

at your prompt type: tail -f /var/log/maillog
this will show you what is happening when you send an email.
Leave a voicemail on an extension where you have voicemail enabled and an email input in the box.
Watch the output on your SSH or terminal. If you get messages that say denied or somethign to that effect, you have not got things set properly. If you get simple lines (should be one for each email sent out) saying email accepted for delivery, you have half the battle won. If emails are going, but you are not getting them, then your ISP is blocking them. Mine was doing this because they were seeing them as coming from elastix.myhomeconnection.local, and .local is not a domain they see as valid. Interstingly enough, hotmail accpted them for relay, but 1&1 and Cox did not.

The other thing you can do if you have two SSH screens open on your desktop or an SSH and a terminal, is have the tail running on one, and on the other type this (to send emials make sure you are at cd /etc/postfix/)

mail <an email address and return>
<type the subject and return>
<this is where you type the body and hit return when done>
. <type the period and you will get a cc:>
<enter your CCs seperated by a comma and hit return>

This will send out the email you just typed.
Switch to your SSH or terminal that is running the tail and watch what you get. It should be telling. Make sure you send to 2 or three addresses, and make sure one of those is your your email with your ISP, and one is a gmail or hotmail or live.com email. You will see that emails you send from the prompt come to you as from root and emails from the voicemail system come vm. If you have a name set in your Extension, it will say, Name, you have a new voicemail...

Make sure you are running 1.6-12. If not burn a new ISO and start over. Not an option for beginners. I hear 2.0 is coming.


Let me know how you do or if this is unclear.
 

magoc

Joined
Mar 11, 2010
Messages
83
Likes
0
Points
0
#4
coryjsanders,
thank you for your answer...

i followed step by step what u said...
and i get this...


May 6 18:56:44 sspsa postfix/qmgr[3820]: CE8C847A05B0: from=<root@seguridadssp.com>, size=332, nrcpt=1 (queue active)
May 6 18:57:15 sspsa postfix/smtp[3915]: connect to mail.seguridadssp.com[69.89.31.201]: Connection timed out (port 25)
May 6 18:57:15 sspsa postfix/smtp[3915]: CE8C847A05B0: to=<h_muruzabal@hotmail.com>, relay=none, delay=30, delays=0.02/0/30/0, dsn=4.4.1, status=deferred (connect to mail.seguridadssp.com[69.89.31.201]: Connection timed out)


how can i solve it ??
 

coryjsanders

Joined
Mar 25, 2010
Messages
181
Likes
0
Points
0
#5
I don't know that I see enough info to help you. I feel your pain. Check your myorigin setting in main.cf. Which line is uncommented, and what does it say? You have your relay host set to your smtp server and it is uncommented? You have your Host setting in the Networking tab of the GUI set to something like elastix.your.provider.com? Because all I see is connect to mail.seguridadadssp.com

If I reply slowly it is because I do not get email notifications. The folks at Palo Santo are looking into the problem. My settings may not work for you. I just moved my box from a cox.net account (residential IP, dynamic) to a cox.com account (business IP, static), and now my Trunk does not work. I have the problem that I've seen here of being able to make an outbound call, but no voice passes either way. And I can not call inbound to my box. I need to talk to my SIP provider tomorrow and also Jorge at Palo Santo (paid support) and find out what is going on! In the mean time, here I go scouring these boards. I'm sure it has somethign to do with my Trunk settings.

I say all that to you because there are many variables with each installation. Look at your settings again in main.cf. Make sure relayhost = <your smtp outgoing server> (watch those spaces! and tell me what your myorigin = setting is.
 

coryjsanders

Joined
Mar 25, 2010
Messages
181
Likes
0
Points
0
#6
magoc, are you still there? how is it going?
 

magoc

Joined
Mar 11, 2010
Messages
83
Likes
0
Points
0
#7
hi !!

i finally solved it... :)
i added " :26 " at end of the relayhost...... anddddd.... everything working !!!!!

thank u for ur help !!!
 

coryjsanders

Joined
Mar 25, 2010
Messages
181
Likes
0
Points
0
#8
Fantastic! What's the :26 for? Did your ISP tell you to put that? Is that a port they are on?
 

magoc

Joined
Mar 11, 2010
Messages
83
Likes
0
Points
0
#9
yeap.... my isp works with port 26... thats why i had to changed it...

i need to ask u another question..

do u know how to change the email layout and the recipient of the fax notification ?

thanksss !!
 

coryjsanders

Joined
Mar 25, 2010
Messages
181
Likes
0
Points
0
#10
I'm sorry to say I do not. But someone else will. Post it in a new thread. Good luck.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top