fix for symlink error

Joined
Jun 14, 2007
Messages
276
Points
0
I have created a script that will take care of the symlink errors in freepbx.

Copy the file to /usr/src
#tar zxvf symlink-correct.tar
#chmod 777 symlink-correct.sh
#./symlink-correct.sh

C
 
Joined
Oct 4, 2007
Messages
275
Points
0
Thanks for the fix. I have just deployed it. I will let you know if it is successful...(so far so good).

Good Job Cowboy47
 
Joined
Oct 30, 2007
Messages
11
Points
0
cowboy47, nice work. I tried the link and steps but it doesn't work for me. It shows symlink_correct.tar for me and when I try that one it fails also. Any suggestions? Larry
 
Joined
Jun 14, 2007
Messages
276
Points
0
I just tested and here is what I found. The tar zxvf did not unzip the file, sooooo.

#gunzip symlink_correct.gz

This will extract a file named "symlink_correct"

Then issue the following:

#chmod 777 symlink_correct
#./symlink_correct


Hope that helps. Sorry for the error before.

C
 
Joined
Oct 4, 2007
Messages
275
Points
0
OK well after 5 days the symlink errors started back up.

I have not done any updates or even program changes.
 
Joined
Jun 14, 2007
Messages
276
Points
0
Are you sure it is the same error? If you click on the error, it will tell you where it failed. I have not seen this reoccur at all.

C
 
Joined
Oct 4, 2007
Messages
275
Points
0
Yes it is the same one(s). I am going to apply the patch again and see if it comes back.

Thanks
 
Joined
Feb 14, 2008
Messages
12
Points
0
Script file is on the first page of this thread.
I tried the script file and still have an error:
"retrieve_conf failed to sym link the /etc/asterisk/extensions.conf file from modules
Added 52 minutes ago
(retrieve_conf.SYMLINK)"

FYI - using lastest Elastix with 'yum update' and FreePBX 2.4.
Below is some of the output:
[root@elastix ~]# cd /usr/src
[root@elastix src]# gunzip symlink_correct.gz
[root@elastix src]# chmod 777 symlink_correct
[root@elastix src]# ./symlink_correct
mv: target `/var/lib/asterisk/bin/retrieve_conf' is not a directory

Checking for PEAR DB..OK
Checking for PEAR Console::Getopt..OK
Checking for /etc/amportal.conf ..OK
Bootstrapping /etc/amportal.conf ..OK
Parsing /etc/amportal.conf ..OK
Parsing /etc/asterisk/asterisk.conf ..OK
Connecting to database..OK
Connecting to Asterisk manager interface..OK
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = elastix456
Use of uninitialized value in string eq at /var/lib/asterisk/bin/retrieve_op_conf_from_mysql.pl line 415.
no crontab for root
no crontab for root
Please update your modules and reload Asterisk by browsing to your server.
mv: target `/var/lib/asterisk/bin/retrieve_conf' is not a directory

Checking for PEAR DB..OK<br><br>Post edited by: mullman, at: 2008/02/16 18:06
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top