file editor - error? - strips backslashes

Discussion in 'General' started by bhp666, Feb 15, 2009.

  1. bhp666

    Joined:
    Feb 15, 2009
    Messages:
    8
    Likes Received:
    0
    Attempting to edit voicemail.conf using the file editor under tools tab under pbx tab.

    specifically the area in the email message body that gives detailed instructions to the person receiving the email.

    after editing a line or two and then saving, i lose this little piece of code that seems to be a line break tag - \n - all i get after saving it is this, n - effectively losing the backslash.

    and sure enough voicemail email messages appear as one line with a bunch of lower case n's where i wanted a line break.

    any ideas?

    i tried different browsers, firefox 3, ie 7 - same results

    thanks, bob
     
  2. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    Have you tried a dual slash in the editor (e.g. \\n)? That MIGHT escape the slash and cause one slash to go into the file.

    Failing that, what I'd do is ssh into the system (using a terminal window on a Linux or Mac box, or Putty on a Windows box) and then type mc to go into Midnight Commander and use its file editor. I'm pretty sure that Midnight Commander is installed with Elastix, but if not, you can probably do "yum install mc" from a command prompt to install it.

    Some people swear by nano as an editor, but you'd also have to be in an ssh session to use that. But I don't think Elastix includes nano, so you might have to use yum to install it, then Google a bit to learn how to use it (not real difficult). I prefer Midnight Commander because that lets you find the file, then click on "edit" or press f4 to edit it.
     

Share This Page