Faxing

veritech

Joined
Jul 16, 2008
Messages
92
Likes
0
Points
6
#1
Sorry about many posts, I am trying to get a good understating of Elastix and its capabilites.

Faxing......

I've got a virtual machine that is being hosted, so I have only ip capabilities. I am trying fax over ip.
I went to the fax menu -> New Virtual fax. Entered name, email, extension, secret, country code and area code.
It got created.

in PBX -> extensions, I created an iax2 extension using the settings from the fax. Fax Extension=disabled, fax email="" fax detection type=None.

In my inbound route, I don't have an IVR setup, I have 1 phone and 1 softphone for testing. My inbound route goes to a ring group that has the 2 phones and my cell (works great!).
If I turn on any features of the fax on the inbound route, my inbound dies and I get a busy signal. I believe that I can still dial out though.

I ssh'ed into the machine and the config for iaxmodem (/etc/iaxmodem/iaxmodem-cfg.ttyIAX1) contains:

device /dev/ttyIAX1
owner uucp:uucp
mode 660
port 40000
refresh 300
server 127.0.0.1
peername 4100
secret <hidden>
cidname
cidnumber
codec slinear


I verified that the IAX extension is also using port 40000.
/var/log/asterisk/full is full of:
[Sep 3 02:54:37] NOTICE[11386] chan_iax2.c: Restricting registration for peer '4100' to 60 seconds (requested 300)

Now somethis is broken as I can't receive any calls. I've tried removing the virtual fax and extension with no luck

Any suggestions on trying to get this feature to work.

Thanks
 

veritech

Joined
Jul 16, 2008
Messages
92
Likes
0
Points
6
#2
I fixed my incoming route and re-did the faxing.

I created an IVR to answer the phone and detect the fax.
my inbound route, has Fax extension = 4100 (the iax extension I created)
fax email=<my email address>
fax detection type=zaptel (if I use NVFax, I get a buy signal calling in).

Tried faxing. No luck


googling all of this is making my eyes cross :-(


I am probably missing 1 little stupid thing.
 

veritech

Joined
Jul 16, 2008
Messages
92
Likes
0
Points
6
#3
Well, I got faxing to work as long as my incoming route went to an extension set to receive a fax.

I still can't seem to get an inbound route to goto the ivr and autodetect a fax or a voice call.

Is there an option to get an inbound route to detect the fax tone and send it to an extension to handle faxes?

Thanks
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#4
On your inbound route set the where it says fax handling
set to freepbx default
Then goto general settings and where it says Extension of fax machine for receiving faxes set it to your fax ext
and set email to send to under general
Also on your inbound route I have the email blank as the general section handles it
For fax detection I use NVfax as it detects in the background for fax tones and have pause set to 6, any lower and found it would miss some faxes

Hope that helps
 

veritech

Joined
Jul 16, 2008
Messages
92
Likes
0
Points
6
#5
I've tried that. If I have NVFax on an inbound route, I get a fast busy signal.

I got it to work by having my inbound route go directly to my fax extension, not the IVR.


Thanks
 

veritech

Joined
Jul 16, 2008
Messages
92
Likes
0
Points
6
#6
After a bunch of searching and diagnostics, I discovered that NVFax is not compiled with asterisk in Elastix.
I checked another Elastix machine, it wasn't there also. I looks like we are supposed to use Zaptel.

So I downloaded the compiled modules from:
http://www.elastix.org/index.php?option ... tid=5#4746
copied them to my /usr/lib/asterisk/modules and rebooted.

Faxing is working great.

Is there anyway to enable colour?

Thanks
 

paulsoddy

Joined
Sep 9, 2008
Messages
12
Likes
0
Points
0
#7
I'm newbie to all this can you please help me with:

1) Do I need to install IAX or SIP Trunk to make this work?
2) Is there a possibility you can send me step by step guide?
 

maumar

Joined
Sep 12, 2008
Messages
80
Likes
0
Points
0
#8
DaveD:

inbound route set to freepbx default
freepbx default set it to your fax iax2 ext
iax2 ext set to? system??

and what card are you using? i have isdn pci card (cologne chip)
 

maumar

Joined
Sep 12, 2008
Messages
80
Likes
0
Points
0
#9
hi veritech
i have the same /etc/iaxmodem/iaxmodem-cfg.ttyIAX1 as you have:
[root@elastix asterisk]# cat /etc/iaxmodem/iaxmodem-cfg.ttyIAX1
device /dev/ttyIAX1
owner uucp:uucp
mode 660
port 40000
refresh 300
server 127.0.0.1
peername 8000
secret 8000
cidname
cidnumber
codec slinear

i am able to reach iax extension as i configured it in inbound route
(i could pass through freepbx default but then this bounce to iax 8000 ext)
 

maumar

Joined
Sep 12, 2008
Messages
80
Likes
0
Points
0
#10
i am unable to redirect iax 8000 ext to iaxmodem port 4000

P[ 1] channel with stid:0 for one second still in use!
-- Executing [22222222@from-pstn:1] Set("mISDN/1-u93", "__FROM_DID=22222222") in new stack
-- Executing [22222222@from-pstn:2] GotoIf("mISDN/1-u93", "0 ?cidok") in new stack
-- Executing [22222222@from-pstn:3] Set("mISDN/1-u93", "CALLERID(name)=11111111") in new stack
-- Executing [22222222@from-pstn:4] NoOp("mISDN/1-u93", "CallerID is "11111111" <11111111>") in new stack
-- Executing [22222222@from-pstn:5] Set("mISDN/1-u93", "FAX_RX=8000") in new stack
-- Executing [22222222@from-pstn:6] Goto("mISDN/1-u93", "app-blackhole|hangup|1") in new stack
-- Goto (app-blackhole,hangup,1)
-- Executing [hangup@app-blackhole:1] NoOp("mISDN/1-u93", "Blackhole Dest: Hangup") in new stack
-- Executing [hangup@app-blackhole:2] Hangup("mISDN/1-u93", "") in new stack
== Spawn extension (app-blackhole, hangup, 2) exited non-zero on \'mISDN/1-u93\'
 

maumar

Joined
Sep 12, 2008
Messages
80
Likes
0
Points
0
#11
i missed in inbound route to set destination to 8000
i set this only in fax section :(

i downloaded NVFax module and now fax does work!
 

paulsoddy

Joined
Sep 9, 2008
Messages
12
Likes
0
Points
0
#12
Gentleman,

I truly appriciate everyone's help to make inbound FAX work so far I have no problem. The best source for Step By Step guide is "Elastix without Tears", Google it you'll find it.

But I had no success sending FAX out of the SIP extension and here the diagram.

NET --> Linksys Router(Public IP) --> Elastix Box (Static IP 192.168.XXX.XXX)
--> Linksys PAP2T (Static IP 192.168.XXX.XXX) --> Brother FAX Machine.

I monitored the log and everytime we send FAX we get this error message. rtp.c: Unable to set TOS to 184.

I searched and found 2 answers.
1) Asterisk need to run as root. (Not possible)
2) configure the firewall.
But when I check Elastix have firewall off by default. So I'm kind of stuck. What should I do next.

Any help would be appricated.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,564
Latest member
Mai Tuyen
Top