fax sent or fail - email confirmation, notify

loanrefi

Joined
Aug 20, 2009
Messages
41
Likes
0
Points
0
#1
Elastix 1.5.2-2.3
AvantFax 3.1.4
FreePBX 2.5.2.2

When I send out a fax and set a request for success confirmation I do receive the email with a PDF attached but the PDF is blank.

I notice that if I fax out a Post Script file instead of a PDF things work! I get the email with the PDF of the file I faxed out.

I'm assuming its an issue with converting the file somehow since I use a client (JHylaFax) to fax out but even if I use a web browser (Firefox) I still get the email with a blank PDF.

The only way its working is to use a Post Script file.

Does anyone know how I can solve this?
Thanks!
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#2
I don't think ghost script is installed by default in Elastix

yum install ghostscript from console should fix the issue as ghostscript is an interpreter for the PostScript language and for PDF

Dave
 

loanrefi

Joined
Aug 20, 2009
Messages
41
Likes
0
Points
0
#3
Well it looks like I already have it installed;

"Package ghostscript-8.15.2-9.4.el5_3.7.i386 already installed and latest version"

I'm still googling.....
 

loanrefi

Joined
Aug 20, 2009
Messages
41
Likes
0
Points
0
#4
I tried a couple of different things;

1)
I was missing "pdf; in /var/spool/hylafax/bin/notify

RETURNFILETYPE=pdf;

But did not fix the problem.

2)
The same file was giving me this error;

FATAL ERROR: $SPOOL/etc/setup.cache is missing!

The file $SPOOL/etc/setup.cache is not present. This
probably means the machine has not been setup using the faxsetup(8C)
command. Read the documentation on setting up HylaFAX before you
startup a server system.

So I ran faxsetup command and accepted all defaults then reboot

But did not fix the problem.

3)
In /var/spool/hylafax/etc I have the file "setup.cache" which has this information;
# Warning, this file was automatically generated by faxsetup
# on Thu Sep 24 10:00:51 CDT 2009 for root
AWK='/usr/bin/gawk'
BASE64ENCODE='/usr/bin/uuencode -m ==== | /bin/grep -v ===='
BIN='/usr/bin'
CAT='/bin/cat'
CHGRP='/bin/chgrp'
CHMOD='/bin/chmod'
CHOWN='/bin/chown'
CP='/bin/cp'
DPSRIP='/var/spool/hylafax/bin/ps2fax'
ECHO='/bin/echo'
ENCODING='base64'
FAXQ_SERVER='yes'
FONTPATH='/usr/share/ghostscript/8.15/lib:/usr/share/ghostscript/8.15/Resource:/usr/share/ghostscript/fonts:/usr/share/fonts/default/ghostscript:/usr/share/fonts/default/Type1:/usr/share/fonts/default/amspsfnt/pfb:/usr/share/fonts/default/cmpsfont/pfb:/usr/share/fonts/japanese:/etc/ghostscript'
FUSER='/sbin/fuser'
GREP='/bin/grep'
GSRIP='/usr/bin/gs'
HFAXD_OLD_PROTOCOL='no'
HFAXD_SERVER='yes'
HFAXD_SNPP_SERVER='no'
IMPRIP=''
LIBDATA='/etc/hylafax'
LIBEXEC='/usr/sbin'
LN='/bin/ln'
MANDIR='/usr/share/man'
MIMENCODE='mimencode'
MKFIFO='/usr/bin/mkfifo'
MV='/bin/mv'
PATHEGETTY='/bin/egetty'
PATHGETTY='/sbin/mgetty'
PATH='/usr/sbin:/bin:/usr/bin:/etc:/usr/local/bin'
PATHVGETTY='/sbin/vgetty'
PSPACKAGE='gs'
QPENCODE='qp-encode'
RM='/bin/rm'
SBIN='/usr/sbin'
SCRIPT_SH='/bin/bash'
SED='/bin/sed'
SENDMAIL='/usr/lib/sendmail'
SPOOL='/var/spool/hylafax'
SYSVINIT=''
TARGET='i686-pc-linux-gnu'
TIFF2PDF='/usr/bin/tiff2pdf'
TIFFBIN='/usr/bin'
TTYCMD='/usr/bin/tty'
UUCP_LOCKDIR='/var/lock'
UUCP_LOCKTYPE='ascii'
UUENCODE='/usr/bin/uuencode'

At this point I'm lost and will star searching again. ????

I still receive the Fax Sent email confirmation with a pdf but Blank.

I forgot to mention that the Fax Visor shows the outbound faxes but only shows the Post Script files not the PDF file attachments.
 

landfiets

Joined
May 20, 2008
Messages
20
Likes
0
Points
0
#5
I have the same problem, and it starte I believe after an update or of freepbx or a yumupdate of elastix. Before that it was fine.
The fax is received by the other party only the confirmation is blank.

It's getting on my nerves, so is there anyone who knows what to do?
or do we need to reinstall the whole thing.
 

t0lik

Joined
Oct 15, 2009
Messages
26
Likes
0
Points
0
#6
Any update on this guys? I'm having similar issue - receiving faxes works fine. When I sent one out, I get blank PDF confirmation, and no fax reaches the destination. I'm also running Elastix 1.5.2. Spent two days trying to figure this out... No updates available.. ghostscript etc all installed. Please let me know if you have any ideas, or found solution.

Thanks!
 

t0lik

Joined
Oct 15, 2009
Messages
26
Likes
0
Points
0
#7
I checked system.cache file, and noticed I had ghostscript path wrong - it was pointing to old 7.14 folder. I manually changed it, but it's still not sending faxes properly. I wonder if ghostscript was not updated "cleanly" and has some config files pointing to old 7.14 folder (I have it in 8.15 dir). is there a way to completely remove ghostscript and reinstall it again?
 

johnme

Joined
Nov 28, 2008
Messages
148
Likes
0
Points
0
#8
Hi

I found this stuff in my quick search.
I'm not sure i will help you but keep them in your records too.


======================================================================
I am getting this error

Failed to create PDF for Archive

I think this is due to file permissions..


Yes,
The probllem is in this:
Code:
mkdirs> Error creating directory /var/www/html/avantfax/faxes/sent
If you want make directory by hand and then should work. At least works for me.

======================================================================
Please check, if the /var/www/html/avantfax/faxes and /var/www/html/avantfax/tmp have the right permissions

# cd /var/www/html/avantfax/
# ls -la
...........
drwxrwx--- 4 asterisk uucp 4096 Oct 20 10:00 faxes
drwxrwx--- 59 asterisk uucp 4096 Oct 30 08:59 tmp

to fix the permissions

# chown -R asterisk:uucp /var/www/html/avantfax/faxes
# chown -R asterisk:uucp /var/www/html/avantfax/tmp
# chmod -R 777 /var/www/html/avantfax/faxes /var/www/html/avantfax/tmp

======================================================================
Thanks guys.. I am able to receive the fax in the INBOX now. Like you said,
I added the lines to the ttyiax.config, changed permissions and I'm good to go.

======================================================================
please can you post the output for this command

ls -la /var/www/html/avantfax/tmp/

I think your /var/www/html/avantfax/tmp have not the right permissions, please see the different.

your output

ls -la /var/www/html/avantfax/tmp
drwxrwx--- 2 asterisk uucp 4096 Dec 1 19:56 .
drwxr-xr-x 13 asterisk asterisk 4096 Dec 1 19:08 ..
...........

the right output

ls -la /var/www/html/avantfax/tmp
drwxrwxrwx 2 asterisk uucp 4096 Dec 2 08:14 .
drwxr-xr-x 3 asterisk asterisk 4096 Dec 2 08:14 ..
...........

Please see 2nd line

to fix it:
chmod -R 777 /var/www/html/avantfax/tmp
chmod -R 777 /var/www/html/avantfax/faxes
======================================================================

I hope something will help you from this stuff...

Hi again
John
 

barbus

Joined
Oct 23, 2009
Messages
4
Likes
0
Points
0
#9
After analysis of my situation I now see that this is my issue as well. Actually the same as t0lik above. The only thing is that I'm not using avantfax, so premissions on avantfax directories have no effect on my problem.

I will try yum reinstall ghostscript ghostscript-fonts and see where it takes me.
 

emenny81

Joined
Nov 5, 2009
Messages
24
Likes
0
Points
0
#10
Im having the same problem, I currently have multitech fax server, so I used the same client app to send faxes and it works fine it just doesnt send out the confirmation email. so when I use the Winfax client it sends the confirmation email but the pdf file is blank.

I would also like to change the confirmation file to say something like the multitech says, like this below

What I really care is about the status, if the sales agent sees it passed we are all good.

Name:
Remote ID:
Port: 5
Fax Number: 1585
Status: fail - fax aborted by remote user, error (b4)

Direction: receive
Number of Pages: 0
Elapsed Time: -1 Seconds
Total Bytes: 0
Email Attachments: 0

Init Time: 11/06/2009 15:52:14
Off Hook Time: 11/06/2009 15:53:47
Connect Time: 11/06/2009 15:53:58
 

emenny81

Joined
Nov 5, 2009
Messages
24
Likes
0
Points
0
#11
Ok guys there's something weird going on, and it points out to be client related, what fax client are you guys using ?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top