fax capability quit working

Joined
May 12, 2010
Messages
1,663
Points
0
dicko said:
Agreed, but In my case it WAS in /usr/sbin, there from the Elastix installation and /usr/local/sbin from my inept installation of hylafax. and i was calling the wrong one.

Neither has he any output at all from /usr/bin/faxstat, so I was suspicious.
Just my 2cents, and you know me, sometimes I don't know when to shut up :)
XDD
 
Joined
Aug 4, 2008
Messages
45
Points
0
Hi ramoncio,
I'm giving this a try but I don't get any output when I try "sqlite3 /var/www/db/fax.db "select * from fax;"". I did go find the fax.db file so I know it's where it's supposed to be. Also when I try "/etc/init.d/hylafax restart" this is my output.

[root@elastix /]# /etc/init.d/hylafax restart
Shutting down HylaFAX queue manager (faxq): FIFO: open: No such device or address
[FAILED]
Shutting down HylaFAX server (hfaxd): [ OK ]
Starting HylaFAX queue manager (faxq): [ OK ]
Starting HylaFAX server (hfaxd): [ OK ]


I don't see anything about faxgetty in the restart however when I did "which faxgetty" it shows the path /usr/sbin/faxgetty so I know it's there. Any thoughts? Thanks, Steve
 
Joined
May 12, 2010
Messages
1,663
Points
0
Have your tried removing all virtual faxes as I told you? After removing the virtual faxes, the fax.db should be empty, this is normal. But sometimes it doesn't. This is why I told you to make sure all faxes were removed from fax.db.
 
Joined
Aug 4, 2008
Messages
45
Points
0
Yes I removed all virtual faxes & just looked again at fax.db using a text editor & the references to the virtual faxes look like they're gone. I do see a long list of past faxes that were received before things broke. I'll go after the next steps now.
 
Joined
Aug 4, 2008
Messages
45
Points
0
Here's the output from the last two commands. Does it look right?

[root@elastix /]# /etc/init.d/iaxmodem restart init q
Starting IAXmodem: [ OK ]


[root@elastix /]# /etc/init.d/hylafax restart
Shutting down HylaFAX queue manager (faxq): FIFO: open: No such device or address
[FAILED]
Shutting down HylaFAX server (hfaxd): [ OK ]
Starting HylaFAX queue manager (faxq): [ OK ]
Starting HylaFAX server (hfaxd): [ OK ]
[root@elastix /]#
 
Joined
May 12, 2010
Messages
1,663
Points
0
Yes. Both services seem to have started ok.
Can you see them with ps aux |grep fax?
 
Joined
Aug 4, 2008
Messages
45
Points
0
Yes,

[root@elastix /]# ps aux |grep fax
adm 17013 0.0 0.0 4480 724 ? Ss 12:51 0:00 /usr/sbin/hfaxd -i hylafax
root 17905 0.0 0.0 3904 680 pts/3 R+ 13:48 0:00 grep fax

I've recreated a virtual fax and the status shows as "on ttyIAX1" on the elastix gui.
 
Joined
Aug 4, 2008
Messages
45
Points
0
Hi Ramoncio & Dicko,

I've made a little progress with the fax issue but could use some help again. After working on & off for days using Ramoncio's steps to get it going I gave up & used dicko's hammer solution. I used "rpm -e --nodeps hylafax" to remove hylafax & then install it using yum. The process went well although there were some warnings below:



Code:
[root@elastix db]# faxsetup

Setup program for HylaFAX (tm) 4.3.3.

Created for i686-pc-linux-gnu on Fri Dec 26 14:18:00 ECT 2008.

Reading cached parameters from /var/spool/hylafax/etc/setup.cache.

Found base64 encoder: /usr/bin/uuencode -m ==== | /bin/grep -v ====
Found Quoted-Printable encoder: qp-encode
Found mimencode for compatibilty: mimencode
Checking system for proper client configuration.
Checking system for proper server configuration.


Warning: /sbin/vgetty does not exist or is not an executable program!

The file:

    /sbin/vgetty

does not exist or this file is not an executable program.  The
HylaFAX software optionally uses this program and the fact that
it does not exist on the system is not a fatal error.  If the
program resides in a different location and you do not want to
install a symbolic link for /sbin/vgetty that points to your program
then you must reconfigure and rebuild HylaFAX from source code.


Warning: /bin/egetty does not exist or is not an executable program!

The file:

    /bin/egetty

does not exist or this file is not an executable program.  The
HylaFAX software optionally uses this program and the fact that
it does not exist on the system is not a fatal error.  If the
program resides in a different location and you do not want to
install a symbolic link for /bin/egetty that points to your program
then you must reconfigure and rebuild HylaFAX from source code.


Warning: /usr/share/ghostscript/fonts does not exist or is not a directory!

The directory /usr/share/ghostscript/fonts does not exist or this file is not a directory.
This is the directory where the HylaFAX client applications expect to
locate font metric information to use in formatting ASCII text for
submission as facsimile.  Without this information HylaFAX may generate
illegible facsimile from ASCII text.


Make /var/spool/hylafax/bin/ps2fax a link to /var/spool/hylafax/bin/ps2fax.gs.


Make /var/spool/hylafax/bin/pdf2fax a link to /var/spool/hylafax/bin/pdf2fax.gs.

Update /var/spool/hylafax/status/any.info.

        HylaFAX configuration parameters are:

        [1] Init script starts faxq:            yes
        [2] Init script starts hfaxd            yes
        [3] Start old protocol:                 no
        [4] Start paging protocol:              no
Are these ok [yes]?

I set up a virtual fax using one of the fax extensions I had previously set up & get " Listening to rings from modem on ttyIAX1"

I've checked to make sure the services are running & it all looks good.

Any suggestions? Thanks, Steve
 
Joined
Oct 24, 2008
Messages
4,099
Points
0
you didn't need to run faxsetup, just follow the "Elastix without Tears" to set up the the faxes and modems.

If /etc/init.d/hylafax restarts without error, you are close.
 
Joined
Aug 4, 2008
Messages
45
Points
0
Hi dicko,

I ran /etc/init.d/hylafax restart & everything is running. I also followed "elastix without tears to set up the virtual fax and extension but still can only get a status on the elastix gui that says "Listening to rings from modem on ttyIAX1". It won't switch over to "Running and idle on ttyIAX1". When I test by sending a fax to the number it just rings & finally fails with busy/no response.
 
Joined
Oct 24, 2008
Messages
4,099
Points
0
sskiba said:
Hi dicko,

I ran /etc/init.d/hylafax restart & everything is running. I also followed "elastix without tears to set up the virtual fax and extension but still can only get a status on the elastix gui that says "Listening to rings from modem on ttyIAX1". It won't switch over to "Running and idle on ttyIAX1". When I test by sending a fax to the number it just rings & finally fails with busy/no response.
Ref:
Code:
http://www.cs.bgu.ac.il/~piavka/hylafax-howto/using.html
3.3-4 particularly

now you have to rewind and do that faxgetty and iaxmodem debugging again because they are not talking to each-other, which I believe has largely been covered here.

(don't you hate that "expert" that got you here? :) , I assume you cancelled his check! )
 
Joined
Aug 4, 2008
Messages
45
Points
0
Hey Dicko,

Just an update to let you know what I had to do to fix my fax issue & then 1 more question.

I ended up reinstalling the elastix on our first box & then did a restore of a working configuration. After a couple of hours of tweaking to get some minor settings set it's all working beautifully again.

Back when our expert asterisk guy came in he was concerned that I logged in as root so he did some security magic & made it so no one could log in as root external to the actual elastix box. We then set up individual user logins. What I realized after all of the hassles was that hylafax (when it was working) would send me reports etc as root. My assumption is that blocking root access is what broke our fax capability.

So finally the question. Is it possible to make a change within hylafax that would allow it to use something besides root or allow it only access as root and that would still allow it to work? I'd still like to block direct root access outside of using the box. Or... is this just not worth the hassle and allowing open root access is not that big a thing?

Thanks, Steve
 
Joined
Oct 24, 2008
Messages
4,099
Points
0
I believe hylafax normally runs as the user uucp.

I do agree with not allowing direct root access, personally I change the port that ssh runs on from 22 to something less likely to be attacked, (in /etc/ssh/sshd_config) which is probably where he spun his "magic" also, then you log in as a regular user and then "su" to root from the shell.
 

Members online

No members online now.

Forum statistics

Threads
30,988
Messages
131,101
Members
17,716
Latest member
Orbit114
Top