FATAL: module zaptel not found

Discussion in 'General' started by dsantiago, Dec 6, 2007.

  1. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
    Hi,

    After yum update, I got this error: "FATAL: module zaptel not found". Also, echo canceller failed.
    I have Elastix 0.9.1-4.


    What can I do?
     
  2. adminad

    Joined:
    Apr 29, 2010
    Messages:
    150
    Likes Received:
    0
    Where did you see this message?

    Do you have the kernel-module-zaptel installed? Please run this command:

    rpm -qa | grep zaptel

    And send us the output
     
  3. blapoint

    Joined:
    Jun 11, 2007
    Messages:
    34
    Likes Received:
    0
    Are you by any chance using a Rhino card. If so I do not know how to fix the issue after the damage has been done but if you want to reload elastix and want it to work using 0.9.1 you can try this..it worked for me.

    1. Installed Elastix 9.0-14 from ISO.
    2. Configured my system as if it were in production.
    3. yum install kernel-module-rhino
    4. yum install kernel-module-rhino-xen
    5. yum -y update
    6. reboot
    7. system comes up with no Kernel Errors but my R4FXO channels did not working.
    8. I looked at the previously configured Zaptel.conf file and found that it had been changed back to the pre configured state.
    8. Reconfigured Zaptel.conf and rebooted.
     
  4. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
    Actually, I am not using any card for FXS or FXO. So, I don't think re-install elastix is a good option. But thanks anyway, blapoint.

    Answer to "rpm -qa | grep zaptel" was:

    kernel-module-zaptel-xen-1.4.5.1-28_2.6.18_8.el5
    kernel-module-zaptel-xen-1.4.6-1_2.6.18_8.el5
    kernel-module-zaptel-1.4.5.1-28_2.6.18_8.el5
    kernel-module-zaptel-1.4.6-1_2.6.18_8.el5
    zaptel-devel-1.4.6-1
    zaptel-1.4.6-1

    Regards
     
  5. lek

    lek Guest

    Ooops, i see your problema now and it's weird.

    You have duplicate versions of the kernel-module-zaptel* packages. Please remove these packages and reinstall again:

    rpm -e kernel-module-zaptel-1.4.5.1-28_2.6.18_8.el5
    rpm -e kernel-module-zaptel-1.4.6-1_2.6.18_8.el5
    rpm -e kernel-module-zaptel-xen-1.4.5.1-28_2.6.18_8.el5
    rpm -e kernel-module-zaptel-xen-1.4.6-1_2.6.18_8.el5

    yum install kernel-module-zaptel
    yum install kernel-module-zaptel-xec

    If the packages complain to be uninstalled use --force (or --nodeps)
     
  6. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
    Edgar,

    Everything was ok, until I wrote "yum install kernel-module-zaptel-xen":

    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages from CentOS-5 - Base
    Finished
    Excluding Packages from CentOS-5 - Updates
    Finished
    Excluding Packages from CentOS-5 - Addons
    Finished
    Excluding Packages from Elastix RPM Repository for CentOS
    Finished
    Excluding Packages from CentOS-5 - Extras
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package kernel-module-zaptel-xen.i386 0:1.4.6-1_2.6.18_8.el5 set to be installed
    --> Running transaction check
    --> Processing Dependency: kernel-xen = 2.6.18-8.el5 for package: kernel-module-zaptel-xen
    --> Finished Dependency Resolution
    Error: Missing Dependency: kernel-xen = 2.6.18-8.el5 is needed by package kernel-module-zaptel-xen

    Additionally, I ran this command:
    rpm -qa | grep kernel
    kernel-2.6.18-53.el5
    kernel-devel-2.6.18-53.el5
    kernel-module-zaptel-1.4.6-1_2.6.18_8.el5
    kernel-module-oslec-0.1-13
    kernel-xen-2.6.18-53.el5
    kernel-module-oslec-xen-0.1-13
    kernel-headers-2.6.18-53.el5

    I see there are "two" kernels?
     
  7. lek

    lek Guest

    Santiago, plese remove any kernel different than 2.6.18-8

    All the Elastix kernel modules (including zaptel) have been compiled against this kernel version. If you change the kernel version they will not work.<br><br>Post edited by: edgar, at: 2007/12/06 23:01
     
  8. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
    Edgar,

    How do I downgrade to kernel 2.6.18-8?
     
  9. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
  10. lek

    lek Guest

    Yes, it will work because you're recompiling zaptel against the new kernel. So, zaptel will work fine.

    But the point is still that upgrading the kernel is not a good idea unless you recompile the zaptel modules :(
     
  11. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
    Yes, you're right. Upgrading kernel is not a good idea, but I learned this the hard way!. I'll have this present now on.
     
  12. lek

    lek Guest

    Santiago,

    I think this could help you in the future: Try to don't run a "yum update" so on, because it will break your box. (It will try to install a new zaptel module)
     
  13. dsantiago

    Joined:
    Aug 28, 2007
    Messages:
    22
    Likes Received:
    0
    Edgar,


    It should be yum update elastix, right?
     

Share This Page