Fallo al actualizar la version 2.8 de freepbx...

Discussion in 'Elastix 2.x' started by arusnet, Jun 29, 2010.

  1. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Pues eso gente, me dió el mismo error en dos centrales.

    Symlink from modules failed

    retrieve_conf failed to sym link:
    /var/www/html/admin/images/application_link.png
    /var/www/html/admin/images/sound_delete.png
    /var/www/html/admin/images/play.png
    /var/lib/asterisk/bin/retrieve_op_conf_from_mysql.pl
    /var/lib/asterisk/bin/retrieve_op_conf_from_mysql.php
    /var/www/html/admin/images/notify_security.png
    /var/www/html/admin/images/notify_notice.png
    /var/www/html/admin/images/notify_delete.png
    /var/www/html/admin/images/notify_update.png
    /var/www/html/admin/images/notify_warning.png
    /var/www/html/admin/images/notify_error.png
    /var/www/html/admin/images/notify_critical.png
    /var/www/html/admin/images/dashboard-sysinfo.png
    This can result in FATAL failures to your PBX. If the target file exists, the symlink will not occur and you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.
    Añadido hace -4392 segundos


    A alguien más le ha pasado? Alguna idea para solucionarlo.

    Gracias...
     
  2. chacon

    Joined:
    Jan 4, 2010
    Messages:
    2
    Likes Received:
    0
    Tengo exactamente el mismo error.
    Y no tengo idea como solucionarlo
     
  3. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    La verdad es que ya he probado algunas soluciones que aparecen en el foro de FreePBx. La más coherente es que son enlaces simbólicos que están cambiados por la actualización y para que funcione hay que borrar los archivos que figuran en el error. En mi caso los he renombrado todos, pero el problema sigue.
    A nadie más le ha pasado?
    Gracias.
     
  4. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    Ese es un error grave el problema esta en que aun no existe solución ya que apenas se acaba de liberar esta versión de FreePBX, por eso es IMPORTANTE que antes de realizar cualquier actualización se pruebe en un servidor que no esté en producción y se averigüe si hay algún error reportado, por el momento lamento comentarles que no se ah reportado solución al problema, esperemos que a lo largo del día se soluciones, y antes de actualizar hay que averiguar.


    saludos
     
  5. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Gracias Augusto, por suerte me paso en dos servidores que no estaban en producción. Y uno de ellos ya lo he reinstalado de cero. El otro esperare a ver si se puede resolver sin reinstalar.

    Saludos,
     
  6. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    He reinstalado todo otra vez. He actualizado hasta la versión 2.7 (que hasta ahora no había dado ningún problema) y otra vez con el mismo fallo!. No será algún módulo de los que se actualizan que no es compatible ni si quiera con la versión 2.7?

    Saludos,
     
  7. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    Intenta esto

    mv /etc/asterisk/sip.conf /etc/asterisk/sip.conf.old
    mv /etc/asterisk/iax.conf /etc/asterisk/iax.conf.old
    mv /etc/asterisk/extensions.conf /etc/asterisk/extensions.conf.old
    mv /etc/asterisk/features.conf /etc/asterisk/features.conf.old
    mv /var/lib/asterisk/bin/fax-process.pl /var/lib/asterisk/bin/fax-process.pl.old
    /var/lib/asterisk/bin/retrieve_conf

    despues de en la barra rosa
     
  8. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Efectivamente Augusto, seguí tus instrucciones y en el error desaparecían los avisos del FreePBX. Así que también renombre todos los que ponía en el mensaje de error y problema resuelto!.
    Muchas gracias por la ayuda.

    Saludos,
     
  9. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    PAra eso estamos, prueben si con esto solucionan en problema en la version 2.8 tambien

    saludos
     
  10. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Pues he probado el arreglo con la version 2.8 y el problema en esta versión es que no se reconoce el comando retrieve_conf (dice comand not found) y por esa razón no llega a actualizar.
     
  11. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Bueno, al final aparecieron unas actualizaciones en FreePBX y con ellas se arreglaron todos los problemas. Por supuesto, antes he renombrado todos los archivos en cuestión. Desconozco si se arregla solo con las actualizaciones.
    Saludos,
     
  12. dariohimo

    Joined:
    Jun 12, 2007
    Messages:
    297
    Likes Received:
    1
    tengo elastix 1.6.2-7 empece actualizando freepbx primero framework y despues empece por version primero todo 2.5 despues 2.6 pero me salieron modulos con erros. revise la ruta
    /var/www/html/admin/modules y cada modulo lo renombre el directorio. y con esto empezo a instalar los modulos.
     
  13. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Hola dariohimo, con las últimas actulizaciones de FreePBX se han solucionado todos problemas que daba. Ya hice varias actualizaciones desde la 2.5 hasta 2.8 sin problemas.

    Saludos,
     

Share This Page