Exts offline / unknown overnight

Discussion in 'General' started by Chilling_Silence, Nov 22, 2009.

  1. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    Hi guys,

    posting from my iPhone so apologies this is brief.

    Have a client with issues of phones dropping offline overnight. It seems random which one will.
    Phones are Netcomm V90.

    Here's the status page I wrote output:
    Code:
    
    Asterisk Peers (All should show "OK" if the Ext is online)
    
    Name/username              Host            Dyn Nat ACL Port     Status               
    301/301                    210.86.26.39     D   N      5060     OK (131 ms)           
    221/221                    (Unspecified)    D   N      0        UNKNOWN              
    220/220                    (Unspecified)    D   N      0        UNKNOWN              
    212/212                    (Unspecified)    D   N      0        UNKNOWN              
    211/211                    192.168.2.252    D   N      5060     OK (64 ms)           
    210/210                    (Unspecified)    D   N      0        UNKNOWN              
    209/209                    121.98.130.93    D   N      1025     OK (96 ms)           
    208/208                    (Unspecified)    D   N      0        UNKNOWN              
    207                        (Unspecified)    D   N      0        UNKNOWN              
    206/206                    (Unspecified)    D   N      0        UNKNOWN              
    205/205                    (Unspecified)    D   N      0        UNKNOWN              
    204/204                    121.98.136.121   D   N      5060     OK (47 ms)           
    203/203                    (Unspecified)    D   N      0        UNKNOWN              
    202/202                    192.168.2.251    D   N      5060     OK (107 ms)           
    201/201                    192.168.2.250    D   N      5060     OK (108 ms)           
     
    
    Asterisk SIP Trunk status (All should be "Registered")
    
    Host                            Username       Refresh State                Reg.Time                 
    2talk.co.nz:5060                099680535          105 Registered           Mon, 23 Nov 2009 08:21:59
    2talk.co.nz:5060                095290045          105 Registered           Mon, 23 Nov 2009 08:21:58
    2talk.co.nz:5060                095290040          105 Registered           Mon, 23 Nov 2009 08:21:58
    2talk.co.nz:5060                099680538          105 Registered           Mon, 23 Nov 2009 08:21:58
    2talk.co.nz:5060                099680536          105 Registered           Mon, 23 Nov 2009 08:21:59
    2talk.co.nz:5060                094791212          105 Registered           Mon, 23 Nov 2009 08:21:59
    2talk.co.nz:5060                094444588          105 Registered           Mon, 23 Nov 2009 08:21:58
    2talk.co.nz:5060                099680534          105 Registered           Mon, 23 Nov 2009 08:21:58
    2talk.co.nz:5060                099680537          105 Registered           Mon, 23 Nov 2009 08:22:01
    2talk.co.nz:5060                094761212          105 Registered           Mon, 23 Nov 2009 08:21:58
     
    
    Asterisk channel status
    
    Peer             User/ANR    Call ID      Seq (Tx/Rx)  Format           Hold     Last Message   
     
    
    
    they're using what I'd call a non-standard router, but it seems stable and connected, calls still reach Elastix inbound.

    Any thoughts / help / ideas appreciated

    cheers


    chill
     
  2. rphenix

    Joined:
    Feb 25, 2009
    Messages:
    25
    Likes Received:
    0
    A few things to check:
    use tcpdump/tshark from the elastix box and see if the phones are attempting a re-register when they are showing as offline.

    Is anything possibly coming on the network to conflict with the pbx's IP address?

    Is the PBX multi-homed? If so is it possible that several network interfaces on the pbx can be accessed from the the same LAN? If this is the case you might be having ARP problems try this as a quick test:
    /bin/echo 1 > /proc/sys/net/ipv4/conf/all/arp_filter
    then reboot the phone to clear its arp cache and wait..
     

Share This Page