externhost is blocking my SIP TRUNKS

Discussion in 'General' started by inSync, Jul 27, 2010.

  1. inSync

    Joined:
    Jul 22, 2010
    Messages:
    7
    Likes Received:
    0
    Hello, forum!

    First of all a big thank you for Elastix. It is a pleasure configuring and working with it as a main telephone system at my office.

    now, lets get to work :

    I have elastix 1.6 and 8 local extensions. I want to connect 2 remote extensions so I did port forwading on my router, did nat=yes on my extensions (all of them got it) and last but not least I went to sip_nat.conf and wrote:

    -=-=-=-
    nat=yes
    externhost=myelastix.no-ip.info
    localnet=10.0.0.0/255.255.255.0
    externrefresh=120
    -=-=-=-

    With this setting, my remote extensions can connect and have two way audio when using a GSM Trunk as well as my mISDN Trunks. But with externhost enabled, the connection with my two SIP trunks (voipdiscount, lowratevoip) is lost!

    If I # the externhost option, then my asterisk connects with my SIP Trunks but I have one-way or no-way audio to my remote extensions.

    my sip trunk PEER Details are:

    =-=-=-=-=-
    nat=yes
    allow=gsm&ulaw&alaw
    auth=md5
    disallow=all
    host=sip.voipdiscount.com
    qualify=yes
    secret=secret
    type=peer
    username=username
    =-=-=-=-=-=-

    and of course the register string is user:pass@sip.voipdiscount.com

    ---

    So, what is happening, my dear experts???

    (Greetings from Greece)

    Iannis
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    What is going wrong for you is that you forgot to RTFM :)

    There is a priority in how codecs are allowed

    first you :-

    allow=gsm&ulaw&alaw

    but then you :-

    disallow=all

    at that point in time then you have no allowed codecs, Aristotelian logic, no?

    reverse the order of those two statements to resolve (and then RTFM, before you post your next "problem" )


    dicko
     
  3. inSync

    Joined:
    Jul 22, 2010
    Messages:
    7
    Likes Received:
    0
    I changed the order (although there were no problems with my audio at least with local extensions) but no change with sip trunks when i uncomment externhost.

    Can you please tell me which part of the "fine" manual resolves my "problem"? I ve read elastix without tears many many times, and I follow the guide, that's what leads me to the issues...

    Thanks for the interest :)
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Extension to Extension calls don't use trunks, inboun d and outbound calls are also in different contexts. If it helps and from another manual, perhaps start with:-

    http://www.voip-info.org/wiki/view/Asterisk+contexts

    You could search the forums here for voipdiscount and perhaps find


    http://www.elastix.org/component/kunena ... g=en#56035


    Another good manual is google, try:-

    http://letmegooglethatforyou.com/?q=sip ... risk+setup

    there are a few posts there concerning voipdiscount settings, The articles at nerdvittles are usually pretty good as a FM too.

    dicko

    (I always assume that the M is plural)
     
  5. inSync

    Joined:
    Jul 22, 2010
    Messages:
    7
    Likes Received:
    0
    Thanks for the links and your time generaly, but I think I have not made you understand my problem.

    My SIP Trunk Settings seem to be fine. I have tried all the SIP Trunk settings variations for betamax (voipdiscount, lowratevoip etc) and when I have externhost commented (with #), my asterisk registers with the sip trunks and I am able to make calls. But then my REMOTE EXTENSIONS connect but there is no sound when I place a call.

    When i UN-comment the externhost, my REMOTE EXTENSIONS CAN!!! connect to the my asterisk, THEY CAN call using mISDN Trunks BUT asterisk does not register to my sip trunks ( when I do asterisk -r and "sip show peers" the sip trunks are "UNREACHABLE")


    EDIT : Adding qualify=no on sip trunk settings fixes the issue!!! :D
     
  6. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I'm glad you got it figured out.

    I would like to also point out that " # " is NOT the comment character in asterisk config files it is " ; " The hash character will "include" the following file if it exists at that point in the pasrse process

    dicko
     
  7. inSync

    Joined:
    Jul 22, 2010
    Messages:
    7
    Likes Received:
    0
    Cr@p ... qualify=no just shows offline trunks as online so... :( no success :(
     
  8. inSync

    Joined:
    Jul 22, 2010
    Messages:
    7
    Likes Received:
    0
    After a long time (4 months) I finally figured out what the problem was

    On some routers, there is an option for "ALG" .. on this specific router there was SIP ALG and it is supposed to help do sip calls without forwarding etc... but in our case it breaks connectivity of our asterisk with the sip trunks .

    I deselected it, un-commented my externhost and ... voilla !!! it is working :D
     

Share This Page