Errors after upgrading to kernel 2.6.28.7

Discussion in 'General' started by pedropolian, Mar 2, 2009.

  1. pedropolian

    Joined:
    Mar 2, 2009
    Messages:
    20
    Likes Received:
    0
    I've just installed kernel 2.6.28.7 in pure Elastix 1.3. When I start the system there are 2 failed process :

    Missing /dev/zap

    Echo Canceller [FAILED]

    I wan to know what are the disadvantages of not having each of the 2 processes working.

    Thanks in advance,
    Pedro
     
  2. Redfone

    Joined:
    Jul 12, 2007
    Messages:
    177
    Likes Received:
    0
    Zaptel/Dahdi is compiled per Kernel version. They would need to be re-installed, from source, not RPM packages to work with this kernel. Lack of Zaptel/Dahdi is the reason why you are seeing both of these errors.

    Disadvantages of not having them installed; No TDM hardware support (t1, e1, fxo, fxs, etc). And no timing source for voicemail, conferencing and other applications that require a timing source which is provided by Zaptel/Dahdi.
     
  3. pedropolian

    Joined:
    Mar 2, 2009
    Messages:
    20
    Likes Received:
    0
    I was reading and I found Zaptel/Dahdi last version is only for kernel 2.6.27 right?

    So I can´t use any fxo target or ATA with FXO ports ? :eek:hmy:

    I have been working with kernel 2.6.28 and I've been using an ATA with FXO and I can make calls to the PSTN but I can't make calls from the PSTN to the internal voip network. That would be because I dont' have Zaptel/Dahdi ??

    Pedro
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Pedro, you are a bit confused.
    An ATA doesn't use zaptel/dadhi, it uses SIP to "talk" with asterisk.
    You will need ztdummy as a timing source for conferences and IVRs, but no other zaptel module.
    If you can't receive incoming calls might be a configuration problem.
     
  5. pedropolian

    Joined:
    Mar 2, 2009
    Messages:
    20
    Likes Received:
    0
    ok thanks for the answers

    Sorry yes I'm confused with this packages and modules..I've never heard about :p

    So, for kernel 2.6.28 is there a zaptel package I can install?

    Pedro
     
  6. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    As Redfone told you, if you want to install it you have to compile it from source.
    But you will need to patch the source with the oslec patches if you want that echo canceller.
    The prebuilt rpms include some patches to support more TDM hardware, oslec, and some other tweaks.
    If I were you I would install a stock kernel again and forget about problems.
     
  7. pedropolian

    Joined:
    Mar 2, 2009
    Messages:
    20
    Likes Received:
    0
    I think that stock kernel you mean kernel 2.6.18-8 again?

    I need to have a kernel up to 2.6.20 in order to run elastix with "Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)" because with the default kernel 2.6.18-8 that comes with elastix it doesn't work.

    Pedro
     
  8. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I recommend you to plug another supported network card in a free pci or pci-e slot.
    It is much easier than recompiling asterisk and zaptel with all needed patches.
     

Share This Page