error very missing repository

Joined
Apr 10, 2008
Messages
3
Points
0
Ok and thanks for your help.

I look you installation for centos 5.0 and is missing few questions.

System for install from Centos 5.1 to 5.0

1.-
rpm -qa | grep kernel
2.- delete kernels no need with
rpm -vv -e kernel-here the name of the kernel
3.- Install old kernel
rpm -ivh --force kernel-* --nodeps --oldpackage
in centos the kernel maybe need to be:
kernel-xen-2.6.18-8.1.8.el5.centos.plus.x86_64.rpm
kernel-xen-devel-2.6.18-8.1.8.el5.centos.plus.x86_64.rpm
4.- make
nano /etc/yum.conf
and add
exclude=kernel*
this make no update kernel with yum

5.- make
nano /etc/sysconfig/kernel
an look is this:

# DEFAULTKERNEL specifies the default kernel package type
DEFAULTKERNEL=kernel-xen
REBOOT the server


login root and make:
rpm -qa | grep kernel
Look there is kernel-xen-2.6.18-8.el5

make:
and need to log
2.6.18-8.el5
If not the installation is round

make:
yum clean packages
this delete all cached packages

and final make:

yum install elastix php-sqlite3 php-mysql asterisk-addons asterisk-devel asterisk-perl asterisk-sounds-es asterisk-sounds-fr cyrus-imapd openfire tftp-server perl-Data-UUID perl-HTML-TokeParser-Simple perl-Mail-IMAPClient perl-DateManip perl-XML-Parser perl-Archive-Zip perl-MailTools perl-Net-Telnet perl-suidperl perl-WWW-Mechanize RoundCubeMail fxload
The only problem the system give in the end:
Error: Missing Dependency: kernel-module-oslec-xen is needed by package zaptel
Error: Missing Dependency: kernel-module-oslec is needed by package zaptel
Error: Missing Dependency: kernel-module-zaptel is needed by package zaptel
Error: Missing Dependency: kernel-module-zaptel-xen is needed by package zaptel
Where is all this kernels in your repository???
is not possible end the installation and I try to install manual this rpm and I get:
error: Failed dependencies:
kernel-xen = 2.6.18-8.el5 is needed by kernel-module-zaptel-xen-1.4.9.2.xpp.r5517-3_2.6.18_8.el5.i386

and if I make quote]nano /etc/yum.conf[/quote] and delete the line
exclude=kernel*
I get in this time:

Error: Missing Dependency: kernel-xen = 2.6.18-8.el5 is needed by package kernel-module-zaptel-xen
where I get the correct kernel 2.6.18-8.el5 and the missing rpm

where is possible I download all this rpm and install and end the elastix installation or in other case how you solve this??
:huh:

thanks in advance<br><br>Post edited by: gineta, at: 2008/04/12 07:13
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top