eMailing of Voicemail

Discussion in 'General' started by zharvek, May 8, 2007.

  1. zharvek

    Joined:
    May 7, 2007
    Messages:
    2
    Likes Received:
    0
    Hello guys, I found Elastix while looking for other alternatives to Trixbox, and I have to say, that I really love the look.

    I have everything working correctly, but I cannot seem to get the voicemails sent to my email. I have a exchange server running on another system, and it is working fine. I have turned off all of the spam detection but still nothing.

    Does anyone have some tips for getting the emails working from voicemail? I have updated the system using yum update and installed all of the available updates.

    Is there something I am missing? Thanks guys!
     
  2. ceres

    Joined:
    Apr 23, 2007
    Messages:
    5
    Likes Received:
    0
    Your exchange server may not be setup to relay smtp traffic. If you have a computer on the same subnet as your elastix box, start a command prompt and telnet to your exchange server on port 25 (or whatever port you are using for smtp if you have a non-standard setup), ie telnet server_name 25

    If you get a helo message from exchange's virtual smtp server then you likely have a configuration problem on the elastix box. If you get "connection failed" or anything similar, then exchange's virtual smtp server is set to restrict smtp relay or disallow it all together.

    If relay access is disallowed altogether a good security practice would be to allow smtp traffic to be relayed for a specific host or IP address (such as your elastix box).

    Hope that's of some help
     
  3. zharvek

    Joined:
    May 7, 2007
    Messages:
    2
    Likes Received:
    0
    Hi, just found my problem after playing around. This is and was not a Asterisk problem, but I suspected that.

    For postfix, I setup the relayhost parameter to be my exchange server, and asterisk is configured correctly.

    The problem was with postfix, I had to do this to get it working...

    cd /etc/postfix (change to postfix directory)
    postmap virtual (run postmap virtual to create the virtual.db file)

    Now it works great! Maybe this needs to be done after the initial setup?
     

Share This Page