Elastix2.0 recieving DTMF issue, SIP Trunk

Discussion in 'General' started by Elastix20, Aug 20, 2010.

  1. Elastix20

    Joined:
    Aug 20, 2010
    Messages:
    2
    Likes Received:
    0
    I just installed a Elastix2.0, and the whole working envorinment as follows:

    [PSTN]=====[E1 Trunk]=====[CISCO Gateway]====[SIP Trunk]====[Elastix2.0 Virtual Machine]=======[Eyebeam Softphone]

    with above scenario, i can do:

    1. Eyebeam softphone extensions can call each other.

    2. PSTN user can dial in through [E1 Trunk], and Eyebean softphone can answer the calls.

    3. Eyebeam softphone can dial out to PSTN numbers, in addtion to PSTN IVR system, and make IVR menu selection.

    4. I also setup IVR in Elastix2.0 system, as well as a "Misc Application" point to the IVR, eyebeam softphone extension can
    dial to the "Misc Application" and the IVR work normal, can recieve the extension DTMF input.

    but the problem is:

    the PSTN user dial in the Elastix2.0 IVR, the IVR can not recieved the PSTN user's DTMF input.

    One thing i can confirm: the CISCO Gateway do transfer DTMF normally, since when Gateway route the SIP calls to another
    non-Elastix PBX, the non-Elastix PBX IVR can recieve the DTMF input.

    Can anyone help me?

    Thanks
     
  2. Awesomo

    Joined:
    Nov 5, 2009
    Messages:
    32
    Likes Received:
    0
    Did you define the dtmf type in peer details on the trunk between your elastix install and the cisco gateway?

    dtmfmode=rfc2833
     
  3. Elastix20

    Joined:
    Aug 20, 2010
    Messages:
    2
    Likes Received:
    0
    I don't know what happened, my question has been posted two times. really sorry for that!!!!


    For the question i posted, i just find out the solution.

    In CISCO gateway, i use:

    dtmf-relay sip-notify

    when i change it to:

    dtmf-relay rtp-nte

    the IVR work normal now.

    Attention please, in Elastix2.0 SIP trunk setting, i have used "dtmfmode=info" to map the CISCO gateway setting, but it seems dtmfmode=info does not work.
     

Share This Page