Elastix with Sangoma A500 install

Discussion in 'General' started by mbedzymt, Apr 14, 2011.

  1. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi Guys

    Please shed a light on the following problem that i am experiencing:

    I have installed Elastix on my server which have Sangoma A500. I have installed wanpipe drivers for this device and followed all steps mentioned on http://wiki.sangoma.com/sangoma-wanpipe ... sk_install successfully, bjt the problem is that when i go to Elastix front end and click on SYSTEM, Hardware Detector, Elastix does not detect Sangoma A500. It gave me the following error message
    "No cards were detected on your system. Please press the "Detect New Hardware" button to detect new hardware."

    But when i go to BACKEND and type dmesg it gave me the following output.

    wanpipe: AFT-A500-SH PCI ISDN BRI card found (HDLC rev.35), cpu(s) 1, bus #10, slot #9, irq #10
    wanpipe: Allocating maximum 2 devices: wanpipe1 - wanpipe2.
    WANPIPE: TDM Codecs Initialized
    WANPIPE(tm) Socket API Module 3.5.19.0 (c) 1994-2010 Sangoma Technologies Inc
    NET: Registered protocol family 25
    WANPIPE(tm) WANEC Layer 3.5.19.0 (c) 1995-2006 Sangoma Technologies Inc.

    wanpipe1: Locating: A500/B700 card, CPU A, PciBus=10, PciSlot=9
    wanpipe1: Found: A500/B700 card, CPU A, PciBus=10, PciSlot=9, Port=0

    I am really not sure if there is something i can do so that this device will be detected by Elastix on front end.

    i have already configured IM and don't want to roll back.

    Please advice ASAP.

    Thank you in advance.
    Muks
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    On first place, you must first try with all packages that comes in your Elastix server, dont install any other package from other sources (just leave this as last option).

    Try to configure the card, running the following command:
    wancfg_dahdi

    If you have any issue, install elastix on a test server (with the sangoma card attached), and follow these steps:

    1. yum update elastix -y
    2. yum update elastix-* -y
    3. yum update -y
    4. reboot your server
    5. wancfg_dahdi
     
  3. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi

    Thanks for your reply, But when i tried that i get the following error message:

    # wancfg_dahdi


    ###################################################################
    # SUMMARY #
    ###################################################################



    No Sangoma voice compatible cards found/configured

    I have also updated the server and still get the same message.

    See if you can assist further.

    Thanx once again.
     
  4. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Execute lspci
    It will reveal you if your card is detected by the kernel.
    Else try switching your card into another PCI slot
     
  5. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi there

    thanx for replying

    the results for lspci -v is as follows:

    04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5786 Gigabit Ethernet PCI Express (rev 02)
    Subsystem: Lenovo Device 1015
    Flags: bus master, fast devsel, latency 0, IRQ 74
    Memory at d0100000 (64-bit, non-prefetchable) [size=64K]
    Expansion ROM at <ignored> [disabled]
    Capabilities: [48] Power Management version 3
    Capabilities: [50] Vital Product Data
    Capabilities: [58] Vendor Specific Information: Len=78 <?>
    Capabilities: [e8] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Kernel driver in use: tg3
    Kernel modules: tg3

    0a:09.0 Network controller: Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card
    Subsystem: Device a500:3500
    Flags: bus master, medium devsel, latency 255, IRQ 66
    Memory at d0200000 (32-bit, non-prefetchable) [size=64K]


    I have tried to re-install wanpipe drivers but still i can not detect the card on Elastix front end.

    Please shed a light as this starts to be my biggest worries now.

    Regards
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Have you already tried wancfg_dahdi on a new installed Elastix server? I mean without changing drivers or anything? Just using the included packages?
     
  7. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi there

    Thanx for the reply.

    I tried that and i am getting the error message below:

    ###################################################################
    # SUMMARY #
    ###################################################################



    No Sangoma voice compatible cards found/configured

    [root@muks asterisk]#

    I am stuck here, i tried to re-install the sangoma drivers as suggested by someone from sangoma support but it did not work.

    Any idea what can i do now?

    The device and drivers can be viewed in backend but can not be detected by elastix front end.

    Thanx in advanced.
     
  8. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi Guys

    ANY advice regarding my problem that i am experiencing ABOVE? i have tried to re-install this but without any LUCK, Is there anything i can do. I am reaching the deadline sooner and i want this Elastix free PBX to work ASAP.

    Your urgent assistance / reply will be greatly appreciated.

    Thank you in advance.
     
  9. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi Guys

    Will my Sangoma A500 BRI card work perfectly if it can only be viewed when i used lspci -v command and in elastix fron end is giving the following error message "No cards were detected on your system. Please press the "Detect New Hardware" button to detect new hardware."

    Please advice as i am new on Elastix, or can i try other flavour that is compatible with the sangoma card?.

    Thanx in advance.
     
  10. Lee Sharp

    Joined:
    Sep 28, 2010
    Messages:
    332
    Likes Received:
    0
  11. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi Lee Sharp

    The following is the results for uname -a

    2.6.18-238.12.1.el5 #1 SMP Tue May 31 13:23:01 EDT 2011 i686 i686 i386 GNU/Linux

    Since you adviced that i am not loading the module, let me try something once again or advice if there is any other way to load it.

    Thank you very much
     
  12. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi Guys

    I have changed my /etc/grub file to use 2.6.18-194.3.1.el5 as my default kernel. See below results of uname -a now.

    [root@muks wanpipe-3.5.20]# uname -a
    Linux muks 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:09:10 EDT 2010 i686 i686 i386 GNU/Linux

    But when i go to elastix front end and press the detect hardware button, it still giving me the same error message "No cards were detected on your system. Please press the "Detect New Hardware" button to detect new hardware."

    Please advice what can i do next to resolve this issue as it is becoming extremely important now. i am reaching my deadline soon.

    Your urgent assistance in this regard will be greatly appreciated.

    Thanx in advance.
     
  13. mbedzymt

    Joined:
    Apr 11, 2011
    Messages:
    62
    Likes Received:
    0
    Hi Guys

    I have changed my /etc/grub file to use 2.6.18-194.3.1.el5 as my default kernel. See below results of uname -a now.

    [root@muks wanpipe-3.5.20]# uname -a
    Linux muks 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:09:10 EDT 2010 i686 i686 i386 GNU/Linux

    But when i go to elastix front end and press the detect hardware button, it still giving me the same error message "No cards were detected on your system. Please press the "Detect New Hardware" button to detect new hardware."

    Please advice what can i do next to resolve this issue as it is becoming extremely important now. i am reaching my deadline soon.

    Your urgent assistance in this regard will be greatly appreciated.

    Thanx in advance.
     
  14. james.zhu

    Joined:
    Feb 13, 2008
    Messages:
    99
    Likes Received:
    0
    hi:
    I think sangoma should be no problem with ealstix. have you tried resinstall elastix and have a try with card.
     

Share This Page