Elastix unable to receive calls (possible DNS Issu

Discussion in 'General' started by EricLomm, May 19, 2009.

  1. EricLomm

    Joined:
    May 19, 2009
    Messages:
    20
    Likes Received:
    0
    Hello,

    This is the second time I have attempted to post this message, apparently while I was typing it before I was automatically logged out of the forum.

    I am not sure if this is even the correct place to be posing this question, but since the product we are installing is Elastix I will start here.

    This morning when I showed up at work my boss asked me to start looking at whether we had our DNS information for the Elastix box he was installing was correct.

    What I know is that my boss said that he can make calls out with Elastix, but Elastix Cannot receive calls. He asked me to look at our DNS server to make sure the stale entries for a previous box that had the same internal IP address was removed.

    Then he asked me to make sure that the DNS was setup correctly for the Elastix box. He gave me some documentation for another software package that is installed on Ubuntu but our Elastix is installed on CentOS and the information in the document makes no sense to me.

    I have tried to do searches on information for testing or troubleshooting DNS in CentOS but have not been able to find wht I need.

    Can someone please point me int the direction of finding documentation on how to make sure the DNS is setup to properly work with CentOS

    Thank you
     
  2. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    EricLomm,

    You may be going up the wrong path to resolve your issue, however there is nothing wrong with checking that everything else is setup correct.

    The DNS Settings are set via Web GUI under the NETWORK tab. These settings are written to the config files in the OS.

    This file that it writes to is the /etc/resolv.conf file which should contain one or two nameservers. It is preferable to use the GUI to set these.

    Another test to check that your DNS is working is to go to the Linux Console (either directly to the screen connected to Elastix, or via SSH (Putty) and try pinging some common domain names (e.g. www.google.com) and confirm it comes back with an IP address. At this point you can confirm that DNS is working, at least satisfactorily for the Elastix system.

    Now if you want to check that IP Addresses are set correctly, again preferable that it is done via the GUI, but if you want to check that the config files are written correctly (via the console/SSH), then check /etc/sysconfig/network-scripts/ifcfg-eth0 (assuming that you have one network card in the system) and review this file. It should look like the following

    # Intel Corporation 82540EM Gigabit Ethernet Controller
    DEVICE=eth0
    BOOTPROTO=static
    DHCPCLASS=
    HWADDR=00:06:5B:C8:9F:91
    ONBOOT=yes
    TYPE=Ethernet
    IPADDR=192.168.0.100
    NETMASK=255.255.255.0
    BROADCAST=192.168.0.255
    NETWORK=192.168.0.0
    NOZEROCONF=yes

    Naturally your IP addresses will differ, but you get what I am referring to.

    And finally,
    /etc/sysconfig/network contains your Gateway settings, again set via the GUI.

    You can check all of these and confirm that the right settings have been set.

    This will remove one variable out of your equation and allow you (hopefully) discount the network/DNS/gateway as the source of your issue, especially as outgoing calls are working which relies on these settings being correct (I am assuming that you are using a SIP/IAX connection in this discussion). Furthermore, the fact that outgoing calls are working, shows that generally you have a registration with a SIP/IAX provider.

    So what next, how long is a piece of string??? There can be many issues, and we should confirm that you indeed have a SIP/IAX connection otherwise a good part of this message is off target.

    The most probably causes are

    1) Incoming route not set correctly (e.g. based on CLID) with no route
    2) NAT issue with router not allowing calls in (ports not open etc).

    Can you reveal more on your system such as SIP/IAX connection, what incoming route, can you ring extension to extension, can you provide a excerpt from the logs showing the call coming in (if it is).

    Regards

    Bob
     
  3. EricLomm

    Joined:
    May 19, 2009
    Messages:
    20
    Likes Received:
    0
    Hello Bob,

    Thanks for the help. with your help I was able to check all the DNS info and make sure it was setup correctly. However we are still not able to receive inbound calls.

    We are migrating to elastix from an existing trixbox system.

    Our VoIP provider is vitelity and we have two extra lines available through vitelity that we have setup to elastix to make sure it is working correctly befor we complete the migration. We have setup a seperate nat for these additional lines.

    We are able to dial out and dial extension to extension. We are just not able to receive incoming calls on this on Elastix.

    Below is the vitel-inbo configuration with the username nad password changed.

    Code:
    type=friend
    username=genericuser
    secret=genericpassword
    insecure=very
    context=from-trunk
    canreinvite=no
    host=inbound2.vitelity.net
    disallow=all
    allow=ulaw
    
    
    Here is the registration string with the same change

    Code:
    genericuser:genericpassword@inbound2.vitelity.net
    
    finally here is the vitel-outbo configuration with the username nad password changed.

    Code:
    type=friend
    username=genericuser
    secret=genericpassword
    fromuser=genericuser
    trustrpid=yes
    sendrpid=yes
    context=from-trunk
    canreinvite=no
    host=outbound1.vitelity.net
    disallow=all
    allow=ulaw
    
    I am not sure how to the logs so to post those I would need instructions on how to find them.
     
  4. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    EricLomm,

    I assume that from your statement that you have multiple IP addresses on your router. Otherwise you would not be able to NAT to the Elastix system. Furthermore you need to make sure that your outbound registration from the Elastix system is going out via the correct IP address.

    When it registers with Vitelity, it picks up the IP address that you are registering from and naturally will return back to that IP address, which would be the incorrect one, and it would go back to the Trixbox, which would reject the call.

    Note the above does not apply if you are using different port numbers, but based on information supplied so far, I am pretty sure your level of expertise and knowledge of this type of implementation would have allowed you to perform this.

    So assuming the above is correct, then possibly providing the logs would assist. You can view the logs at
    /var/log/asterisk/full (there is also probably full.1 full.2 - archived logs)
    the current full log is all we need and just the part that pertains to the call coming in. It is possible that it may not show at all. If you can confirm this then we need to go back further...

    Regards

    Bob
     
  5. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    You could also force the trunk to go into from-pstn context, to do that, edit:
    /etc/asterisk/sip_general_custom.conf
    and write:
    context=from-pstn
    then execeute from the shell:
    asterisk -rx "reload"

    Don't forget to set your inbouns routes on the web interface, also set an anyCID/anyDID route to catch all DIDs, in the case that you are not receiving all DIDs or if you aren't receiving any one
     

Share This Page