Elastix fails to detect Sangoma A200 - Kernel Prob

Joined
May 18, 2008
Messages
219
Points
0
Hi Guys,

Someone between trying to enable Trixbox repos or something else there seems to be a kernel problem that I have. Sangoma Card Detection module doesn't detect any card even though I have a PCI A200 install and all is fine with the card. I have tried to manually install wanpipe drivers and here is what I got:

****************************************************************************************************8
Custom Compilation:
------------------
Customise WANPIPE driver compilation to add only the
protocols that you need. This way one can reduce
the size of the WANPIPE kernel drivers.

Refer to http://wiki.sangoma.com for more info
./Setup: line 1049: /lib/modules/2.6.18-53.1.19.el5xen/build/Makefile: No such file or directory
./Setup: line 1090: [: -eq: unary operator expected
./Setup: line 1094: [: -eq: unary operator expected
./Setup: line 1097: [: -eq: unary operator expected



ERROR: The /lib/modules/2.6.18-53.1.19.el5xen/build contains a fresh, unconfigured kernel!

If you already have a working kernel image, a
simple kernel configuration can solve this problem
In linux source dirctory run:

make dep modules

Then retry the Setup script !!

If you are still expriencing problems please contact
Sangoma Tech Support
Press [Enter] to continue...
[root@eLASTA wanpipe-3.3.15]#

***************************************************************************************************

Then I tried this to fix the problem:

*********************************************************************************************************
[root@eLASTA wanpipe-3.3.15]# yum install kernel-devel-$(uname -r)
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
* elastix-beta: repo.elastix.org
* trixbox: yum.trixbox.org
* base: www.muug.mb.ca
* updates: www.muug.mb.ca
* elastix-extras: repo.elastix.org
* addons: mirror.trouble-free.net
* elastix: repo.elastix.org
* extras: www.muug.mb.ca
Excluding Packages from Elastix-Beta RPM Repository for CentOS
Finished
Excluding Packages from CentOS-5 - Base
Finished
Excluding Packages from CentOS-5 - Updates
Finished
Excluding Packages from Elastix-Extras RPM Repository for CentOS
Finished
Excluding Packages from CentOS-5 - Addons
Finished
Excluding Packages from Elastix RPM Repository for CentOS
Finished
Excluding Packages from CentOS-5 - Extras
Finished
Setting up Install Process
Parsing package install arguments
No package kernel-devel-2.6.18-53.1.19.el5xen available.
Nothing to do
[root@eLASTA wanpipe-3.3.15]#
***************************************************************************************************

I have another freshly install Elastix and it is set to kernel-devel-2.6.18-53.1.19.el5 rather than kernel-devel-2.6.18-53.1.19.el5xen. How can I change to the one without "xen" ?

Thanks
 
Joined
Aug 8, 2008
Messages
293
Points
0
Sounds like you may have done a yum update with tb repo enabled. if you don't have too much to lose you might reinstall easier than fixing it. Don't know how to fix the problem but if you set enable=0 in the trixbox repo. Then if you want something from tb do yum --enablerepo=trixbox list bla-bla.

Don
 
Joined
May 18, 2008
Messages
219
Points
0
Thanks for the reply donhwyo. But it seems to be really late to turn off trixbox repo. However, I do have it off. Unfortunately, I can re-install this box; it's in production and lot's of modifications have been done to it. I wish there was a restore point feature to CentOS to go back a week :)

Maybe there is some place to set the kernel to be kernel-devel-2.6.18-53.1.19.el5 rather than kernel-devel-2.6.18-53.1.19.el5xen.

I will post this on CentOS forum at the same time.
 
Joined
Aug 8, 2008
Messages
293
Points
0
Check in /boot for the files in the following /boot/grub/menu.lst . If they are there add this to it or if they are already there change default to them. Change to your root=/dev/* and hd(*,*) Follow the format of the other items.


title Elastix-base (2.6.18-53.1.19.el5)
root (hd0,0)
kernel /vmlinuz-2.6.18-53.1.19.el5 ro root=/dev/md2
initrd /initrd-2.6.18-53.1.19.el5.img

If the files are not there try adding them with yum and check the menu.lst file. You might have to force it and it may say it will break stuff. Keep the list so you can look back at it if you need to. It wont actually break anything except when you boot with this kernel. Of course it is already broken with the other kernel so I guess it is worth a try.

Find the thread about making an image of your system and use that first. That is your restore point:lol: You need to use your other system to test things before putting them on a production system. And then have a backup to fall back on if after that it fails. Basic stuff here. This is not a game machine its serious business tools.

Don
 
Joined
May 18, 2008
Messages
219
Points
0
All that worked and I got help from Sangoma people and people on CentOS forums. Basically modified Grub file to get the non XEN version starting up. I was able to remove kernel-xen afterwards but wanpipe-modules won't update because zaptel wasn't there. Zaptel install again required kernel-xen. After a day of working it with a Sangoma tech, he notified that now everything is messed up with my system :) and I have to re-install everything. So, I did. I hate it when this happens and you don't know what broke what. I like MS Windows much more when it comes to things like this. At least I can know what is wrong and why stuff don't work. Anyhow, I am on a fresh start. Let's see how long this lasts :) Thanks
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top