Elastix como servidor web

Discussion in 'Elastix 2.x' started by dfloid, Jan 6, 2011.

  1. dfloid

    Joined:
    Apr 30, 2010
    Messages:
    35
    Likes Received:
    0
    Buenas.
    El problema que tengo es que no consigo hacer que elastix redireccione las paginas a su correcta ubicacion y siempre me remita a la pagina de acceso de elastix.
    En la actualidad tengo elastix como centralita y winserver como web server, pero solo tengo problemas.
    Tengo una sola linea telefonica y dos paginas web que podrian cohabitar perfectamente en elastix y asi ahorrarme los quebraderos de cabeza del windows.
    Lo que he hecho es lo siguiente:
    He pasado todo el contenido de las carpetas a sus correspondientes directorios en /var/www/html/directorio_de_la_pagina
    He importado la base de datos de la pagina mediante phpmyadmin
    He creado el virtual server mediante webmin

    Tambien he comentado el fichero elastix.conf quedando de esta manera:

    <Directory "/var/www/html">
    # Redirect administration interface to https
    # RewriteEngine On
    # RewriteCond %{HTTPS} off
    # RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    </Directory>

    He podido comprobar que los vhosts estan correctamente configurados y puedo acceder en modo local poniendo la direccion y ruta a la pagina correspondiente de esta manera:

    http://Direccion_local/Carpeta_dE_la_pagina

    y todo funciona correctamente
    El problema es que al poner la direccion publica http://midominio.com , me redirecciona a la pagina inicial de elastix aunque eso si, ya no es https sino http, es la unica diferencia que he notado al realizar los cambios
    Quiza me falta algun paso que dar?
    Gracias por su ayuda.
     
  2. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    <VirtualHost 172.19.2.16:8080>
    ServerAdmin manzurek@hotmail.com
    DocumentRoot /var/www/aplicaciones
    ServerName 172.19.2.16
    ErrorLog logs/reniec-error_log
    CustomLog logs/reniec-access_log common
    </VirtualHost>
     
  3. dfloid

    Joined:
    Apr 30, 2010
    Messages:
    35
    Likes Received:
    0
    gracias por tu respuesta.
    Pero no se supone que ya tengo creados los vhosts mediante admin?
    si miro en /etc/httpd/conf/httpd.conf , ya veo que webmin los creo por cada uno de los dominios que he metido.
    Ejemplo:

    <VirtualHost triodo.es:80>
    DocumentRoot "/var/www/html/triodo"
    <Directory "/var/www/html/triodo">
    allow from all
    Options +Indexes
    </Directory>
    </VirtualHost>

    al menos eso es lo que en teoria pasa en todos los servidores linux, que con eso debe ser suficiente para que redireccione cada dominio a su carpeta, pero al parecer elastix tiene alguna restriccion para eso no?.
     
  4. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    A ver, creo que entendi mal, a ver

    midominio.com => directo hacia la pagina de administracion de elastix

    Bueno lo que puedes probar es usar diferentes puertos

    <VirtualHost 172.19.2.16:8080>
    ServerAdmin manzurek@hotmail.com
    DocumentRoot /var/www/aplicaciones
    ServerName 172.19.2.16
    ErrorLog logs/reniec-error_log
    CustomLog logs/reniec-access_log common
    </VirtualHost>


    y prueba ingresando midominio.com:8080

    Suerte,
     
  5. dfloid

    Joined:
    Apr 30, 2010
    Messages:
    35
    Likes Received:
    0
    bien si funciona asi es buena idea, pero claro tendria que andar direccionando para que los visitantes de mi pagina no tuvieran que poner :8080 cada vez que me visiten.
    Lo que busco sencillamente es que apache funcione correctamente.
    Lo interesante seria saber que hace que todo redireccione a la /index.php, ya que toricamente es el puerto 443 el que tiene que ser redireccionado y no el 80
    Gracias.
     
  6. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Entonces redirecciona la interfaz de administracion del elastix al puerto que desees para liberar el puerto 80

    en
    /etc/httpd/conf/httpd.conf

    #
    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, in addition to the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to
    # prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
    #
    #Listen 12.34.56.78:80
    Listen 8080

    Saludos,
     
  7. dfloid

    Joined:
    Apr 30, 2010
    Messages:
    35
    Likes Received:
    0
    pues tampoco he conseguido gran cosa con eso
    Solo que ahora ciertamente las paginas alojadas no redireccionan a la interfaz, sino que sencillamente no se muestran
     
  8. dfloid

    Joined:
    Apr 30, 2010
    Messages:
    35
    Likes Received:
    0
    Pues ya esta listo, despues de 15 trillones de vueltas lo he conseguido.

    El tema es el siguiente:
    Po alguna razon, webmin no crea correctamente los Vhosts y los renombra de alguna manera que no es correcta, al menos los directorios donde se encuentran, por lo que lo unico que hay que hacer es lo siguiente, insertar en httpd.conf , lo primero esto:

    <VirtualHost *:80>
    DocumentRoot /var/www/html
    ServerName localhost:80
    </VirtualHost>

    Eso es ineludible o los vhosts dejaran de funcionar a partir de ahi el resto es ir poniendo vhosts direccionados a sus carpetas y listo.
    Por ejemplo:

    #Triodo
    <VirtualHost *:80>
    DocumentRoot /var/www/html/triodo
    ServerName triodo.es
    </VirtualHost>

    Y nada mas, como siempre, la opcion mas sencilla era la correcta, solo habia que dar con ella, jeje y la tenia delante mia, solo me costo un par de paquetes de tabaco.

    Gracias por tu ayuda.
     
  9. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    De nada, estamos para ayudarnos

    Saludos,
     

Share This Page