Elastix and Voxalot

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#1
Dear Experts,
I appreciate if someone can help me in setting up my Voxalot account with Elastix which I am not able to achieve it so far as a Sip Trunk to call out and receive calls. I have looked everywhere here in this forum and couldn't find anything related to voxalot..
Thanks in advance
 

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#2
I managed to call out using my voxalot account by setting up the follwing configurations:

I have added the following to my main sip configuration in sip.conf
disallow=all
allow=g729
allow=g723


Trunk settings:
---------------

Outgoing dial rules

xx.

Set the trunk name to Voxalot

Outgoing settings

context=from-trunk
host=us.voxalot.com
secret=mysecret
type=peer
username=myusername

Incoming settings so far completely blank - I deleted the dummy settings

Set the register string to

myusername:mysecret@us.voxalot.com

Now remains the inbound calls settings which again I highly appreciate any hints..
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#3
Try setting the register string to:

myusername:mysecret@us.voxalot.com/myVoxalotDID (ignore the space that the brain-dead forum software inserts).

Then set your inbound route to match the DID in the above string, any CID.
 

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#4
@wiseoldowl, excuse my ignorance but can you please tell me the format of voxalot DID?
- Is it the SIP URI: memberID@us.voxalot.com?
- Or maybe I can substitute it with my voxalot number xxxxxx? which is the same as myusername..
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#5
Nakkoush said:
@wiseoldowl, excuse my ignorance but can you please tell me the format of voxalot DID?
- Is it the SIP URI: memberID@us.voxalot.com?
- Or maybe I can substitute it with my voxalot number xxxxxx? which is the same as myusername..
The DID ("Direct Inward Dial" ) is the number other people dial to reach you through that provider. So yes, it is your Voxalot number.
 

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#6
wiseoldowl said:
Try setting the register string to:

myusername:mysecret@us.voxalot.com/myVoxalotDID (ignore the space that the brain-dead forum software inserts).

Then set your inbound route to match the DID in the above string, any CID.
@ wiseoldowl, I tried the above and unfortunately I am still not able to receive incoming voxalot calls..
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#7
Nakkoush said:
wiseoldowl said:
Try setting the register string to:

myusername:mysecret@us.voxalot.com/myVoxalotDID (ignore the space that the brain-dead forum software inserts).

Then set your inbound route to match the DID in the above string, any CID.
@ wiseoldowl, I tried the above and unfortunately I am still not able to receive incoming voxalot calls..
Well, next step is to try the advice in How to get the DID of a SIP trunk when the provider doesn't send it (and why some incoming SIP calls fail)
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#8
You know, I must be getting senile - I totally forgot that we actually have a Voxalot trunk coming in here! Just didn't make the mental connection, I guess.

Here is how we have it set up:

Trunk name: Voxalot

PEER Details

disallow=all
allow=ulaw
context=from-trunk
host=us.voxalot.com
username=nnnnnn (Voxalot number)
secret=password
type=peer

Register String: nnnnnn: password@us.voxalot.com/nnnnnn (OMIT THE SPACE!!!)

EVERYTHING else in the trunk settings are blank.

Inbound route:

Description: Voxalot
DID Number: nnnnnn
Destination: IVR (Main)

Wherever you see nnnnnn it is the same six-digit Voxalot number.
 

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#9
@wiseoldowl: Thanks very much for your help, I really appreciate..

Unfortunately even with your last settings things are still not working here; therefore I am posting my asterisk log file (verbose and debug are set to 5)

Thanks again.. http://forum.elastix.org/old_files/log.txt
 

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#10
My current voxalot account is working properly on my SPA3102 (in other words, I have no problems in my network and forwarding ports from my router); I want t incorporate my Voxalot account as a SIP trunk in my Elastix..

FYI, In order for my Voxalot account to work on my network with my SPA3102 I have to enable NAT, and use a Stun server (stun.xten.com).. I hope that these information will help you narrow down the troubles that I am having with my incoming calls..
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#11
Asterisk logs really don't mean much to me, although someone else might find them useful. I'd rather see the CLI output usually, but in this case I doubt it would reveal much more.

I'm wondering if there is a hidden character in your trunk config or something. I'm tempted to say totally delete the trunk and then re-enter everything, taking care not to have spaces or extra characters where they don't belog (in other words, I'm about out of ideas here).
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#12
Try adding nat=yes to your peer details

Also, this is something we had to do for a different provider, but may also affect your situation. In /etc/asterisk/sip_general_custom.conf we have the following lines:
bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
insecure=invite
tos=0x68
srvlookup=no
I don't even understand exactly what all of these do but I was told that they were necessary to use with a different provider and sure enough, if we didn't use them the trunk wouldn't work. So now I'm wondering if perhaps these might also be allowing the Voxalot trunk to work.

As I say, I'm about out of ideas here!
 

Nakkoush

Joined
Feb 14, 2009
Messages
73
Likes
0
Points
0
#13
wiseoldowl said:
Try adding nat=yes to your peer details

Also, this is something we had to do for a different provider, but may also affect your situation. In /etc/asterisk/sip_general_custom.conf we have the following lines:
bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
insecure=invite
tos=0x68
srvlookup=no
As I say, I'm about out of ideas here!
@ Wiseoldowl: I am very gratefull, thanks.

Bingo! your above settings solved my problem.. In and out calls are now going through with my Voxalot account on ELastix..
 

chacon

Joined
Jan 4, 2010
Messages
2
Likes
0
Points
0
#14
Hi,
I tried to follow the threat but maybe I lost something and I still can´t to configure the Elastix & voxalot
can you share with us your final setting ???

Thanks in advance
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top