elastix 2.0 Hylafax + sip trunk + iaxmodem help

Discussion in 'General' started by Shen, Oct 19, 2010.

  1. Shen

    Joined:
    Oct 2, 2010
    Messages:
    2
    Likes Received:
    0
    Hi all

    I am having problem receiving fax, I follow the IAXModem setup, I do get a fax tone, then it will disconnect, and on the fax machine where i send the fax from, says comm error, i have attached the error log, and i am using G711 ulaw and alaw, our sip trunk is over vlan over a fiber so there is no issues with the quality of the sip trunk, any help would be great..

    note:
    the 2 things i notice
    Oct 20 11:39:30.43: [ 2383]: --> [5]
    Oct 20 11:39:30.43: [ 2383]: MODEM Command error
    Oct 20 11:39:30.43: [ 2383]: FCS error

    thank you advance


    error log

    Oct 20 11:39:12.98: [ 2383]: SESSION BEGIN 000000107 6496493670102
    Oct 20 11:39:12.98: [ 2383]: HylaFAX (tm) Version 4.3.9
    Oct 20 11:39:12.98: [ 2383]: CallID: "6493685915" "6493685915" "<NONE>" "s"
    Oct 20 11:39:12.98: [ 2383]: MODEM set XON/XOFF/FLUSH: input ignored, output disabled
    Oct 20 11:39:12.98: [ 2383]: <-- [4:ATA\r]
    Oct 20 11:39:16.70: [ 2383]: --> [7]
    Oct 20 11:39:16.70: [ 2383]: ANSWER: FAX CONNECTION DEVICE '/dev/ttyIAX1'
    Oct 20 11:39:16.70: [ 2383]: STATE CHANGE: ANSWERING -> RECEIVING
    Oct 20 11:39:16.70: [ 2383]: RECV FAX: begin
    Oct 20 11:39:16.70: [ 2383]: <-- HDLC<32:FF C0 04 B5 00 AA 12 9E 36 86 62 82 1A 04 14 2E B6 94 04 6A A6 4E CE 96 F6 76 04 2C 74 CC 74 9C>
    Oct 20 11:39:16.70: [ 2383]: <-- data [32]
    Oct 20 11:39:16.70: [ 2383]: <-- data [2]
    Oct 20 11:39:17.63: [ 2383]: --> [7]
    Oct 20 11:39:17.63: [ 2383]: <-- HDLC<23:FF C0 02 A6 B6 A6 E6 86 76 86 B2 04 9E 2E 4E A6 0E F6 4E 0A 04 C2 9A>
    Oct 20 11:39:17.63: [ 2383]: <-- data [23]
    Oct 20 11:39:17.63: [ 2383]: <-- data [2]
    Oct 20 11:39:18.39: [ 2383]: --> [7]
    Oct 20 11:39:18.39: [ 2383]: <-- HDLC<13:FF C8 01 00 73 5F 23 01 FB C1 01 01 18>
    Oct 20 11:39:18.39: [ 2383]: <-- data [13]
    Oct 20 11:39:18.39: [ 2383]: <-- data [2]
    Oct 20 11:39:18.98: [ 2383]: --> [2]
    Oct 20 11:39:18.98: [ 2383]: <-- [9:AT+FRH=3\r]
    Oct 20 11:39:19.54: [ 2383]: --> [7]
    Oct 20 11:39:20.56: [ 2383]: --> [1]
    Oct 20 11:39:20.56: [ 2383]: --> HDLC<16:FF F4 46 08 03 00 F9 18 08 08 08 08 08 04 60 8B>
    Oct 20 11:39:20.56: [ 2383]: --> [5]
    Oct 20 11:39:20.56: [ 2383]: MODEM Command error
    Oct 20 11:39:20.56: [ 2383]: FCS error
    Oct 20 11:39:20.56: [ 2383]: <-- [9:AT+FRS=7\r]
    Oct 20 11:39:22.49: [ 2383]: --> [2]
    Oct 20 11:39:22.49: [ 2383]: <-- [9:AT+FTH=3\r]
    Oct 20 11:39:22.51: [ 2383]: --> [7]
    Oct 20 11:39:22.51: [ 2383]: <-- HDLC<3:FF C8 58>
    Oct 20 11:39:22.51: [ 2383]: <-- data [3]
    Oct 20 11:39:22.51: [ 2383]: <-- data [2]
    Oct 20 11:39:23.58: [ 2383]: --> [2]
    Oct 20 11:39:23.58: [ 2383]: RECV send CRP (command repeat)
    Oct 20 11:39:23.58: [ 2383]: <-- [9:AT+FRH=3\r]
    Oct 20 11:39:23.82: [ 2383]: --> [7]
    Oct 20 11:39:30.43: [ 2383]: --> HDLC<2:FF F3>
    Oct 20 11:39:30.43: [ 2383]: --> [5]
    Oct 20 11:39:30.43: [ 2383]: MODEM Command error
    Oct 20 11:39:30.43: [ 2383]: FCS error

    Oct 20 11:39:30.43: [ 2383]: <-- [9:AT+FRS=7\r]
    Oct 20 11:39:33.50: [ 2383]: --> [2]
     
  2. trymes

    Joined:
    Aug 19, 2009
    Messages:
    228
    Likes Received:
    0
    Faxing over SIP is asking for trouble. It might work sometimes, but it will not be reliable.

    I would suggest that you set up t.38 or a real phone line.
     
  3. Shen

    Joined:
    Oct 2, 2010
    Messages:
    2
    Likes Received:
    0
    cheers for the advice, do you have any instruction setting up t38?

    cheers
     
  4. trymes

    Joined:
    Aug 19, 2009
    Messages:
    228
    Likes Received:
    0
    Unfortunately, I do not, but Google is likely your friend there. I am not certain that it has gotten to the point of an easy setup at this point, but I really don't know.

    How are you sending these faxes? Over SIP to an ITSP, and then to various people via the PSTN? Or are you sending over SIP to another Asterisk box?

    Tom
     

Share This Page