Elastix 2.0.1 ISDN ZAPHFC outgoing, not incoming c

Discussion in 'General' started by antone, Aug 30, 2010.

  1. antone

    Joined:
    Mar 1, 2010
    Messages:
    17
    Likes Received:
    0
    The RC3 Elastix 2.0 did not work at all with my ISDN due to drivers clashes after the first yum update.
    The New Elastix 2.0.1 works fine, detects the ISDN and I can make calls, but the incoming calls is not shown, nothing happens in Asterisk CLI either when I dial into the ISDN.
    DADHI channels & hardware shows all is fine.

    I might have wrong setup in trunks, I added it as DADHI trunk or as a ZAP/DAHDI compatible trunk as ZAP channel g12, but same result. (g0 is a 8-port TDM800 wildcard) I also added 2 seperate ZAP trunks as zap id 9 & 10 (the dahdi channels) buit same results.

    Can someone please give me some indication where I should look to try and solve incoming call issues on the ISDN? My TDM800 with FXO ports work fine with incoming calls.

    Thanks
    AntonE
     
  2. hansdinges

    Joined:
    Oct 31, 2009
    Messages:
    5
    Likes Received:
    0
    hi antone,
    i have the same problem here. outgoing works fine but there is no ringing and not one line in asterisk cli if a call comes in.
    have you found a solution for your problem?
    thanks H.
     
  3. antone

    Joined:
    Mar 1, 2010
    Messages:
    17
    Likes Received:
    0
    No sorry, no solution/reply yet.
    I had my old 1.6.2 on another drive, so I reverted back to that(using mISDN) so I'll use that till I can fix it.

    If you find a solution, please post here.

    AntonE
     
  4. tstav

    Joined:
    Nov 13, 2009
    Messages:
    19
    Likes Received:
    0
    Elastix 2.0.2 has the same problem.
    Does anyone know where should we post for an answer?
     
  5. tstav

    Joined:
    Nov 13, 2009
    Messages:
    19
    Likes Received:
    0
    Problem solved

    If you probably have a plain ISDN line, like myself, that is a point-to-multipoint cinfiguration then,
    you have to edit /etc/dahdi/genconf_parameters and add the ptmp parameter to the signaling style

    bri_sig_style bri_ptmp

    Also you have to add the same parameter to the /etc/asterisk/dahdi_channels.conf

    signalling = bri_cpe_ptmp

    Tassos
     
  6. eski

    Joined:
    Sep 11, 2008
    Messages:
    28
    Likes Received:
    0
    Bravo re Tassos :)

    I 'll try later

    I tried to install mISDN instead dahdi but did not work with anything.
    yum install asterisk-mISDN not installed because he lacked depecities by mISDNuser but the mISDNuser does not exist for Elastix 2.0!!!
    Maybe it is a BUG..
     
  7. eski

    Joined:
    Sep 11, 2008
    Messages:
    28
    Likes Received:
    0
    Works Fine :)

    Kai pali bravo re c Tassos..
     
  8. antone

    Joined:
    Mar 1, 2010
    Messages:
    17
    Likes Received:
    0
    Thanks a lot. I'll try those on the 2.0.1 tomorrow.
    I remember putting them in a long time ago in 1.4...
    AntonE
     

Share This Page