Elastix 1.6 to 2 Upgrade

Discussion in 'General' started by dmanghani, Jan 21, 2010.

  1. dmanghani

    Joined:
    Jul 14, 2009
    Messages:
    83
    Likes Received:
    0
    The new elastix 2.00 is in iso how does a elastix 1.6 user upgrade?
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Carefully, and only if necessarily. If it works, don't FWI
     
  3. dmanghani

    Joined:
    Jul 14, 2009
    Messages:
    83
    Likes Received:
    0
    how does one upgarde carefully! B)
    a hint would be appreciated
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Again I ask, "Why do you want to upgrade, does the current system not work?"

    If you are a "dyed in the wool" up-grader, then just do the upgrade and please note your problems and report them back as a beta tester, a beta is for experimenting with, so experiment, if it's production, then, well, just don't do it. If you want other beta testers to tell you what to do, then I suggest you miss the point of beta testing, nobody will do that. that is your job, just do it and report and share YOUR experience, on the beta testers list with your peers .

    dicko
     
  5. Kalama Sutra

    Joined:
    Apr 15, 2009
    Messages:
    95
    Likes Received:
    0
    dmanghani & dicko,

    Interesting little feature in e.v.2.x.xx ... FreeBBX === Tools / Asterisk IAX Settings .... video support ....

    Hum ? might have to drop my xxxxx account .... video phone carrier out of Rochester NY

    Jim
     
  6. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Elastix 2.0 is not out yet. We would still give support and security fixes for 1.6, but not new functionallities. It would take a while before there is an upgrade path from 1.6 to 2.0.

    regards,

    rafael
     
  7. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    Rafael - when do you think Elastix 2.0 will be out?
     
  8. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    yesterday was release the RC2. It still has some bugs, so I think we are going to have a new RC. Hope we have Elastix 2.0 as soon as possible.

    regards,

    rafael
     
  9. balvarez

    Joined:
    Jun 13, 2010
    Messages:
    12
    Likes Received:
    0
    Hello Karma,

    Does the 2.0 will include the lates SugarCRM version?

    Where I can read the news about this version?

    Best,
     
  10. donhwyo

    Joined:
    Aug 8, 2008
    Messages:
    293
    Likes Received:
    0
    Sorry to disappoint you but I believe sugar is being removed because it is no longer open source enough. Can't find the change log but the download is here.
    http://sourceforge.net/projects/elastix/files/

    You can always do a manual install yourself.You will probably be more up to date that way anyway.

    Don
     
  11. accesip

    Joined:
    May 16, 2007
    Messages:
    113
    Likes Received:
    0
    Hi,
    I've tried to follow Dicko instructions to upgrade from 1.6 to 2.0, but now I get this error:

    Error: The module modules/pbxadmin/index.php could not be found



    The ssl-error log says

    [Fri Nov 26 23:11:57 2010] [error] [client 192.168.1.80] PHP Notice: Undefined variable: skip_astman in /var/www/html/admin/header.php on line 117, referer: https://192.168.1.7/index.php?menu=hardware_detection
    [Fri Nov 26 23:11:57 2010] [error] [client 192.168.1.80] PHP Notice: Undefined variable: htmlFPBX in /var/www/html/modules/pbxadmin/index.php on line 482, referer: https://192.168.1.7/index.php?menu=hardware_detection
    [Fri Nov 26 23:11:57 2010] [error] [client 192.168.1.80] File does not exist: /var/www/html/modules/pbxadmin/js/script.legacy.js, referer: https://192.168.1.7/index.php?menu=pbxconfig

    does somebody have an idea?

    Brice http://forum.elastix.org/old_files/elastixv200.gz
     
  12. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    I do not believe I have ever posted any " . . .instructions to upgrade from 1.6 to 2.0 . . "
     
  13. accesip

    Joined:
    May 16, 2007
    Messages:
    113
    Likes Received:
    0
  14. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    That was a post I made to the Beta list and purely for the consumption of the Beta Testers, please understand the difference in the assumed level of competency between those here and those there. It worked for me back in the days of elastix-firstboot-2.0.0-6.noarch.rpm, this has long changed, They were never "instructions" if you want to do beta stuff then wait for the next release as Elastix 2.0 is now released, so officially the beta-list is dormant.

    There is no known working "script" as yet to do such update. If you want to dig deep in the very old beta code, then please do so, but don't expect too much support here. You are better advised to investigate the lastest firtsboot script and be VERY familiar with how Elastix/FreePBX work both together and more so lately, against each other. Also how the yum repositories work (and change as to what happens with time.)

    Please everyone stay within your "comfort zone" or some-one will follow my latest advice to "rm -rf /"

    dicko
     

Share This Page