elastix 1.6 issue with libspandsp.so.0

mattrh

Joined
Jul 15, 2008
Messages
175
Likes
0
Points
0
#1
did a clean install with the 1.6 iso. Ran a yum update and i got this error.

Code:
--> Running transaction check
---> Package sgpio.i386 0:1.2.0_10-2.el5 set to be updated
--> Processing Dependency: libspandsp.so.0 for package: asterisk
--> Finished Dependency Resolution
2009020507:asterisk-1.4.26.1-4.i386 from installed has depsolving problems
  --> Missing Dependency: libspandsp.so.0 is needed by package 2009020507:asterisk-1.4.26.1-i386 (installed)
Error: Missing Dependency: libspandsp.so.0 is needed by package 2009020507:asterisk-1.4.26.1.i386 (installed)
[root@elastix src]#
Any ideas?
 

mattrh

Joined
Jul 15, 2008
Messages
175
Likes
0
Points
0
#2
i guess i will just use --skip-broken
 

palillo

Joined
Aug 27, 2008
Messages
23
Likes
0
Points
0
#3
Hi,

Same problem here. New clean install on i386 server but when trying to update via yum update, the libspandsp issue is showed...

Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libspandsp.so.0 for package: asterisk
---> Package spandsp.i386 0:0.0.6-0.1.pre12.el5 set to be updated
---> Package spandsp-devel.i386 0:0.0.6-0.1.pre12.el5 set to be updated
--> Finished Dependency Resolution
2009020507:asterisk-1.4.26.1-4.i386 from installed has depsolving problems
--> Missing Dependency: libspandsp.so.0 is needed by package 2009020507:asterisk-1.4.26.1-4.i386 (installed)
Error: Missing Dependency: libspandsp.so.0 is needed by package 2009020507:asterisk-1.4.26.1-4.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Just tried with package-cleanup but it is not found. Tried yum clean, yum update --skip-broken, no luck.

We need to get spandsp package and build it or the RPM repo could be fixed.

Please let us know as soon as there is a fix.

Kind regards.
Andrés Maduro
 

palillo

Joined
Aug 27, 2008
Messages
23
Likes
0
Points
0
#4
Hi,

I have just search for the missing rpm spandsp-0.0.6-0.1.pre12.el5.src.rpm that you can find in:

http://rpm.pbone.net/index.php3/stat/26 ... l5.src.rpm

I will compile, install and post back results if yum update was able to run smoothly and Asterisk is happy with it.

Kind regards.
Andrés
 

palillo

Joined
Aug 27, 2008
Messages
23
Likes
0
Points
0
#5
Hi,

I have just compiled spandsp but when trying to install and/or upgrade current spandsp.0.0.4 it says that asterisk-1.4.26.1-4 requires it and won't install. I tried even forcing the install rpm --force but then you get 2 spandsps and could not update either.

Then, I tried to download asterisk-1.4.26.1-4.src.rpm and recompile to see if it will be able to install with newer spandsp but there are other dependencies that are deprecated. Tried to fix this by removing the package checks (new packages already installed) but gave error during build.

No luck here. It would be easier for the maintainers of the distro to fix this.

I will check to see if a fix is available soon or try to continue later when I have time.

Regards.
 

tstav

Joined
Nov 13, 2009
Messages
19
Likes
0
Points
0

palillo

Joined
Aug 27, 2008
Messages
23
Likes
0
Points
0
#7
Hi,

Thanks for pointing to the trixbox forum.

I tried the procedure found there and it worked just fine to solve the yum update issue on Elastix 1.6 with spandsp.

Best regards.
Andrés.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,566
Latest member
Fpino
Top