Elastix 1.5 RC1 Ready for Download

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#1
Elastix 1.5 RC1 is available for download. This release is for testing only, it is not for production use.

Changelog:

- Changed module billing_report zaptel by dahdi
- DAHDI 2.1.0.3
- FreePBX 2.5.1
- Asterisk 1.4.23.1
- updated kernel to 2.6.18-92.1.22.el5.
- RPMS Sangoma created.
- Add php-pdo to dependency list
- No need to overwrite /etc/php.ini, just create new elastix.ini with required the variable changes
- Updated wancfg_zaptel.pl patch for wanpipe-util 3.3.15
- Add session.save_path override to elastix.ini. Required because installation changes httpd process owner to asterisk, which does not have write permission on /var/lib/php/session
- Delete module echo canceller in web interface Elastix.
- Standar language localization in each module.
- New call error reports module
- Select installation language
- Fix the bug when selecting language
- Better view of ports in hardware detection module
- Fixed bug with fxotune
- New currency module in preferences
- Endpoint configurator now support Aastra phones
- Extension bacth now can delete sip extensions in a masive way
- Outgoing fax visor support
- New 64 bits distro version

For those of you who want to test the latest release of Elastix, we welcome to register and participate in the beta-testers mailing list. Help us to make Elastix more stable than ever.
 

winson97

Joined
Jan 5, 2009
Messages
3
Likes
0
Points
0
#2
hasn't 32 bits?
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#3
Have this installed on my home production system and so far have only noticed a few things which don't work

1. In address book is no external numbers only extensions
2. When using ##70 to park a call it doesn't announce the park number, instead it just hangs up but call is parked.Might be a headache if you have a busy system
3. Restoring from a backup of 1.4.2 worked smooth no major issues
4 Once installed you will need to update all freepbx modules as most are disabled for upgrade


Will post any more I find
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#4
> 1. In address book is no external numbers only extensions

The Problem, wrong variables in the config file for the Address Book module.

To fix it, please edit the /var/www/html/modules/address_book/configs/default.conf.php

and remove the old tow lines

$arrConfig['module_name'] = 'adress_book';
$arrConfig['templates_dir'] = 'themes';

and add these lines

global $arrConfModule;
$arrConfModule['module_name'] = 'address_book';
$arrConfModule['templates_dir'] = 'themes';
$arrConfModule['dsn_conn_database'] = "sqlite3:////var/www/db/address_book.db";
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#5
winson97 said:
hasn't 32 bits?
Actually 32 bits version is ready for download, the 64bits would be in the next days.
 

zorandimit

Joined
Feb 18, 2009
Messages
11
Likes
0
Points
0
#6
Hi
First, my congratulations for the great job that you have done with Elastix. I am really fascinated with it.
Now, because I am using ISDN-BRI interfaces to PSTN, can you please shortly explain me what it would be necessary to install to make them functional with DAHDI. I am saying this, because with ZAPTEL, a had to download and install bristuff drivers. I dont know what i'll have to do to make them work with Dahdi. The cards that I am using are listed as:
ZTHFC1 "HFC-S PCI A ISDN card 0 [TE] (1-port ISDN-BRI card)
Thank you, and I wish you many many successes in the future, you deserve that
 

security

Joined
May 14, 2007
Messages
299
Likes
0
Points
0
#7
bueno por el momento actuliza los paquetes, los modulos de freepbx, pero mañana le hare pruebas de carga con servidores y las tarjetas que tenemos a ver como se comporta.....

que falta para la version final.....:blush: :blush: :blush:
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#8
rafael said:
winson97 said:
hasn't 32 bits?
Actually 32 bits version is ready for download, the 64bits would be in the next days.
Hi Rafael.

You say that "Actually 32 bits version is ready for download", but I see only the 64Bit and not the 32Bit version.
Can you give me the link?
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#10
Hi saleh..

I had only this link.
And not 32 Bit version.

Thanks for your help Saleh ;)
 

garcia.ronald.d

Joined
Sep 24, 2008
Messages
134
Likes
0
Points
0
#11
This Elastix has support MFCR2 with libopenr2?

Thanks
 

abukhazneh

Joined
Feb 10, 2009
Messages
68
Likes
0
Points
0
#12
congratulations for the new version , i want to ask about the 1.5 verssion is it stable and redeay to use (the 32 bit version) ??
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#13
abukhazneh,

Like any beta or Release Candidate, they can never be regarded as stable.
1.3 is the only release can be regarded as stable right this minute.

1.5RC1 is usable, however 1.5RC3 is due out in the next 24-48 hours (guesstimate) and has had a lot of improvements made in it and gone through a lot of testing from Developers and Beta testers.

1.5 needed this testing due to the changeover to native DAHDI (the new ZAPTEL). Personally I am looking forward to the stable release of 1.5 which shouldn't be far away now.

Regards

Bob
 

gmeles

Joined
Jul 28, 2008
Messages
32
Likes
0
Points
0
#14
Everything is fine. But the openvox A1200P is not recognized by dahdi. Can you include the Openvox patch in the stable release?
 

samix4u

Joined
Mar 31, 2008
Messages
20
Likes
0
Points
0
#15
When are you planing to release stable version of elastix 1.5 Please tell us. if i install 1.5 rc4 to my server what you think about stability.
 

omaticon

Joined
Mar 21, 2009
Messages
4
Likes
0
Points
0
#16
Well guys...

Here is something you should take care of before a 1.5 final release. It seems to effect AMD Opteron systems.

http://bugs.digium.com/view.php?id=13930

It is causing audio issues. Audio fades in & out every few seconds. Thus making the current iteration unusable for any AMD Opteron systems.

I would highly suggest this patch be implemented before a final 1.5 release. I guess I'm the only person running elastix 1.5 betas on an Opteron box.
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#17
Hi omaticon, thanks for the info.
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#18
samix4u said:
When are you planing to release stable version of elastix 1.5 Please tell us. if i install 1.5 rc4 to my server what you think about stability.
We would releae the next sable version of Elastix, when it is ready. You should be awere that somethings could go wrong, so you should be ready to fix things. Also it depends what implementation you are doing, if you are going for 100 users I would recomend 1.3, but if you are going to implement an small one of about 10 users it might be safe to impelemnt 1.5 rc4.

Good luck

Rafael
 

centritech

Joined
Jul 23, 2008
Messages
63
Likes
0
Points
0
#19
Are there issues with this latest RC and a Digium TDM800P? Ever since an upgrade i get

FATAL: Module wctdm24xxp not found.

when I issue a modprobe wctdm24xxp commmand. Dhadi does not seem to have gotten upgraded properly. The card is detected at the hardware level.

When I try to dial out I get "All circuits are busy". Inbound seems to work fine and I can call outbound through my less.net sip trunk.

Any ideas?

Thanks
Scott Brown
Centritech
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#20
Elastix 1.5 is out ready for downloads
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top