Elastix 1.5-9 impossible d'ouvrir l'onglet PBX

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#1
Bonjour,
je viens d'installer la nouvelle version 1.5-9 d'elastix
j'ai restauré une ancienne sauvegarde que j'avais effectué sous Elastix 1.3
Mais quand je clique sous l'onglet Pbx de l'interface web rien ne s'affiche la page reste desesperement blanche.
il doit y avoir un blocage je crois avec Freepbx mais je ne vois pas lequel
Si quelqu'un a une idée

Merci d'avance
PAtrick
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#2
Re bonjour
pour votre info
j'ai fait des recherches dans les fichiers de log (full) et j'ai rien vu de particulier.
j'ai fait la manip avec une version 1.3 et une version 1.5 sur la 1.5 il y a tjrs bloquage quand on clique sur onglet pbx et ce que l'on voit dans les fichiers de log est identique quelque soit la version.

Comment peut on voir d'ou vient le bloquage a l'ouverture de cette fenetre?

Merci d'avance pour votre aide

Patrick
 

Patrick_elx

Joined
Dec 14, 2008
Messages
1,120
Likes
0
Points
0
#3
c'est le même problème relaté ailleurs dans ce forum.
il est possible que le répertoire PEAR ait été updaté et supprimé quelques elements essentiels.

tu peux voir ça dans var/log/httpd/error_log

sous linux:

pear channel-update pear.php.net
pear upgrade-all
pear install db MDB2 Mail Net_SMTP Mail_mime MDB2_driver_mysql
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#4
Bonjour ,

Merci pour ton aide, voila ce que j'ai dans le fichier error_log

ERROR 1049 (42000): Unknown database 'asteriskrealtime2'
touch: cannot touch `Queues': Permission denied
touch: cannot touch `defined': Permission denied
touch: cannot touch `Conferences': Permission denied
touch: cannot touch `defined': Permission denied
touch: cannot touch `iax': Permission denied
touch: cannot touch `trunks': Permission denied
touch: cannot touch `defined': Permission denied
touch: cannot touch `AMP': Permission denied
touch: cannot touch `Users': Permission denied
touch: cannot touch `defined': Permission denied
tar: Removing leading `/' from member names
tar: Removing leading `/' from member names
tar: Removing leading `/' from member names
tar: Removing leading `/' from member names
tar: Removing leading `/' from member names
tar: Removing leading `/' from member names
tar: Removing leading `/' from member names
tar: tftpboot: time stamp 2015-02-14 15:37:54 is 185502066 s in the future

Mais je vois pas trop comment corriger cela

Merci d'avance pour vos idées
Patrick
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#5
Hmmmm, ça m'a l'aire d'être coton ce problème! :blink:
 

Patrick_elx

Joined
Dec 14, 2008
Messages
1,120
Likes
0
Points
0
#6
un autre problème de droits que beaucoup ont eu ces derniers jours peut être résolu par:

chown -R asterisk:asterisk /var/lib/asterisk

mais les symptômes étaient un peu différent.
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#7
Je pense prendre un temps d'observation avant de migrer en 1.5 et voir ainsi les problèmes qui peuvent arriver.
(Bon ... c'est peut-être pervers....mais bon... :huh: )
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#8
Franck:
Off topic, but your new footer?, Is that maybe a newly released Danard?
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#9
dicko said:
Franck:
Off topic, but your new footer?, Is that maybe a newly released Danard?
Hi Dicko.
I'm dad.
Karine Danard. ;)
 

dicko

Joined
Oct 24, 2008
Messages
4,099
Likes
0
Points
0
#10
Felicitation pour votre famille, bienvenue dans le monde " petite unite de l'homme "!
C'est tres tres bonne!
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#11
Merci.
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#12
Bonjour Franck

Félicitation pour cet heureux événement.
A toi et a la maman aussi.


Concernant mon pb
en fait quand j'installe la nouvelle version 1.5 tout semble bien marcher, meme l'onglet PBX.
c'est apres avoir restauré une sauvegarde de la version 1.3 que j'ai ce pb.
ça doit avoir un lien avec Freepbx (version de freepbx que j'avais mis a jour a cause du pb de FOP) ou la database, mais je vois pas trop quoi.
j'ai aussi posé cette question a la suite d'un post en anglais ou le pb semblait etre le meme, mais toujours pas de solution

MErci pour ton aide, mais passes plutot ton temps aupres de ton petit bout de chou je pense que tout le monde te comprendra ici

@plus
joyeux biberonsss

Patrick
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#13
Je me demande ce qui se passerait avec un yum update! :S

Heureusement que j'ai un banc d'essais en Virtual Box!
Je pourrais ainsi faire une migration sans souffrir de ces désagréments.
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#14
En fait je fait cette installation pour les tests sous vmware.
j'ai aussi fait un yum update et les paquets ont été mis a jours, mais tjrs le meme pb
@plus
Patrick
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#15
J'ai essayé ce que proposé patrick_elx un peu plus haut, a savoir

chown -R asterisk:asterisk /var/lib/asterisk

car j'avai root:root a la place d'astérisk mais le pb est le meme

je cherche...
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#16
J'ai fait des recherches en regardant divers fichier de log en faisant la meme manip avec la version Elastix1.3-2 et la version Elastix1.5
Voici le resultat de ces fichiers si quelqu'un a une idée

/var/log/httpd/ssl_request_log (version 1.3-2)


[31/Mar/2009:13:00:40 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /images/user_info.png HTTP/1.1" -
[31/Mar/2009:13:00:50 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /?menu=pbxconfig HTTP/1.1" 22167
[31/Mar/2009:13:00:52 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /modules/pbxadmin/themes/default/mainstyle.css HTTP/1.1" 9026
[31/Mar/2009:13:00:52 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /modules/pbxadmin/themes/default/ie.css HTTP/1.1" 236
[31/Mar/2009:13:00:52 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /modules/pbxadmin/js/script.js.php HTTP/1.1" 851
[31/Mar/2009:13:00:52 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /modules/pbxadmin/js/script.legacy.js HTTP/1.1" 313
[31/Mar/2009:13:00:52 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /modules/pbxadmin/js/libfreepbx.javascripts.js HTTP/1.1" 62299

/var/log/httpd/ssl_request_log (version 1.5)

[31/Mar/2009:12:28:02 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /modules/dashboard/images/user_info.png HTTP/1.1" -
[31/Mar/2009:12:28:11 +0200] 192.168.1.131 SSLv3 RC4-MD5 "GET /?menu=pbxconfig HTTP/1.1" -


/var/log/httpd/ssl_error_log (version 1.3-2)


[Tue Mar 31 13:00:03 2009] [error] [client 192.168.1.131] File does not exist: /var/www/html/0.gif, referer: https://192.168.1.220/
[Tue Mar 31 13:00:40 2009] [error] [client 192.168.1.131] PHP Notice: Undefined index: extension in /var/www/html/modules/dashboard/index.php on line 105, referer: https://192.168.1.220/
[Tue Mar 31 13:00:51 2009] [error] [client 192.168.1.131] PHP Notice: Undefined variable: htmlFPBX in /var/www/html/modules/pbxadmin/index.php on line 464, referer: https://192.168.1.220/
[Tue Mar 31 13:00:52 2009] [error] [client 192.168.1.131] File does not exist: /var/www/html/modules/pbxadmin/js/script.legacy.js, referer: https://192.168.1.220/?menu=pbxconfig


/var/log/httpd/ssl_error_log (version 1.5)


[Tue Mar 31 10:43:53 2009] [error] [client 192.168.1.131] File does not exist: /var/www/html/0.gif, referer: https://192.168.1.220/
[Tue Mar 31 10:52:32 2009] [error] [client 192.168.1.131] Tue, 31 Mar 2009 10:52:32 +0200 - Got event.. reload, referer: https://192.168.1.220/?menu=backup_restore
[Tue Mar 31 10:52:32 2009] [error] [client 192.168.1.131] Tue, 31 Mar 2009 10:52:32 +0200 - No event handler for event 'reload', referer: https://192.168.1.220/?menu=backup_restore
[Tue Mar 31 10:52:32 2009] [error] [client 192.168.1.131] Tue, 31 Mar 2009 10:52:32 +0200 - Got event.. channelreload, referer: https://192.168.1.220/?menu=backup_restore
[Tue Mar 31 10:52:32 2009] [error] [client 192.168.1.131] Tue, 31 Mar 2009 10:52:32 +0200 - No event handler for event 'channelreload', referer: https://192.168.1.220/?menu=backup_restore
[Tue Mar 31 12:27:56 2009] [error] [client 192.168.1.131] File does not exist: /var/www/html/0.gif, referer: https://192.168.1.220/



/var/log/httpd/ssl_access_log (version 1.3-2)


192.168.1.131 - - [31/Mar/2009:13:00:50 +0200] "GET /?menu=pbxconfig HTTP/1.1" 200 22167
192.168.1.131 - - [31/Mar/2009:13:00:52 +0200] "GET /modules/pbxadmin/themes/default/mainstyle.css HTTP/1.1" 200 9026
192.168.1.131 - - [31/Mar/2009:13:00:52 +0200] "GET /modules/pbxadmin/themes/default/ie.css HTTP/1.1" 200 236
192.168.1.131 - - [31/Mar/2009:13:00:52 +0200] "GET /modules/pbxadmin/js/script.js.php HTTP/1.1" 200 851
192.168.1.131 - - [31/Mar/2009:13:00:52 +0200] "GET /modules/pbxadmin/js/script.legacy.js HTTP/1.1" 404 313
192.168.1.131 - - [31/Mar/2009:13:00:52 +0200] "GET /modules/pbxadmin/js/libfreepbx.javascripts.js HTTP/1.1" 200 62299




/var/log/httpd/ssl_access_log (version 1.5)


192.168.1.131 - - [31/Mar/2009:12:28:02 +0200] "GET /modules/dashboard/images/user_info.png HTTP/1.1" 304 -
192.168.1.131 - - [31/Mar/2009:12:28:11 +0200] "GET /?menu=pbxconfig HTTP/1.1" 200 -

Dans error_log je n'ai plus rien que je trouve bizarre en fonction des versions.

Merci de me donner votre avis si ces quelques log vous inspirent.

@plus

Patrick
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#17
bon je crois que je vais jetter l'eponge
je ne referais pas de restauration de Elastix1.3.2 vers elastix1.5
je pense qu'il y a un pb avec freepbx lors de la restauration de la sauvegarde.

En effet sur la nouvelle version de ELastix1.5 freepbx doit etre en version 2.5.1

Apres une restauration des données de Elastix1.3.2 il y a donc blocage a l'ouverture de l'onglet pbx

Et quand on arrive a rentrer sur l'interface de freepbx il y a plein d'erreurs et surtout je m'aperçois qu'il est en version (freepbx2.4.1.2)qui etait la version dans Elastix1.3.2...

Donc comme il est precisé dans un des posts du forum général en anglais il vaut mieux pour l'instant ne pas faire de restauration


@plus

PAtrick
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#18
Question comme çà.
Et si tu faisais une migration de Freepbx en 2.5.1 tout en étant sous Elastix 1.3.2, puis faire une sauvegarde, et réinjecter la sauvegarde sur Elastix 1.5.9?
 

pat1

Joined
Jan 20, 2009
Messages
68
Likes
0
Points
0
#19
je vais voir si je peu faire cela car je suis derriere un proxy et:
les maj de Elastix se font bien mais celle de freepbx bloque???

j'y suis arrivé en deplaçant mon serveur sur une partie du reseau sans proxy et la ça a marché.

Oui pour ça c'est plus que bizzare

Je vais voir d'essayer quand meme cela

Merci de ton aide

PAtrick
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top