Elastix 1.5.2 repo and a Missing Dependency

Discussion in 'General' started by pourrien, Apr 7, 2009.

  1. pourrien

    Joined:
    Apr 4, 2009
    Messages:
    23
    Likes Received:
    0
    Hi,
    I try to install a new fresh server with a Centos 5 using this procedure: http://www.elastix.org/index.php?op...s5#check_the_version_of_kernel_and_kernel-xen
    But the first step (yum install asterisk*
    ) give me a missing dependency error.
    I think the next steps too...
    Here the error:


    ---> Downloading header for kernel to pack into transaction set.
    kernel-2.6.18-92.1.22.el5 100% |=========================| 324 kB 00:17
    ---> Package kernel.i686 0:2.6.18-92.1.22.el5 set to be installed
    ---> Downloading header for kernel-xen to pack into transaction set.
    kernel-xen-2.6.18-92.1.22 100% |=========================| 326 kB 00:17
    ---> Package kernel-xen.i686 0:2.6.18-92.1.22.el5 set to be updated
    --> Running transaction check
    --> Processing Dependency: spandsp-devel for package: asterisk-devel
    --> Processing Dependency: libpri.so.1.0 for package: asterisk
    --> Processing Dependency: libgsm.so.1 for package: asterisk
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: asterisk
    --> Finished Dependency Resolution
    Error: Missing Dependency: libpri.so.1.0 is needed by package asterisk
    Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package asterisk
    Error: Missing Dependency: libgsm.so.1 is needed by package asterisk
    Error: Missing Dependency: spandsp-devel is needed by package asterisk-devel
     
  2. pourrien

    Joined:
    Apr 4, 2009
    Messages:
    23
    Likes Received:
    0
    Is it possible to put the old sources (V1.3.2) in another folder (for ex: repo.elastix.org/centos/5/updates/RPMS/1.3/ ). Like this it's possible to install an Elastix on our server and we will install new version when it works properly -including all dependences) :blink: :blush:
    Thank you
    Pourrien
     
  3. jedaustin

    Joined:
    Dec 30, 2008
    Messages:
    34
    Likes Received:
    0
    I'm trying to do a yum update on 1.3-2 and getting the same kind of dependency BS! In my case it's asterisk and asterisk-devel that have an issue updating. This is why I don't like RPM based Asterisk distributions. They're only as good as whoever maintains the repository. When the new version comes out the old one is ignored. It's a lot of work to build a distribution like this; I understand why things like this fall through the cracks.

    Ever since the early days of asterisk@home I've seen this issue over and over and over with all of the different rpm based asterisk distributions. It's why in most cases you can't upgrade trixbox and elastix; you have to export the configuration/etc, lay down a fresh installation, and restore the elastix and freepbx backup.

    Regarding your issue... You'll wait forever for them to fix things like this. Is there any reason you can't just plop in an Elastix 1.5 cd and lay down a fresh installation?
     

Share This Page