Elastix 1.5.2 out for Download

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#1
Elastix 1.5.2 is ready for download. This version fix the issues with openvox and sangoma hardware.

Here is the complete changelog:
- CentOs 5.2 rpms updadated
- Update of OpenVox drivers in dahdi RPM
- Asterisk updated to 1.4.24 to fix the asterisk crash issue reported by email
- Wanpipe drivers updated to fix an issue reported in the forums, kernel panic
during reboot.
- Fix the update issue that rewrited postfix, fax dispacher, and httpd.conf
files
- Fixed bug drivers yaster in dahdi.

Regards,

Rafael
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#2

pawels

Joined
May 19, 2008
Messages
51
Likes
0
Points
0
#3
Hello,
Is there any way to upgrade from 1.5.2-beta?

Regards,
Pawel
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#4
Wiseoldowl, it might take a bit longer than Friday. On Friday the repo would be open as a beta repo to have the beta-testers test several upgrades in different envioroments. After the tests then you would be able to do a yum update.

This versions has major changes that could break things in the upgrade. That is why is so important the testings before the repo is out. So please be patient.

Regards,

Rafael
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#5
pawels said:
Hello,
Is there any way to upgrade from 1.5.2-beta?

Regards,
Pawel
On Friday, the beta repos would be enable. As you are using a beta version you want to take the risk to do a yum update, and you are not using zaptel. Anyway please read my previous post.

Regards,

Rafael
 

wiseoldowl

Joined
Aug 19, 2008
Messages
251
Likes
0
Points
0
#6
Thanks, rafael - I'd rather wait a few more days until the bugs are out than to upgrade and have it break the system. The main thing I was trying to determine was whether an upgrade would be available.

I don't suppose there's any chance that we'll be able to do the full upgrade but exclude FreePBX, in case we've already upgraded that (or alternately, if it will automatically detect that FreePBX is already the current version and not touch it)?
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#7
In theory yes, but we haven't test it. From "man yum"
--exclude=package
Exclude a specific package by name or glob from updates on all
repositories.
Configuration Option: exclude
You might get dependencies problems and not be able to upgrade Elastix. I am not sure what the result could be, but if you have time you might helps us doing some testings and report them in the beta testers mailing list.

Best regards,

Rafael
 

Lou1z

Joined
Aug 20, 2008
Messages
57
Likes
0
Points
0
#8
generally, i do a yum --exclude=freePBX update and tend to get no problems. the dependencies take care of themselves.
for a major upgrade, i'm not sure although i went from 1.2.1 to 1.3.2 using the above method without issue.
 

pourrien

Joined
Apr 4, 2009
Messages
23
Likes
0
Points
0
#9
Hi,
I'm new user here, but I have a little question.
I'm agree that will be a problem to upgrade from 1.3 to 1.5 but why it's not possible to install a 1.5 version of Elastix on a new server ??

Few days ago, I created a Virtual machine on my PC. I used the .iso image of the Elastix 1.52 all works perfectly.
Now I try to install Elastix on my server hosted in a datacenter using this procedure:
http://www.elastix.org/index.php?option ... om_centos5

When the installation was finished, It was a big surprise.. The version of Elastix is an old one: 1.32 :angry:
So is it possible to install directly a 1.52 on my server ??
Thank you for your help.
 

Lou1z

Joined
Aug 20, 2008
Messages
57
Likes
0
Points
0
#10
1.5.2 is still in the beta repos as far as i'm aware which is why 1.3.2 was installed.
 

pourrien

Joined
Apr 4, 2009
Messages
23
Likes
0
Points
0
#11

Patrick_elx

Joined
Dec 14, 2008
Messages
1,120
Likes
0
Points
0
#12
I do not have enabled the beta repo and the upgrade to 1.5.2 from 1.5.1 worked great from the stable rpm.
 

Usuarioforum

Joined
Nov 15, 2007
Messages
93
Likes
0
Points
0
#13
Rafael:

La opcion de fax handler cuando defines una extension ha desaparecido en la version 1.5 tal y como comente en foro. Como afectará esto al upgrade desde 1.3 que si que tiene esta opcion teniendo en cuenta que es una opcion necesaria para la opcion de fax de elastix?

Si el fax deja de funcionar, tendriais que notificarlo para que la gente lo tenga en cuenta cuando haga el upgrade. En mi caso, y entiendo que en el de muchos, no merece la pena hacer el upgrade si se pierde la funcionalidad de fax.
 

Lou1z

Joined
Aug 20, 2008
Messages
57
Likes
0
Points
0
#14
just updated to 1.5.2 via yum so its there now. also did an exclude=freePBX without issue as my version of freePBX was newer.
 

pourrien

Joined
Apr 4, 2009
Messages
23
Likes
0
Points
0
#15
:blink: I think there are a big problem.
Because my server crashed. I install it with a new OS (centos 5) and now when I try to install Elastix I have some errors with the dependency:
---> Package kernel.i686 0:2.6.18-92.1.22.el5 set to be installed
---> Package kernel-xen.i686 0:2.6.18-92.1.22.el5 set to be updated
--> Running transaction check
--> Processing Dependency: spandsp-devel for package: asterisk-devel
--> Processing Dependency: libpri.so.1.0 for package: asterisk
--> Processing Dependency: libgsm.so.1 for package: asterisk
--> Processing Dependency: libspandsp-0.0.3.so.0 for package: asterisk
--> Finished Dependency Resolution
Error: Missing Dependency: libpri.so.1.0 is needed by package asterisk
Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package asterisk
Error: Missing Dependency: libgsm.so.1 is needed by package asterisk
Error: Missing Dependency: spandsp-devel is needed by package asterisk-devel


:blush:
And it's the first step of the same procedure I used one week ago:
http://www.elastix.org/index.php?option ... kernel-xen

When I make a "yum install asterisk*"
it give me the above error :huh:
Somebody can help me to resolve this problem please ?
Regards
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#16
Can you please retry?
 

pourrien

Joined
Apr 4, 2009
Messages
23
Likes
0
Points
0
#17
Dear Sir,
I just installed again the server to start the install in a "fresh" server.
So I have the same problem.
When I start "yum install asterisk*", I obtain this message:


---> Downloading header for kernel to pack into transaction set.
kernel-2.6.18-92.1.22.el5 100% |=========================| 324 kB 00:17
---> Package kernel.i686 0:2.6.18-92.1.22.el5 set to be installed
---> Downloading header for kernel-xen to pack into transaction set.
kernel-xen-2.6.18-92.1.22 100% |=========================| 326 kB 00:17
---> Package kernel-xen.i686 0:2.6.18-92.1.22.el5 set to be updated
--> Running transaction check
--> Processing Dependency: spandsp-devel for package: asterisk-devel
--> Processing Dependency: libpri.so.1.0 for package: asterisk
--> Processing Dependency: libgsm.so.1 for package: asterisk
--> Processing Dependency: libspandsp-0.0.3.so.0 for package: asterisk
--> Finished Dependency Resolution
Error: Missing Dependency: libpri.so.1.0 is needed by package asterisk
Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package asterisk
Error: Missing Dependency: libgsm.so.1 is needed by package asterisk
Error: Missing Dependency: spandsp-devel is needed by package asterisk-devel
 

galexander

Joined
Nov 24, 2008
Messages
15
Likes
0
Points
0
#18
nevermind my post was re: 1.5 not 1.5.2, erased
 

ssierra

Joined
Feb 27, 2009
Messages
9
Likes
0
Points
0
#19
I have the same problem nor I can't do a yum update from a previous version.

Any idea?

thanks
 

pourrien

Joined
Apr 4, 2009
Messages
23
Likes
0
Points
0
#20
No idea for those errors ?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,967
Messages
131,028
Members
17,677
Latest member
John-V
Top