Elastix 1.5.2-2 Incoming Call

Discussion in 'General' started by snakeapit, Oct 23, 2009.

  1. snakeapit

    Joined:
    Oct 20, 2009
    Messages:
    19
    Likes Received:
    0
    Hi all,

    I have an issue with my incoming call when I upgrade to new version of Elastix 1.5.2-2. Basically, I used the same Trunk setting on my older version of Elastix and the outbound call works fine but i can't receive inbound call and the error saying "the number you have dial is not in service". I wondering if they are newest setting for incoming trunks? Please help, need it urgently thanks

    Here is my trunk settings

    Extension
    Display Name : test1
    User Extension : 100

    Outgoing
    username=613900xxxxx
    type=peer
    secret=xxxxxx
    qualify=yes
    insecure=very
    host=sip.comvergence.com.au
    fromusers=613900xxxxx
    fromdomain=sip.comvergence.com.au
    dtmfmode=rfc2833
    auth=md5

    Incoming
    username=613900xxxxx
    type=user
    secret=xxxxxx
    host=sip.comvergence.com.au
    fromdomain=sip.comvergence.com.au
    context=from-trunk

    Inbound route
    DID Number : 613900xxxxx
    Extension : <100> test1
     
  2. snakeapit

    Joined:
    Oct 20, 2009
    Messages:
    19
    Likes Received:
    0
    Problem Solved!!!

    I didnt realized that the new version of elastix set "Allow anonymous inbound sip call" on General Setting default to "NO".

    It works fine when i changed it to "YES" instead
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    For your protection you should add a "register" string with your VSP to your inbound trunk and set allow anonymous to no.
     
  4. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    agree with dicko. If possible try tu use a register string instead of accepting annonymouse calls.
     

Share This Page