elastix 1.3 : sip outbound fine, but no inbound !

Discussion in 'General' started by robinet, Nov 2, 2008.

  1. robinet

    Joined:
    Nov 1, 2008
    Messages:
    12
    Likes Received:
    0
    Hello everybody,

    I just setup an elastix 1.3 to replace the trixbox pro we were using and it seems all right.
    Excepted that I cannot receive any call ...

    I am registered ok with my ITSP and I can make outbound calls.
    I can also make and receive calls from other extensions.
    But I can't receive inbound calls from the ITSP.

    If I configure a SIP phone to connect directly to the ITSP, it works fine, for both outbound and inbound.
    But, with elastix, inbound is not working ...

    Any idea ?
    In the settings, I put my ITSP username as "USER Context" and, in the "USER Details" field, I put :
    type=user
    context=from-trunk

    I also tried to put secret=xxxx (with xxxx is my ITSP password), but no luck.

    Thanks for any help.
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    hi.

    Make:
    CLI>sip debug peer ITSP-trunk
    CLI>

    Make an incoming call.

    Look the result.

    Sometimes, you aren't oblige to set the inbound parameters!
    Add simply the context into the outbound parameters.
    Leave blank inbound part (user context...Etc)

    Verify the NAT from your router.(SIP and RTP port).

    I think that's all. :huh:
     
  3. robinet

    Joined:
    Nov 1, 2008
    Messages:
    12
    Likes Received:
    0
    Hi,

    Thanks for the help.

    It works ok when I only put :

    type=user
    secret=xxxxx
    context=from-trunk
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    ha yes.... it's useful a secret code if your provider need this information! ;)
     
  5. robinet

    Joined:
    Nov 1, 2008
    Messages:
    12
    Likes Received:
    0
    Bonjour,

    Merci pour votre aide.
    J'aurais besoin de quelqu'un qui connait bien asterisk pour un projet pour un client.
    Pourriez-vous me contacter sur mon adresse email ?
    Je ne trouve pas comment envoyer un message par le forum ...

    Cordialement.
     
  6. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tu sais qu'il y a une partie du forum Elastix en Français?
     
  7. robinet

    Joined:
    Nov 1, 2008
    Messages:
    12
    Likes Received:
    0
    Oui, j'ai vu mais comme j'avais posté en anglais, j'ai continué.
    Autant que ça puisse servir aux autres ...

    Comment peut-on se contacter pour le projet dont je parlais ci-dessus ?
     
  8. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ben je t'ai envoyé un mail. Maintenant je t'attend ;)

    Après la sieste dominicale :side:
     
  9. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tu n'as toujours pas reçu mon mail?
     
  10. robinet

    Joined:
    Nov 1, 2008
    Messages:
    12
    Likes Received:
    0
    si, si, ... il était passé en spam.
    Je viens de répondre ...
     
  11. theme

    Joined:
    Nov 3, 2008
    Messages:
    6
    Likes Received:
    0
    Re:elastix 1.3 : sip outbound fine, but no inbound

    HI

    I am also got this problem. but I change your code. But still not working.

    canreinvite=no
    context=from-trunk
    fromuser=0******
    insecure=very
    qualify=no
    secret=*******
    type=friend
    username=0******

    I try to use this one. But Income call is not working.
     
  12. robinet

    Joined:
    Nov 1, 2008
    Messages:
    12
    Likes Received:
    0
    Re:elastix 1.3 : sip outbound fine, but no inbound

    Are you well registered with your sip provider ?
    You can check this with "sip show registry" from the asterisk CLI.
     
  13. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Re:elastix 1.3 : sip outbound fine, but no inbound

    For me, I put it:

    qualify=yes
    type=peer
    disallow=all
    allow=
    your codec

    Basically, it's within every trunk SIP.

    Try with this!
     
  14. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Re:elastix 1.3 : sip outbound fine, but no inbound

    Salut Robinet. Je t'ai répondu l'autre jour (je ne sais pas si tu as bien reçu mon mail)
     
  15. theme

    Joined:
    Nov 3, 2008
    Messages:
    6
    Likes Received:
    0
    Re:elastix 1.3 : sip outbound fine, but no inbound

    Hi Dandrd

    I try to use your code. But still not working. I see the Log.

    "TA612V Line 1" <029003338> s ANSWERED 00:07

    It's successful answered. But my phone is no ring.

    I think the problem is not in Trunk->USER Details.

    Something wrong in Extension setting???

    Thanks

    Joe
     

Share This Page