Elastix 1.0-RC & FreePBX Error

Discussion in 'General' started by CleveJ, Mar 28, 2008.

  1. CleveJ

    Joined:
    Nov 12, 2007
    Messages:
    100
    Likes Received:
    0
    Hi All,

    The install went ok, but when updating Freepbx I got this error.

    Downloading framework 2403536 of 2403536 (100%)
    Untarring..Done.
    error copying framework files:
    'cp -rf' from src: '/var/www/html/admin/modules/framework/htdocs/*' to dst: '/var/www/html'...details follow
    cp: cannot create directory `/var/www/html/_asterisk': Permission denied
    cp: cannot create directory `/var/www/html/recordings': Permission denied
    Checking for upgrades..No upgrades found

    Looks like this has not been fixed and the problem continues, here is a fix to the problem.

    http://www.elastix.org/index.php?option ... 99&catid=1

    Post edited by: Stilllearning, at: 2008/03/28 18:57<br><br>Post edited by: Stilllearning, at: 2008/03/28 18:59
     
  2. redjim

    Joined:
    Mar 26, 2008
    Messages:
    3
    Likes Received:
    0
    I found a small error in the time/date settings.

    When I changed the time on the drop-down list, the time in the new field is {whatever I select}+1

    I wanted my hour to be 16, so I had to select 15 from the drop-down.

    I am just installing my first elastix(looking to move from trixbox), looks really nice.

    Thanks, James

    p.s. I think I just found another one. When the voicemail sends me an email it has this:
    Dial *98 to access your voicemail by phone. Visit http://AMPWEBADDRESS/recordings/index.php to check your voicemail with a web browser.

    It looks like it needs to find AMPWEBADDRESS automatically. JC<br><br>Post edited by: redjim, at: 2008/03/28 07:59
     
  3. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    Re:Elastix 1.0-RC & FreePBX Error

    Just a note to confirm "Still Learnings" findings. I Just did a fresh install of RC1 (not a yum update).

    After installation, setup a couple of trunks via Freepbx GUI and a couple of Extensions.

    Then moved to perform FREEPBX module upgrades, only to the latest 2.3.x (not the 2.4 upgrade), and the following error comes up:

    ==================
    Downloading framework 2403536 of 2403536 (100%)
    Untarring..Done.
    error copying framework files:
    'cp -rf' from src: '/var/www/html/admin/modules/framework/htdocs/*' to dst: '/var/www/html'...details follow
    cp: cannot create directory `/var/www/html/_asterisk': Permission denied
    cp: cannot create directory `/var/www/html/recordings': Permission denied
    Checking for upgrades..No upgrades found
    ================================

    This error needs to be corrected before Stable release, as it appears to come down to permissions set by the Elastix install.

    Regards

    Bob
     
  4. CleveJ

    Joined:
    Nov 12, 2007
    Messages:
    100
    Likes Received:
    0
    Re:Elastix 1.0-RC & FreePBX Error

    Hi Bob,

    Just a side note this only happens when you update the 2.3 core, otherwise all the other modules update without a hitch. When you try to update from 2.3 to 2.4 the problems are even worse, with broken sym links and extensions not showing up in fop etc. I was hoping in this release they would have properly migrated to the FreePBX 2.4 core, and looked into the bug reports I had filed, as the problems still exist. Would like a comment from a Elastix Techie on this.
     

Share This Page