Echo thru sip to pstn

Discussion in 'General' started by Amphibian, Nov 10, 2009.

  1. Amphibian

    Joined:
    Sep 8, 2009
    Messages:
    1,128
    Likes Received:
    2
    Elastix 1.5-12
    Internal Net 192.168.xxx.xxx with DynDns setup

    I have problem with calls made from sip to pstn. If I call in from pstn to softphone no echo, if I call out from softphone thru Voip trunk to pstn big time echo. If I call in from pstn, route thru DISA back to pstn, major echo.

    I have searched on this site for "sip echo" and haven't found much except for zap trunks.

    Any suggestions on where to look or what I might do to correct this would be helpful.


    Thanks


    PS: and, Yes I have rtfm on EWT and don't see any ref. to this issue except for zap trunks dicko
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    It sounds like your analog trunks are greatly imbalanced, the clue being

    . . .If I call in from pstn, route thru DISA back to pstn, major echo . . .

    DISA is local and for the most part instantaneous, largely an almost perfect gozinta/gozouta fifo buffer, so it must be the analog trunk settings.

    I suggest you look at adjusting rx/txgain in chan_dahdi.conf, with the use of milliwatt testing and dahdi_monitor (you have to stop asterisk and restart dahdi between iterations), you have to do that for both inbound and outbound calls. There is a built in milliwatt test function in Asterisk for inbound, you need to find your own local one for outbound. Having done that you should run fxotune -i (with the appropriate parameters for your locale) to further balance your 2/4 wire hybrid on the fxo interfaces. Do all that with any hard/software echo cancelling defeated. Then turn on your echo cancelling in dahdi, I think you will be amazed at the difference.

    SIP is largely echo free unless you are calling over a hugely latent circuit, the audio paths are separate (in effect a 4-wire circuit) so delay is possibly a problem but not echo (which needs acoustic coupling, which could only come from the far end (in effect a 2-wire circuit), and the telco's have much better echo cancellation than we have access to).

    If that all sounds like gibberish, there a quite a few posts here more long winded (some even from me) but basically echo canceling (which is based on Fast Fourier Transforms, (just math :) )) is more effective when the audio paths are balanced into the hybrid.

    If you have a T1(E1) look at the gain settings on your DS1/CSU hardware as they are usually set wildly wrong.
     
  3. Amphibian

    Joined:
    Sep 8, 2009
    Messages:
    1,128
    Likes Received:
    2
    Thanks Dicko,

    I have one X100 card installed but no lines to pstn running to it, it is just installed, not in use.

    All I have is Voip trunks coming into machine, running softphones on other computers within house. If someone calls in from land line, or, if I call someone out from softphone to land line I get echo on landline side and very little on softphone side. I call is made from landline to voip number, then routed out thru DISA by way of another voip trunk to cell phone, land line I get major echo problems.

    I have tried to enable/disable echo cancellation within softphone (Zoiper Brand) and it appears to make no dif.

    I had problems, some real problems, with NAT issues and little echo under same conditions, so I wiped clean server, installed lastest version of Elastix stable and signed up for DYNDNS. Probs with nat went away but echo got worse.

    Am wondering if this is a voip provider issue or if I need to trash softphones and go with ATA's or voip phones or if there is maybe a delay issue I need to correct on my server.

    I have read a lot of post here and at other sites till I blue in the brain, they all deal with echo issues while using pstn cards within server, since I don't have any in use and all calls are made in/out thru voip trunks, I'm not finding anything that covers my issue per se.

    Thanks again Dicko

    Thanks
     

Share This Page