Echo issue (once again).

Discussion in 'General' started by hinzinho, Jan 7, 2011.

  1. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    Hi all,

    I hope someone can give me guidance on my issue and fix this once and for all. I am on Elastix 1.6-10 and using Polycom IP550 handsets with default sip.cfg (version 3.2.2) from Polycom, not the sip.cfg generated by Elastix. *Edited* I am using the OSLEC as the echo cancellation for DAHDI.

    My PBX network layout:
    Polycom IP550 <--CAT5--> Switch <--> Elastix <--> PRI circuit

    When they make a call outside over the PRI, they hear echo (they hear their own voice back) on external calls. Again, it doesn't happen all the time, but enough to bug them. From internal extension to extension, no problem with echo.

    I know this is like beating a dead horse, but I can't figure this out or even know where to start.

    Thanks!
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    the echo is in the pri side not the polycom...maybe you could try sending some info about your configs and drivers used...
    for example last month ive found a bug in dahdi 2.4 and sangoma cards without hardware echo cancel that affects echo cancel...
     
  3. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    Hope this is what you are looking for.

    [root@elastix asterisk]# dahdi_cfg -vvv
    DAHDI Tools Version - 2.2.0

    DAHDI Version: 2.2.0.2
    Echo Canceller(s): OSLEC
    Configuration

    [root@elastix asterisk]# asterisk -V
    Asterisk 1.4.26.1

    [root@elastix asterisk]# uname -r
    2.6.18-164.el5


    chan_dahdi.conf
    Code:
    [trunkgroups]
    
    [channels]
    context=from-pstn
    signalling=fxs_ks
    rxwink=300              ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=no
    faxdetect=incoming
    echotraining=800
    rxgain=0.0
    txgain=0.0
    callgroup=1
    pickupgroup=1
    
    ;Uncomment these lines if you have problems with the disconection of your analog lines
    ;busydetect=yes
    ;busycount=3
    
    
    immediate=no
    
    #include dahdi-channels.conf
    #include chan_dahdi_additional.conf
    
    
    dahdi-channels.conf
    Code:
    ; Autogenerated by /usr/sbin/dahdi_genconf on Tue Feb 23 17:19:43 2010
    ; If you edit this file and execute /usr/sbin/dahdi_genconf again,
    ; your manual changes will be LOST.
    ; Dahdi Channels Configurations (chan_dahdi.conf)
    ;
    ; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
    ; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
    ;
    
    ; Span 1: WCT1/0 "Wildcard TE121 Card 0" (MASTER)
    group=0,11
    context=from-pstn
    switchtype = national
    signalling = pri_cpe
    channel => 1-23
    context = default
    group = 63
    
    ; Span 2: WCTDM/4 "Wildcard TDM400P REV I Board 5"
    ;;; line="25 WCTDM/4/0 FXOKS"
    signalling=fxo_ks
    callerid="Channel 25" <4025>
    mailbox=4025
    group=5
    context=from-internal
    channel => 25
    callerid=
    mailbox=
    group=
    context=default
    
    ;;; line="26 WCTDM/4/1 FXOKS"
    signalling=fxo_ks
    callerid="Channel 26" <4026>
    mailbox=4026
    group=5
    context=from-internal
    channel => 26
    callerid=
    mailbox=
    group=
    context=default
    
    ;;; line="27 WCTDM/4/2 FXOKS"
    signalling=fxo_ks
    callerid="Channel 27" <4027>
    mailbox=4027
    group=5
    context=from-internal
    channel => 27
    callerid=
    mailbox=
    group=
    context=default
    
    ;;; line="28 WCTDM/4/3 FXOKS"
    signalling=fxo_ks
    callerid="Channel 28" <4028>
    mailbox=4028
    group=5
    context=from-internal
    channel => 28
    callerid=
    mailbox=
    group=
    context=default
    
    
     
  4. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    well your config is really old so i would recomend to backup and try a yum upgrade -y to the system reboot and test with the dahdi 2.3.0.1 version...also try to see if when you are having echo issues our cpu use goes up...with the top command...if your cpu is high there is a cpu issue not a driver issue and you will need to get the cpu load down to correct that error (it it is the case)
     
  5. john2010

    Joined:
    Jan 12, 2011
    Messages:
    9
    Likes Received:
    0
    You might want to try the Personal PBXMate or the PBXMate software products. They can help you both in analyzing QoS and get rid of echo.
     
  6. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    Upgrade...that's always a tricky part. Which one is lesser of the two evil, echo or other unknown issues. I'll have to make a clone and give that a try. If all else fail, I have a copy to go back.

    Another question, would you guys recommend roll back on updates? Such instruction as here:

    http://www.vincentverhagen.nl/2007/12/1 ... -5-rhel-5/
     

Share This Page