Drop calls when using FOP.

Discussion in 'General' started by hinzinho, Sep 25, 2009.

  1. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    I hate to re-post question in a different forum but it has been days with no response. Here's my problem:

    Whenever I try to drag calls to the Parking Lot or On Hold, FOP would drop my calls. It works fine if I drag and drop to available lines, but not when I have an active call. I have searched online and have found similar problem, such as the link below. I have tried their solution but still the FOP is not working correctly. I even installed the HUDLite server and is getting the same results.

    www.freepbx.org/forum/freepbx/users/fla ... ring-calls

    Here is the log when I tried to park the call using FOP. This is the default setting after installing Elastix. Somehow the FOP doesn't work. What am I doing wrong?


    dialparties.agi: Caller ID name is 'Mobile' number is '5234'
    dialparties.agi: Methodology of ring is 'none'
    -- dialparties.agi: Added extension 5334 to extension map
    -- dialparties.agi: Extension 5334 cf is disabled
    -- dialparties.agi: Extension 5334 do not disturb is disabled
    dialparties.agi: Extension 5334 has ExtensionState: 0
    -- dialparties.agi: Checking CW and CFB status for extension 5334
    -- dialparties.agi: dbset CALLTRACE/5334 to 5234
    -- dialparties.agi: Filtered ARG3: 5334
    == Manager 'admin' logged off from 127.0.0.1
    -- AGI Script dialparties.agi completed, returning 0
    -- Executing [s@macro-dial:7] Dial("SIP/5234-0a14ce58", "SIP/5334||tr" in new stack
    -- Called 5334
    -- SIP/5334-0a1015a8 is ringing
    -- SIP/5334-0a1015a8 answered SIP/5234-0a14ce58
    -- Executing [h@macro-dial:1] Macro("SIP/5234-0a14ce58", "hangupcall" in new stack
    -- Executing [s@macro-hangupcall:1] ResetCDR("SIP/5234-0a14ce58", "w" in new stack
    == Starting SIP/5334-0a1015a8 at parkedcalls,71,1 failed so falling back to exten 's'
    == Starting SIP/5334-0a1015a8 at parkedcalls,s,1 still failed so falling back to context 'default'
    -- Executing [s@default:1] Playback("SIP/5334-0a1015a8", "vm-goodbye" in new stack
    -- <SIP/5334-0a1015a8> Playing 'vm-goodbye' (language 'en'
    -- Executing [s@macro-hangupcall:2] NoCDR("SIP/5234-0a14ce58", "" in new stack
    -- Executing [s@macro-hangupcall:3] GotoIf("SIP/5234-0a14ce58", "1?skiprg" in new stack
    -- Goto (macro-hangupcall,s,6)
    -- Executing [s@macro-hangupcall:6] GotoIf("SIP/5234-0a14ce58", "1?skipblkvm" in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] GotoIf("SIP/5234-0a14ce58", "1?theend" in new stack
    -- Goto (macro-hangupcall,s,11)
    -- Executing [s@macro-hangupcall:11] Hangup("SIP/5234-0a14ce58", "" in new stack
    == Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/5234-0a14 ce58' in macro 'hangupcall'
    == Spawn h extension (macro-dial, h, 1) exited non-zero on 'SIP/5234-0a14ce58'
    == Spawn extension (macro-dial, s, 7) exited non-zero on 'SIP/5234-0a14ce58' in macro 'dial'
    == Spawn extension (macro-exten-vm, s, 9) exited non-zero on 'SIP/5234-0a14ce58' in macro 'exten-vm'
    == Spawn extension (from-internal, 5334, 1) exited non-zero on 'SIP/5234-0a14ce58'
    -- Executing [s@default:2] Macro("SIP/5334-0a1015a8", "hangupcall" in new stack
    -- Executing [s@macro-hangupcall:1] ResetCDR("SIP/5334-0a1015a8", "w" in new stack
    -- Executing [s@macro-hangupcall:2] NoCDR("SIP/5334-0a1015a8", "" in new stack
    -- Executing [s@macro-hangupcall:3] GotoIf("SIP/5334-0a1015a8", "1?skiprg" in new stack
    -- Goto (macro-hangupcall,s,6)
    -- Executing [s@macro-hangupcall:6] GotoIf("SIP/5334-0a1015a8", "1?skipblkvm" in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] GotoIf("SIP/5334-0a1015a8", "1?theend" in new stack
    -- Goto (macro-hangupcall,s,11)
    -- Executing [s@macro-hangupcall:11] Hangup("SIP/5334-0a1015a8", "" in new stack
     
  2. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    Does this also happen in FOP2 ?
     
  3. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    FOP2 does not show the "Parking Lots". The only thing that show up is the Queue. I am able to transfer calls to the queue under FOP2 but not under FOP.

    TIA!
     
  4. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    Anybody??
     
  5. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    I have installed three copies of Elastix and all are giving me the same issue. Dragging and dropping a call to the parking lot disconnect the call. It doesn't matter which end I drag, I still get the same result. I can't be the only one having this issue??

    I am able to using FOP to drag to Conferences, just not the Parking Lot. Another strange thing I found is this:

    - On ext 5134, I call ext 5334
    - 5334 picks up the call
    - using FOP, I drag 5334 and drop it back to 5334.
    - 5334 gets disconnected
    - 5134 gets the message "Call Forward on no answer on extension 34 cancel".

    Somehow FOP strips the first two digits off the extension. It should be 5334 or 5134, not 34. I don't know if that's the problem or not.
     

Share This Page