Downgrade 1.6 Assistance

Discussion in 'General' started by esposed, Jan 23, 2011.

  1. esposed

    Joined:
    Jan 23, 2011
    Messages:
    2
    Likes Received:
    0
    Hello All,

    Today I was doing updates to all systems in my house, and came across news that Elastix 2.0 was out. My first reaction was to upgrade. I don't believe in the "old if it ain't broke don't fix it", I believe in keeping software up to date, which by-and-large has served me well over the years.

    When I did a yum update on the box and noticed it didn't automatically upgrade me to 2.0, I modified /etc/yum.repos.d/elastix.repo to ?release=2 (instead of ?release=1). This in hind sight may not have been an awesome idea.

    After a reboot and a run of /etc/init.d/elastix-firstboot I'm at a point were pretty much everything but the Elastix web-interface is working fine (i.e Asterisk 1.6, MySQL, Apache, FreePBX are all functioning normally). That said, the Elastix web-interface works and I can log in, but the only thing it gives me is the System tab with User Management and Preferences.

    So, I suppose my question is... now what?

    Do I:
    1. Leave it as is, and thank my lucky stars my phones are still working?
    2. Manually do some SQL updates / modifications or help someone in the Elastix community write a proper upgrade process?
    3. Consider this installation botched and start again?

    Looking for suggestions / comments / feedback (other than if it ain't broke don't fix it) ;)

    Esposed
     
  2. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    What kind of error(s) are you getting when clicking on the PBX tab of web interface?
     
  3. esposed

    Joined:
    Jan 23, 2011
    Messages:
    2
    Likes Received:
    0
    Hello hinzinho,

    The most noticeable issue is that there are no longer any tabs across the top of the page accept for System, if I go to access any of the other modules (or even the Users section) I get a 404 error.

    Error: The module modules/userlist/index.php could not be found

    I have also attached a screenshot... very odd. Thanks for your attention.

    Esposed. http://forum.elastix.org/old_files/Screen_shot_2011_01_24_at_9.zip
     

Share This Page