Distro 0.9-beta

Joined
Oct 30, 2007
Messages
11
Points
0
First I really like Elastix, but whats the deal with the 0.9 Distro. Everything seams to load except Asterisk. Now I don't believe I am doing anything wrong but am doing a fresh install for the third time. Just thought that I would give a heads up. If this fails I will post the files that it says its missing when I attempt a amportal start or amportal restart.
 
Joined
Oct 30, 2007
Messages
11
Points
0
3rd reinstall still no joy. Here is the output of performing a amportal restart.

Last login: Wed Oct 31 13:04:11 2007

root@elastix:~[root@elastix ~]# exittail /var/log/asterisk/full
[root@elastix ~]# amportal restart


STOPPING ASTERISK

STOPPING FOP SERVER
SETTING FILE PERMISSIONS
chown: cannot access `/var/log/asterisk': No such file or directory
chmod: cannot access `/var/log/asterisk': No such file or directory
chown: cannot access `/var/spool/asterisk': No such file or directory
chmod: cannot access `/var/spool/asterisk': No such file or directory
chown: cannot access `/var/www/html/recordings': No such file or directory
chmod: cannot access `/var/www/html/recordings': No such file or directory
chown: cannot access `/var/www/html/_asterisk': No such file or directory
Permissions OK

STARTING ASTERISK
/var/lib/asterisk/bin/freepbx_engine: line 123: /usr/sbin/safe_asterisk: No such file or directory
safe_asterisk: no process killed
mpg123: no process killed

-----------------------------------------------------
Asterisk could not start!
Use 'tail /var/log/asterisk/full' to find out why.
-----------------------------------------------------
]0;root@elastix:~[root@elastix ~]# exit
logout

Sorry, I just find this strange from a fresh install. Please advise. Thanks
 

lek

Guest
Thanks for your post lfhuhn,

Could you post the last lines of your /var/log/asterisk/full file?

BR,

-- Edgar
 

lek

Guest
lfhuhn,

Your problem is weird. It looks like asterisk is not installed on your machine because the /var/log/asterisk and /var/spool/asterisk are folders installed by the asterisk RPM.

We have been unable to reproduce your problem here.
 
Joined
Oct 30, 2007
Messages
11
Points
0
Okay, you are correct it is like asterisk is not installed.Here is the tail output:

-----------------------------------------------------
Asterisk could not start!
Use 'tail /var/log/asterisk/full' to find out why.
-----------------------------------------------------
[root@elastix ~]# tail /var/log/asterisk/full
tail: cannot open `/var/log/asterisk/full' for reading: Not a directory

So I will download the ISO again and burn it again and then reinstall it. I will let you know what happens. thanks. Larry
 
Joined
Oct 30, 2007
Messages
11
Points
0
Okay Edgar,
I have did a fresh download of Distro 0.9-beta. Fresh burn. Reinstalled onto my VA Linux Dual Intel 700 MHZ prossessor sever board with 512 mb of ram and a 160 gig hard drive. I haved used this very machine to test your previous versions as well as AsteriskNow, Trixbox, AAH, FreePBX and a few more. I am not an expert by any strech but am dumb founded by this problem. Still NO JOY!!! Here is the log file:

[root@elastix ~]# amportal restart



STOPPING ASTERISK

STOPPING FOP SERVER
SETTING FILE PERMISSIONS
chown: cannot access `/var/log/asterisk': No such file or directory
chmod: cannot access `/var/log/asterisk': No such file or directory
chown: cannot access `/var/spool/asterisk': No such file or directory
chmod: cannot access `/var/spool/asterisk': No such file or directory
chown: cannot access `/var/www/html/recordings': No such file or directory
chmod: cannot access `/var/www/html/recordings': No such file or directory
chown: cannot access `/var/www/html/_asterisk': No such file or directory
Permissions OK

STARTING ASTERISK
/var/lib/asterisk/bin/freepbx_engine: line 123: /usr/sbin/safe_asterisk: No such file or directory
safe_asterisk: no process killed
mpg123: no process killed

-----------------------------------------------------
Asterisk could not start!
Use 'tail /var/log/asterisk/full' to find out why.
-----------------------------------------------------

Also tail /var/log/asterisk/full is also missing? Am I the only nut having trouble? Please advise.. Larry
 

lek

Guest
lfhuhn,

This is really weird. I have not this bug reported before.

Anyway, please send me your /root/install.log file to info at elastix dot org.

Please, do not copy here because it's big. If asterisk is not being installed should be reported there.
 
Joined
Oct 30, 2007
Messages
11
Points
0
Edgar, the file has been emailed. Thank you for your help. I hope you can make better sense of the problem.
Larry
 

lek

Guest
Thanks larry,

It seems that the asterisk RPM is corrupt. Look:

Installing asterisk - 1:1.4.13-4.i386
error: asterisk-1.4.13-4: Header SHA1 digest: BAD Expected(3fa9e679147ff62b3360c2f180dc4d0bf00da1a2) != (55b1ce39d66e8711619a0b9f09fa585b62687c66)

:(

Please try downloading the iso again.
 
Joined
Oct 30, 2007
Messages
11
Points
0
Hi Edgar,

Okay. 3rd download 4th install Asterisk is running. Thanks for your help. I will play with it today. Larry:woohoo:
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top