DIDFORSALE SIP Trunk

Discussion in 'General' started by Jumpstart07, Sep 11, 2010.

  1. Jumpstart07

    Joined:
    Feb 5, 2010
    Messages:
    5
    Likes Received:
    0
    Hi everyone,

    Elastix 2.0
    Asterisk 1.6.2.10
    a2billing-1.7.1

    I have 3 DID from DIDFORSALE.COM terminate in a2billing, all incoming are not working right. I get Asterisk saying "The number you are dialing is not in service" I been working on this for 2 weeks search everywhere including this link; http://www.didforsale.com/blog/?p=81. Can some one point me to the right file to edit? here is the log:

    -- Executing [###########@from-pstn:1] Set("SIP/didforsale-0000008c", "__FROM_DID=###########") in new stack
    -- Executing [###########@from-pstn:2] NoOp("SIP/didforsale-0000008c", "Received an unknown call with DID set to ###########") in new stack
    -- Executing [###########@from-pstn:3] Goto("SIP/didforsale-0000008c", "s,a2") in new stack
    -- Goto (from-pstn,s,2)
    -- Executing [s@from-pstn:2] Answer("SIP/didforsale-0000008c", "") in new stack
    -- Executing [s@from-pstn:3] Wait("SIP/didforsale-0000008c", "2") in new stack
    -- Executing [s@from-pstn:4] Playback("SIP/didforsale-0000008c", "ss-noservice") in new stack
    -- <SIP/didforsale-0000008c> Playing 'ss-noservice.gsm' (language 'en')
    == Spawn extension (from-pstn, s, 4) exited non-zero on 'SIP/didforsale-0000008c'
    -- Executing [h@from-pstn:1] Hangup("SIP/didforsale-0000008c", "") in new stack
    == Spawn extension (from-pstn, h, 1) exited non-zero on 'SIP/didforsale-0000008c'

    I also point the DID to extension and not working either. I have 1 DID from Vitelity and that one is working fine with a2billing and extension.
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    You are getting that message, because you havent any DID inbound configuration for that DID. Set it the same as you get it on the CLI
     

Share This Page