De extension a extension remota no se oye

Discussion in 'Elastix 2.x' started by wysiwyg, Apr 13, 2010.

  1. wysiwyg

    Joined:
    Jan 13, 2009
    Messages:
    45
    Likes Received:
    0
    Buenos días,

    He dado de alta dos extensiones nuevas en mi servidor elastix 3001 y 3008 , la primera esta conectada en la red del servidor (directa) , la segunda es una remota.

    La primera utiliza un PAP2T para conectar al servidor.
    La segunda utiliza otro PAP2T conectado a un router de telefonica y a linea ADSL.

    Las dos estan registrada
    elastix*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    Trk-Netelip/2799272549 213.236.11.69 5060 Unmonitored
    4001/4001 82.198.102.10 D N A 5060 OK (172 ms)
    4000/4000 (Unspecified) D N A 0 UNKNOWN
    3011/3011 192.168.0.7 D N A 1024 OK (9 ms)
    3010/3010 192.168.0.20 D N A 1025 OK (28 ms)
    3009 (Unspecified) D N A 0 UNKNOWN
    3008/3008 83.43.163.114 D N A 5060 OK (205 ms)
    3007/3007 192.168.0.20 D N A 1024 OK (13 ms)
    3005/3005 192.168.0.24 D N A 5061 OK (17 ms)
    3004/3004 192.168.0.7 D N A 10435 OK (30 ms)
    3003/3003 192.168.0.7 D N A 1025 OK (9 ms)
    3002/3002 192.168.0.9 D N A 5060 OK (85 ms)
    3001/3001 192.168.0.25 D N A 5060 OK (17 ms)
    3000/3000 192.168.0.24 D N A 5060 OK (18 ms)
    14 sip peers [Monitored: 11 online, 2 offline Unmonitored: 1 online, 0 offline]
    elastix*CLI>


    Si marcamos la extension en ambos sentidos el telefono suena sin problemas, pero no se escucha la conversacion... ¿es problema del codec utilizado? ¿es problema del tiempo de retraso 205 ms?


    Adjunto remito el status recogido de la marcacion de la extension 3001 a 3008

    LLAMADA DESDE LA EXTENSION 3001 A LA EXT. REMOTA 3008


    -- Executing [3008@from-internal:1] Macro("SIP/3001-b6d067f8", "exten-vm|novm|3008") in new stack
    -- Executing [s@macro-exten-vm:1] Macro("SIP/3001-b6d067f8", "user-callerid|") in new stack
    -- Executing [s@macro-user-callerid:1] Set("SIP/3001-b6d067f8", "AMPUSER=3001") in new stack
    -- Executing [s@macro-user-callerid:2] GotoIf("SIP/3001-b6d067f8", "0?report") in new stack
    -- Executing [s@macro-user-callerid:3] ExecIf("SIP/3001-b6d067f8", "1|Set|REALCALLERIDNUM=3001") in new stack
    -- Executing [s@macro-user-callerid:4] Set("SIP/3001-b6d067f8", "AMPUSER=3001") in new stack
    -- Executing [s@macro-user-callerid:5] Set("SIP/3001-b6d067f8", "AMPUSERCIDNAME=Ciber - Oficina") in new stack
    -- Executing [s@macro-user-callerid:6] GotoIf("SIP/3001-b6d067f8", "0?report") in new stack
    -- Executing [s@macro-user-callerid:7] Set("SIP/3001-b6d067f8", "AMPUSERCID=3001") in new stack
    -- Executing [s@macro-user-callerid:8] Set("SIP/3001-b6d067f8", "CALLERID(all)="Ciber - Oficina" <3001>") in new stack
    -- Executing [s@macro-user-callerid:9] ExecIf("SIP/3001-b6d067f8", "1|Set|CHANNEL(language)=es") in new stack
    -- Executing [s@macro-user-callerid:10] GotoIf("SIP/3001-b6d067f8", "0?continue") in new stack
    -- Executing [s@macro-user-callerid:11] Set("SIP/3001-b6d067f8", "__TTL=64") in new stack
    -- Executing [s@macro-user-callerid:12] GotoIf("SIP/3001-b6d067f8", "1?continue") in new stack
    -- Goto (macro-user-callerid,s,19)
    -- Executing [s@macro-user-callerid:19] NoOp("SIP/3001-b6d067f8", "Using CallerID "Ciber - Oficina" <3001>") in new stack
    -- Executing [s@macro-exten-vm:2] Set("SIP/3001-b6d067f8", "RingGroupMethod=none") in new stack
    -- Executing [s@macro-exten-vm:3] Set("SIP/3001-b6d067f8", "VMBOX=novm") in new stack
    -- Executing [s@macro-exten-vm:4] Set("SIP/3001-b6d067f8", "EXTTOCALL=3008") in new stack
    -- Executing [s@macro-exten-vm:5] Set("SIP/3001-b6d067f8", "CFUEXT=") in new stack
    -- Executing [s@macro-exten-vm:6] Set("SIP/3001-b6d067f8", "CFBEXT=") in new stack
    -- Executing [s@macro-exten-vm:7] Set("SIP/3001-b6d067f8", "RT=""") in new stack
    -- Executing [s@macro-exten-vm:8] Macro("SIP/3001-b6d067f8", "record-enable|3008|IN") in new stack
    -- Executing [s@macro-record-enable:1] GotoIf("SIP/3001-b6d067f8", "1?check") in new stack
    -- Goto (macro-record-enable,s,4)
    -- Executing [s@macro-record-enable:4] ExecIf("SIP/3001-b6d067f8", "0|MacroExit|") in new stack
    -- Executing [s@macro-record-enable:5] GotoIf("SIP/3001-b6d067f8", "0?Group:OUT") in new stack
    -- Goto (macro-record-enable,s,15)
    -- Executing [s@macro-record-enable:15] GotoIf("SIP/3001-b6d067f8", "1?IN") in new stack
    -- Goto (macro-record-enable,s,20)
    -- Executing [s@macro-record-enable:20] ExecIf("SIP/3001-b6d067f8", "1|MacroExit|") in new stack
    -- Executing [s@macro-exten-vm:9] Macro("SIP/3001-b6d067f8", "dial||tr|3008") in new stack
    -- Executing [s@macro-dial:1] GotoIf("SIP/3001-b6d067f8", "1?dial") in new stack
    -- Goto (macro-dial,s,3)
    -- Executing [s@macro-dial:3] AGI("SIP/3001-b6d067f8", "dialparties.agi") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
    dialparties.agi: Starting New Dialparties.agi
    == Parsing '/etc/asterisk/manager.conf': Found
    == Parsing '/etc/asterisk/manager_additional.conf': Found
    == Parsing '/etc/asterisk/manager_custom.conf': Found
    == Manager 'admin' logged on from 127.0.0.1
    dialparties.agi: Caller ID name is 'Ciber - Oficina' number is '3001'
    dialparties.agi: Methodology of ring is 'none'
    -- dialparties.agi: Added extension 3008 to extension map
    -- dialparties.agi: Extension 3008 cf is disabled
    -- dialparties.agi: Extension 3008 do not disturb is disabled
    dialparties.agi: ExtensionState: 0
    dialparties.agi: Extension 3008 has ExtensionState: 0
    -- dialparties.agi: Checking CW and CFB status for extension 3008
    -- dialparties.agi: dbset CALLTRACE/3008 to 3001
    -- dialparties.agi: Filtered ARG3: 3008
    == Manager 'admin' logged off from 127.0.0.1
    -- AGI Script dialparties.agi completed, returning 0
    -- Executing [s@macro-dial:7] Dial("SIP/3001-b6d067f8", "SIP/3008||tr") in new stack
    -- Called 3008
    -- SIP/3008-096c6fe8 is ringing
    -- SIP/3008-096c6fe8 answered SIP/3001-b6d067f8
    -- Executing [h@macro-dial:1] Macro("SIP/3001-b6d067f8", "hangupcall") in new stack
    -- Executing [s@macro-hangupcall:1] GotoIf("SIP/3001-b6d067f8", "1?skiprg") in new stack
    -- Goto (macro-hangupcall,s,4)
    -- Executing [s@macro-hangupcall:4] GotoIf("SIP/3001-b6d067f8", "1?skipblkvm") in new stack
    -- Goto (macro-hangupcall,s,7)
    -- Executing [s@macro-hangupcall:7] GotoIf("SIP/3001-b6d067f8", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] Hangup("SIP/3001-b6d067f8", "") in new stack
    == Spawn extension (macro-hangupcall, s, 9) exited non-zero on 'SIP/3001-b6d067f8' in macro 'hangupcall'
    == Spawn h extension (macro-dial, h, 1) exited non-zero on 'SIP/3001-b6d067f8'
    == Spawn extension (macro-dial, s, 7) exited non-zero on 'SIP/3001-b6d067f8' in macro 'dial'
    == Spawn extension (macro-exten-vm, s, 9) exited non-zero on 'SIP/3001-b6d067f8' in macro 'exten-vm'
    == Spawn extension (from-internal, 3008, 1) exited non-zero on 'SIP/3001-b6d067f8'
    elastix*CLI>


    Ruego me echeis una cable, por donde investigar..... pienso que será del codec que no es el adecuado...

    Si se registra la extension remota y suena la llamada, habría que abrir algun puerto UDP 5060 en el router????

    Espero vuestra ayuda altruista...
    Agradeciendo de antemano vuestra predisposicion.
    Un cordial saludo.
    Jose
     
  2. wysiwyg

    Joined:
    Jan 13, 2009
    Messages:
    45
    Likes Received:
    0
    A ver he estado investigando un poco y sigo sin conseguirlo, aporto mas datos para ver que estoy haciendo mal:

    A) Software de mi servidor:
    Versión Linux:
    GNU bash, version 3.2.25(1)-release (i686-redhat-linux-gnu)
    Version Asterisk:
    Asterisk 1.4.26.1, Copyright (C) 1999 - 2008 Digium, Inc. and others.
    Versión Elastix: 1.6-12
    Freepbx Versión: 2.7.0.1

    B) He actualizado 2 ficheros del servidor:

    b.1) Fichero: /etc/asterisk/sip_nat.conf
    (le he añadido las siguientes lineas)

    ----> nat=yes
    ----> externip=Ciberwan1.dyndns.org
    ----> localnet=192.168.0.0/255.255.255.0
    ----> qualify=yes
    ----> externrefresh=120

    b.2) Fichero: /etc/asterisk/sip_general_custom.conf
    (le he añadido las siguientes lineas)

    ----> externip=Ciberwan1.dyndns.org
    ----> localnet=192.168.0.0/255.255.255.0


    C) He ejecutado el comando para recargar asterisk (creo que es asi)

    amportal restart

    D) En el router principal ( al que esta conectado el servidor ELASTIX) tiene los siguientes puertos abiertos:

    5060 UPD -----------> Ip servidor elastix (192.168.0.100)
    10000 - 20000 UPD --> "" ""
    443 - 443 TCP ------> "" ""

    E) En el router de la extension remota ct536+ ha abierto los siguientes puertos:

    5060 - 5085 UDP ---> Ip dispositivo de voz (PAP2T)
    ¿Tengo que abrir mas puertos para poder hablar por telefono?

    F) En el dispositivo linksys PAP2T le he asignado una ip 192.168.1.99 estatica para tener acceso, mascara y dns para salida a internet....

    Tambien le he configurado el proxy , su usuario: 3008 y su clave secreta.


    Estado registrado... pero no se escucha la voz.

    ¿Que falta o estoy haciendo mal???

    Un saludo.
    jose.
     
  3. wysiwyg

    Joined:
    Jan 13, 2009
    Messages:
    45
    Likes Received:
    0
    al fin , solucionado.....
    solo faltaba abrir el puerto en el router....

    Un saludo..
     
  4. EicheS

    Joined:
    Nov 13, 2009
    Messages:
    305
    Likes Received:
    0
    wysiwyg cuales puertos te faltaban definir en el router?
     
  5. wysiwyg

    Joined:
    Jan 13, 2009
    Messages:
    45
    Likes Received:
    0
    Me ha bastado con UDP 5060 -apuntando a--> Ip dispositivo linksys PAPT
    Ah!!! y aplique en los parametros de propia extension:

    disallow=all
    allow=gsm&g729

    Igualmente en el PAPT le especifiqué el codec 927a.

    Va de maravilla.
    Saludos y gracias...
     
  6. wysiwyg

    Joined:
    Jan 13, 2009
    Messages:
    45
    Likes Received:
    0
    Tambien quiero rectificar por que al final tuve que eliminar las lineas del fichero:
    sip_general_custom.conf porque daba error y no hace falta...
    saludos.
     
  7. daniluck913

    Joined:
    May 12, 2011
    Messages:
    2
    Likes Received:
    0
    Mil gracias por tu ayuda, editando el archivo /etc/asterisk/sip_general_custom.conf pude solucionar, pues configuranco el paramentro externip en el sip_nat.conf, no fue suficiente.
     
  8. tottocol

    Joined:
    Nov 25, 2011
    Messages:
    15
    Likes Received:
    0
    Amigo te estaria muy agradecido si me regalas la configuracion de las cfg, para aplicarlas, tengo el mismo problema, gracias.
     

Share This Page