Dahdi / OSLEC / Echo problem after changing source

Discussion in 'General' started by aglasser, Mar 7, 2011.

  1. aglasser

    Joined:
    Jan 28, 2011
    Messages:
    25
    Likes Received:
    0
    Elastic 2.0

    I recently had to change the Dahdi source in order for my box to send Pulse digits properly. After doing so (timing seems right, so I'm pretty sure it's this) I now have a nice echo problem on the remote side of calls (The person calling into the extension connected to TDM400 can hear the echo loud and clear.) I tried to reinstall Dahdi but noticed:


    Setting echocan for channel 1 to oslec
    DAHDI_ATTACH_ECHOCAN failed on channel 1: Invalid argument (22)

    Would this be causing my echo problem? I had no echo issues prior to the pulse dialing change to Dahdi (wctdm change).

    If this sounds like the problem, then how to I stop Oslec from failing to load(?) I'm not well versed in recompiling these things so anything shared would be fantastic.


    Regards,

    AG
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
  3. aglasser

    Joined:
    Jan 28, 2011
    Messages:
    25
    Likes Received:
    0
    Excellent, thanks, Dicko!

    From what I described, does this seem to be the reason (Oslec) for my current echo issue? I'd hate to spin my wheels (or anyone elses) if that Oslec error isn't the culprit.

    [Edit]

    On a fresh install is OSLEC or MG2 enabled by default? That may better help me answer my own question :)

    Thanks again, Dicko.

    Regards,

    AG
     
  4. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Indeed, no working echo canceller = more echo, , but while you have no echo cancelling, I suggest you tune your "2/4 wire hybrids" (fxo interfaces) first to optimize the system,

    basically you need to adjust rx and tx gains and run fxotune -i against the newly balanced interface, there are other posts here more detailed.
     
  5. aglasser

    Joined:
    Jan 28, 2011
    Messages:
    25
    Likes Received:
    0
    Thanks, Dicko. VERY much appreciated. You have a fantastic day, sir.
     
  6. aglasser

    Joined:
    Jan 28, 2011
    Messages:
    25
    Likes Received:
    0
    Well, before I get too jazzed up. I'm reading some other stuff, and my failure to post some things may change what's going on:

    OUTPUT from dahdi_cfg -vv

    DAHDI Version: 2.3.0.1
    Echo Canceller(s):
    Configuration
    ======================
    Channel map:

    Channel 01: FXO Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 01)
    Channel 02: FXO Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 02)

    2 channels to configure.

    Setting echocan for channel 1 to oslec
    DAHDI_ATTACH_ECHOCAN failed on channel 1: Invalid argument (22)

    ......


    OUTPUT from dahdi show channel 1

    XXXXXX*CLI> dahdi show channel 1
    Channel: 1
    File Descriptor: 15
    Span: 1
    Extension:
    Dialing: no
    Context: from-internal
    Caller ID: 200
    Calling TON: 0
    Caller ID name: device
    Mailbox: 200@default
    Destroy: 0
    InAlarm: 0
    Signalling Type: FXO Kewlstart
    Radio: 0
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Busy Detection: no
    TDD: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: ulaw
    Fax Handled: no
    Pulse phone: no
    DND: no
    Echo Cancellation:
    128 taps
    (unless TDM bridged) currently OFF
    Wait for dialtone: 0ms
    Actual Confinfo: Num/0, Mode/0x0000
    Actual Confmute: No
    Hookstate (FXS only): Onhook
    XXXXXX*CLI>

    -------

    OUTPUT from system.conf

    # Autogenerated by /usr/sbin/dahdi_genconf on Thu Mar 3 13:17:47 2011
    # If you edit this file and execute /usr/sbin/dahdi_genconf again,
    # your manual changes will be LOST.
    # Dahdi Configuration File
    #
    # This file is parsed by the Dahdi Configurator, dahdi_cfg
    #
    # Span 1: WCTDM/4 "Wildcard TDM400P REV E/F Board 5" (MASTER)
    fxoks=1
    echocanceller=oslec,1
    fxoks=2
    echocanceller=oslec,2

    ....

    I was reading that the "128 taps" in "show channel" is in fact echo cancellation.

    Maybe that will be of more help. However I'm still going to try all the forementioned until I'm blue in the face :)
     
  7. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Dahdi / OSLEC / Echo problem after changing source

    do you also try mg2 as echocanceller as in some systems oslec if really not efficient...
    simply add echocanceller=mg2,1 etc etc
     
  8. aglasser

    Joined:
    Jan 28, 2011
    Messages:
    25
    Likes Received:
    0
    Re: Re:Dahdi / OSLEC / Echo problem after changing source

    [SOLVED]

    I had failed to stick the OSLEC source within the Dahdi source directories and make that small mod to Kbuild. That was where I went awry. Anyway...

    Followed the link that Dicko gave me. Worked perfectly. Using OSLEC now. Will try mg2 for the sake of trying it.

    Thanks again for everything, D.

    AG
     
  9. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Re: Re:Dahdi / OSLEC / Echo problem after changing source

    Did you "tune" your FXO's with the milliwatt test and do the fxotune -i thingy as I suggested? you really should , you will be amazed by the improvement all round in "user satisfaction"

    For your edification ( and others) ref:

    http://www.voip-info.info/wiki/view/Ast ... ncellation

    almost everything that is spouted in the VOIP world about Echo cancellation is just plain BS. It's really just physics and processing power, save your CPU cycles and balance you hybrids, the telco's core EC has worked well for 50 years, the problem is almost always the "local loop" to the CO, both analog and TDM.

    JM2CWAE

    dicko
     
  10. aglasser

    Joined:
    Jan 28, 2011
    Messages:
    25
    Likes Received:
    0
    Re: Re:Dahdi / OSLEC / Echo problem after changing source

    I went to do it then slapped myself. I DC'd Ma Bell entirely and switched to VoIP. So, no, didn't tune it. My FXO card isn't being used ATM. Unless there is a util for FXS that I'm unaware of. I get the occasional hiccup now and then, but that dreadful echo is gone, thanks to your advice.

    Regards,

    AG
     
  11. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: Re:Dahdi / OSLEC / Echo problem after changing source

    excellent now add solved to your message and always remember to thank with a karma upgrade to the people you think help you in this the question
     

Share This Page