DAHDI Hangup Detection when bridging dahdi chanels

tom@intersoft.net.au

Joined
Jun 26, 2008
Messages
32
Likes
0
Points
0
#1
Hi,

I have a persistent problem with Elastix 1.5.2. Basically, when an incoming call (on a dahdi trunk) is transferred to an external number (out another dahdi trunk) asterisk never clears those dahdi channels. ie. even after both parties have hung up 'core show channels' shows the call is still active (both dahdi trunks are still open).

The PBX is in Australia, so unfortunately there is no form of disconnect supervison from the telco.

The card is an OpenVox A400P (analog fxo's).

I have put "options wctdm opermode=AUSTRALIA" in modprobe.conf

I have defaultzone and loadzone set to au in /etc/dahdi/system.conf

I have run fxotune -i

I have busydetect=yes and busycount=6 in chan_dahdi.conf

And after all this I have restarted the whole system

There doesn't seem to be any noise or echo on either of the lines (either when calling via asterisk or when I connected an analog phone directly to the line to test).

The only way I've been able to fix it is to restart asterisk each time it happens.

Does anyone have any ideas on how to fix this?
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#2
Have you tried shortening the busy detect
This is my setting as I has same issue when bridging dahdi channels
busydetect=yes
busycount=3

I had to play around a little to find 3 was good, and I am in Australia
 

tom@intersoft.net.au

Joined
Jun 26, 2008
Messages
32
Likes
0
Points
0
#3
Hi Dave,

Actully the busycount was set to 3 until very recently, and I had the same problem. I changed it to 6 as I was getting random disconnects which I thought might be 'talk off' caused by the low busy count.

I'm also in Aus, (and these are brand new telstra lines i.e. in a new building).
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top