Cuanta Memoria Soporta Elastix

Discussion in 'Elastix 2.x' started by security, Jan 4, 2008.

  1. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Tengo un Serbidor IBM X 3650 con 8G de memoria Ram, la maquina los reconoce como tal, pero cuando instalo eslastix, solo me reconoce 3G:blink: :blink: :blink: :blink: :blink:
     
  2. eboza

    Joined:
    Mar 27, 2007
    Messages:
    45
    Likes Received:
    0
    Debería reconocerte 4GB. Elastix está basado en CentOS 5 el cual, en su kernel normal, solo puede direccionar hasta 4GB de memoria RAM.

    Para direccionar más de 4Gb debes instalar el paquete "kernel-PAE". Primero sería bueno que la gente de Elastix confirme que no se afecta el sistema al instalar este paquete.

    Saludos

    - Edwin Boza<br><br>Post edited by: eboza, at: 2008/01/04 17:37
     
  3. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Ok ya intale el kernel-PAE, y me reconece los 8G de ram, pero que dependecias se perderian de elastix (zapte), al arrancarlo con este kernel, esto es lo que me da cuando lo tengo instalado


    [root@elastix /]# yum search kernel-*
    Loading "installonlyn" plugin
    Setting up repositories
    rpmforge 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    updates 100% |=========================| 951 B 00:00
    addons 100% |=========================| 951 B 00:00
    elastix 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 79 kB 00:00
    ################################################## 258/258
    Excluding Packages from CentOS-5 - Base
    Finished
    Excluding Packages from CentOS-5 - Updates
    Finished
    Excluding Packages from CentOS-5 - Addons
    Finished
    Excluding Packages from Elastix RPM Repository for CentOS
    Finished
    Excluding Packages from CentOS-5 - Extras
    Finished

    tux.i386 3.2.18-9.fc6 base
    Matched from:
    User-space component of TUX kernel-based threaded HTTP server

    yum-kernel-module.noarch 1.0.4-3.el5.centos.2 base
    Matched from:
    yum-kernel-module
    Yum plugin to handle kernel-module-foo type of kernel module

    kernel-module-oslec.i386 0.1-13 elastix
    Matched from:
    kernel-module-oslec

    kernel-module-rhino.i386 2.2.2beta-3 elastix
    Matched from:
    kernel-module-rhino

    kernel-module-rhino-xen.i386 2.2.2beta-3 elastix
    Matched from:
    kernel-module-rhino-xen

    kernel-module-oslec-xen.i386 0.1-13 elastix
    Matched from:
    kernel-module-oslec-xen

    kernel-module-zaptel-xen.i386 1.4.6-3_2.6.18_8.el5 elastix
    Matched from:
    kernel-module-zaptel-xen

    kernel-module-zaptel.i386 1.4.6-3_2.6.18_8.el5 elastix
    Matched from:
    kernel-module-zaptel

    kvm.i386 36-1 extras
    Matched from:
    Kernel-based Virtual Machine

    kernel-module-rhino-xen.i386 2.2.2beta-3 installed
    Matched from:
    kernel-module-rhino-xen

    kernel-PAE-devel.i686 2.6.18-53.el5 installed
    Matched from:
    kernel-PAE-devel

    kernel-headers.i386 2.6.18-8.el5 installed
    Matched from:
    kernel-headers

    kernel-xen.i686 2.6.18-8.el5 installed
    Matched from:
    kernel-xen

    kernel-module-zaptel-xen.i386 1.4.6-3_2.6.18_8.el5 installed
    Matched from:
    kernel-module-zaptel-xen

    kernel-module-oslec-xen.i386 0.1-13 installed
    Matched from:
    kernel-module-oslec-xen

    kernel-module-rhino.i386 2.2.2beta-3 installed
    Matched from:
    kernel-module-rhino

    kernel-PAE.i686 2.6.18-53.el5 installed
    Matched from:
    kernel-PAE
    This package includes a version of the Linux kernel with support for up to
    64GB of high memory. It requires a CPU with Physical Address Extensions (PAE).
    The non-PAE kernel can only address up to 4GB of memory.
    Install the kernel-PAE package if your machine has more than 4GB of memory.

    kernel-devel.i686 2.6.18-8.el5 installed
    Matched from:
    kernel-devel

    kernel-module-zaptel.i386 1.4.6-3_2.6.18_8.el5 installed
    Matched from:
    kernel-module-zaptel

    kernel-module-oslec.i386 0.1-13 installed
    Matched from:
    kernel-module-oslec


    Creo que deberiamos esta penzando en trabajar sobre este kernel, ya que si vamos a manejar mas de 4G de ram, tendriamos limitates por ese lado
     
  4. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    De que otra manera podemos utilizar mas de 4g de ram, si no tenemos el paquete PAE???:blink: :blink: :blink: :blink: :blink: :blink:
     
  5. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Bueno realizando pruebas con el kernel PAE, no me levanta el zaptel:( :( :(

    que podemos hacer ante esto
     
  6. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Quien me puede dar una mano con este tema:unsure: :unsure: :unsure: :unsure: :unsure: :unsure:
     
  7. lek

    lek Guest

    Security, lo más problable es que como zaptel no fue compilado contra ese kernel, entonces los módulos no te cargan bien. Te recomiendo recompilar zaptel luego de instalar este kernel.

    Para esto debes primero instalar el paquete kernel-devel que lo puedes descargar de aqui:

    http://vault.centos.org/5.0/os/i386/Cen ... 5.i686.rpm

    Mañana estaré a las 2PM (-5GMT) en el chat irc de Elastix y te puedo dar una mano.
     
  8. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    que pena edgar, pero la verdad he estado ocupado en unos proyectos y revisando la ultima version a ver como se comporta, pero penzando en esto, como se prodria con la ultima version, para que trabaje los 8G de Ram:blink: :blink: :blink: :blink:
     
  9. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Ok, dime que lab. armamos para poder solucionar esto, y de esa manera lo puedan incluir en los parches futuros.

    Tengo maquina con esa capacidad solo es saber que se debe de hacerB) B) B) B)
     
  10. lek

    lek Guest

Share This Page