could not contact boot server using existing confi

Discussion in 'IP Phones' started by paguira, Oct 17, 2008.

  1. paguira

    Joined:
    Jan 17, 2008
    Messages:
    127
    Likes Received:
    0
    Hello,
    I have the following message when I connect my phone Polycom IP320 and IP550:
    "could not contact boot server using existing config"
    in my folder / tftpboot I have my firmware and my config MAC.cfg and MACreg.cfg
    is there a username and password for the TFTP?
    Otherwise how to create a user tftp for Polycom
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    the only thing that you need to do is to set on your polycom the server settings, choose Trivial FTP and put your Elastix's IP, then on the web interface go to PBX -> Endpoint configuraion, do a scan of your network, select the polycom that you want to configure, select the corect model and assign it an extension. Reboot your polycom, and it will be donwnloading your file from /tftpboot
     
  3. jedaustin

    Joined:
    Dec 30, 2008
    Messages:
    34
    Likes Received:
    0
    Are the phones plugged into your PBX or is another device their gateway?
    If you have a firewall/router serving them DHCP and don't have it telling them where to find the tftp server they may be dying there.

    You can manually set the dhcp server and have them use tftp on the phone by entering setup (default pw for polycom 301/501 is 456).

    If you have a linux machine/etc where you can edit the dhcpd.conf file it would look like this (assuming your pbx is 192.168.1.11, router is at 192.168.1.1,etc):

    authoritative;
    ddns-update-style ad-hoc;

    option voip-tftp-servers code 150 = ip-address;
    option voip-tftp-servers 192.168.1.11;


    subnet 192.168.1.0 netmask 255.255.255.0
    {
    option subnet-mask 255.255.255.0;
    option domain-name "";
    option routers 192.168.1.1;
    option domain-name-servers 192.168.1.1, 208.67.222.222;
    option ntp-servers 209.139.208.96, 69.36.240.252;
    option tftp-server-name "192.168.1.11";
    range dynamic-bootp 192.168.1.100 192.168.1.200;
    default-lease-time 3600;
    max-lease-time 7200;
    }
     

Share This Page