connect Elastix with analog PBX

Discussion in 'General' started by sergiof, Aug 4, 2010.

  1. sergiof

    Joined:
    Aug 2, 2010
    Messages:
    6
    Likes Received:
    0
    Hi, I'm new in the world of IP PBX.

    I've succesfully installed Elastix 2.0 with a OpenVox 2FXS/2FXO card. Following instructions on "Elastix without tears" I configured SIP and ZAP extensions.

    Here's my problem: I've connected an Analog extension from my Analog PBX to one of the FXO ports on Elastix. I followed the books ZAP Trunk configuration and Inbound route configuration, but when I call from an Analog extension on my PBX to the extension connected to Elastix the phone rings but nothing happens.

    I would appreciate your help.

    Thanks,
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi.

    I don't know why you use Elastix 2.0 instead of a stable version.
    Elastix 2.0 is still a RC version and have several bug.

    But, do as you want... :huh:

    About your problem, look at the Dahdi context.
    You should use from-pstn or from-zaptel.
    Else verify the cadence ring sequence compared with your PBX, into the Dahdi config.

    Regards
     
  3. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    ERRATUM

    The Elastix is already out in Stable Version. I missed something yesterday. Sorry :laugh:
    So you can use the last Elastix version HERE ;)
    If not already done :p
     
  4. sergiof

    Joined:
    Aug 2, 2010
    Messages:
    6
    Likes Received:
    0
    Hi,

    I've checked my chan_dahdi.conf file, and I think that the context is correct. Here's the file.

    Code:
    [trunkgroups]
    
    [channels]
    context=from-pstn
    signalling=fxs_ks
    rxwink=300		; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=no
    faxdetect=incoming
    echotraining=
    rxgain=0.0
    txgain=0.0
    callgroup=1
    pickupgroup=1
    
    ;Uncomment these lines if you have problems with the disconection of your analog lines
    ;busydetect=yes
    ;busycount=3
    
    
    immediate=no
    
    #include dahdi-channels.conf
    #include chan_dahdi_additional.conf
    dahdi-channels.conf is empty. Here is chan_dahdi_additional.conf

    Code:
    [2000]
    signalling=fxo_ks
    pickupgroup=
    mailbox=2000@device
    immediate=no
    echotraining=
    echocancelwhenbridged=no
    echocancel=yes
    context=from-internal
    callprogress=no
    callgroup=
    callerid=device <2000>
    busydetect=no
    busycount=7
    accountcode=
    channel=>1
    
    2000 is an analog extension that is working correctly.

    Thanks,
     
  5. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Code:
    ;busydetect=yes
    ;busycount=3
    
    Must be uncommented if you want that the line detect the hangup.
    busycount=3 or > (4 or 5).

    Else, for the cadence
    Code:
    cadence=1000,3000  or other value.
    Otherwise, you could survey the state of dahdi channel with these cmd:

    maquette*CLI> dahdi show [cadences channel channels status]

    Regards
     
  6. sergiof

    Joined:
    Aug 2, 2010
    Messages:
    6
    Likes Received:
    0
    Hi,

    I've changed the configurations you suggested and restarted the server, but it still doesn't work. When I call from the analog extension to Elastix extension nothing happens.

    Here's the result of the commands you suggested:

    dahdi show cadences:

    Code:
    [0;32mr1: 125,125,2000,4000
    r2: 250,250,500,1000,250,250,500,4000
    r3: 125,125,125,125,125,4000
    r4: 1000,500,2500,5000
    
    dahdi show channel: I only get information from channel 1, which is the analog extension #2000. This one is working correctly. From the other channels I get the following message: "Unable to find given channel X" (2,3,4). I suppose this means I don't have any other channels, but I checked the ZAP Channels DID on freepbx and channel 3 is configured. I don't know if I'm missing something.

    dahdi show channels:

    Code:
       Chan Extension  Context         Language   MOH Interpret        Blocked    State     
     pseudo            default                    default                         In Service
          1            from-internal              default                         In Service
    
    dahdi show status:

    Code:
    Description                              Alarms  IRQ    bpviol CRC4   Fra Codi Options  LBO
    Wildcard TDM400P REV E/F Board 5         OK      0      0      0      CAS Unk  YEL      0 db (CSU)/0-133 feet (DSX-1)
    
    I would appreciate any suggestion or help you could give me.

    Thank you
     

Share This Page