Configuration quintum AFT400

Discussion in 'Elastix 2.x' started by JUNIOR, Jan 25, 2010.

  1. JUNIOR

    Joined:
    Aug 10, 2009
    Messages:
    140
    Likes Received:
    0
    BONJOUR A TOUS

    j'ai une passerelle quitum AFT400 en FXO que je souhaite configure avec mon serveur elatix en IP PSTN
    j'ai recu a configurer les appels sortants elastix (ip)==> PSTN
    Mais je n'arrive pas a configurer les appels entrants PSTN===>elastx (ip)
    Je souhaiterais avec une idée sur cette config

    merci a tous
     
  2. lemuelgv

    Joined:
    Sep 9, 2008
    Messages:
    73
    Likes Received:
    0
    I Found this in the web, I tryed and it's work

    Code:
    All Quintum GW can be worked that I did with Elastix as well !!
    Method 1:
    Register to the server 
    
    -GateWay-1
    OutgoingIPRouting: 1 (SIP only)
    
    - SIPSignalingGroup-1
    PrimarySIPServer: xxx.xxx.xxx.xxx (server IP address)
    OutboundPrimaryServer: xxx.xxx.xxx.xxx (server IP address)
    
    -UserAgent-101
    id: 101
    ListenPort: 5060
    PrimaryUser: aaa
    PrimaryPassWord: bbb
    Contacts[1]: aaa (Same as Primary User)
    Contacts[2]: (Not Set)
    
    -HuntLDNDirectory-pub1
    Add the HLDND number -- aaa
    
    If the codec is correct, you can make the call now
    
    And now configure the Trunk and Outbound rule, that is Okay !!
    
    Method 2; (Firmware 106 or above)
    No need to register to TB, you can use the static route
    
    Change as follow;
    -SIPSignalingGroup-1
    1). SIPServerInFromHdr : 0 <------------------SIP Signaling Group
    2). DirectGWRouting : 1 <-----------------SIP Signaling Group
    
    in SR
    3). Registered : 1 <------------------------Static Route
    
    No need to add SERVER IP in PSIPS & OPS ; just set OIPR = 1 
    
    Trunk setting
    [aaa.bbb.ccc.ddd]
    type=peer
    host=aaa.bbb.ccc.ddd
    port=5060
    allow=ulaw
    context=from-internal
    insecure=very
    ;nat=yes
    
    Good Luck !
    
    
    
    

    I hope you can connect your gateway

    sory but I don´t speak francais
     
  3. JUNIOR

    Joined:
    Aug 10, 2009
    Messages:
    140
    Likes Received:
    0
    Thank you for your answers
    I use a Method 1
    I can make call ELASTIX TO PSTN
    but i can't make call PSTN to ELATIX

    Please can you give me a config from PSTN to ELASTIX ?
     
  4. lemuelgv

    Joined:
    Sep 9, 2008
    Messages:
    73
    Likes Received:
    0
    I use the method two

    Can you paste a cli session from a incoming call try
     
  5. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Salut junior.

    Comme cette partie de Forum est Francophone, il serait bien que tu traduises un peu ce qui se passe, et qu'une fois que tu auras trouvée la solution, que tu puisses la transmettre aux autres.
    Penses à la communauté. Tout le monde ne sait pas forcément lire l'Anglais. ;)
     
  6. JUNIOR

    Joined:
    Aug 10, 2009
    Messages:
    140
    Likes Received:
    0
    Merci Franck pour ta remarque
    En fait quand j'ai posté mon poste, la première personne qui ma repondu itl'a faen anglais c'est pour cette raison que j'ai repondu en anglais pour qu'il puisse comprendre et m'aider
    Mais le poste est toujours en cours j'ai pas encore eu de reponse
     
  7. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    oui, ok.
    Mais en faisant une petite traduction entre deux posts et/ou un résumé, ce serait intéressant pour les non anglophiles. Et qui sait, une aide soudaine... ;)

    Pi en ce qui concerne ta config trunk, tu ne donnes pas non plus beaucoup d'indice! :huh:
    Sois plus explicite dans ton problème.
     
  8. JUNIOR

    Joined:
    Aug 10, 2009
    Messages:
    140
    Likes Received:
    0
    OK
    Je veux etre le plus explicite possible
    J'ai un Quintum AFT400 avec 4FXO avec un port réseau. j'ai connecté le port réseau a mon elatix en IP. j'ai créé un trunk sip vers le Quintum
    voici le trunk

    PEER DETAIL
    context=from-trunk
    disallow=all
    allow=g729&g723
    dtmfmode=rfc2833
    host=192.168.1.230
    insecure=invite
    type=friend
    secret=12345
    username=777
    qualify=yes

    USER CONTEXT: from-pstn

    J'ai des config au niveau du Quintum que je ne peux pas vous fournir car c'est des truc a coché.
    Avec cette config j'arrive à faire les appels sortants mais les appels entrants ne passe pas.

    donc j'ai vraiment besoin comment faire la config pour que les appels entrants fonctionnent
    merci
     
  9. lemuelgv

    Joined:
    Sep 9, 2008
    Messages:
    73
    Likes Received:
    0
    pardon pour l'écriture dans une autre langue, je voulais juste aider et non le français, maintenant un traducteur utse


    pourrait ruban de la CLI d'une tentative de connexion de l'extérieur
     
  10. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi, and thanks for your effort, but it's at junior to translate your anwser.
    It's just for the french community members, for that they understand the problem.
    you can continue with the english language. ;)

    Bonjour et merci pour ton effort, mais c'est à Junior de traduire tes réponses.
    C'est juste pour les membres de la communauté Francophone, pour qu'ils comprennent le problème.
    Tu peux continuer en Anglais. ;)
     
  11. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    En regardant, 2 trucs me sautent aux yeux.
    1 - les context
    2 - les codecs

    Normalement Junior, tu dois savoir qu'il n'est pas nécessaire de renseigner la partie Incoming Settings, (Depuis le temps...). Là, tu cherches les embrouilles (context=from-trunk et from-pstn) Heuuu, l'appel choisit quel context?
    Donc revoir la prog de ton trunk.....

    Les codecs maintenants. Nativement, les G729 et 23 ne sont pas installés. As-tu procédé à l'install de ces codecs?

    English translate:
     
  12. JUNIOR

    Joined:
    Aug 10, 2009
    Messages:
    140
    Likes Received:
    0
    OK
    I would be most explicit possible
    I have a Quintum AFT400 with 4FXO with a network port. I connected the network port in my elatix IP. I created a trunk sip to Quintum
    Here is the trunk

    PEER DETAILS
    context = from-trunk
    disallow = all
    allow = g729 & g723
    dtmfmode = RFC2833
    host = 192.168.1.230
    insecure = invite
    type = friend
    secret = 12345
    username = 777
    qualify = yes

    USER CONTEXT: from-pstn

    I have config level Quintum I can not give you the trick because it was checked.
    With this config I can make outgoing calls but incoming calls not getting through.

    so I really need how to config for incoming calls work
    thank you
    Please note Although no boardcode and smiley buttons are shown, they are still useable
     
  13. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Junior, Veux tu de mon aide?
     
  14. JUNIOR

    Joined:
    Aug 10, 2009
    Messages:
    140
    Likes Received:
    0
  15. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ok, je ne peense pas qu'il y est plusieurs manières de faire une trunk.
    Pour ta config je mettrais:

    PEER DETAIL
    Code:
    host=192.168.1.230
    username=777
    secret=12345
    context=from-trunk
    disallow=all
    allow=alaw&ulaw
    dtmfmode=rfc2833
    insecure=very
    type=friend
    qualify=yes
    nat=no
    Et uniquement çà.

    _____________________
    Ok, I do not think that there are several ways to make a trunk. For your config I will put:

    ....

    And only that.
     

Share This Page