Configurarcion de una extension externa

Discussion in 'Elastix 2.x' started by racanix, Nov 19, 2009.

  1. racanix

    Joined:
    Oct 26, 2009
    Messages:
    29
    Likes Received:
    0
    Hola foro. Nuevamente yo.

    Resulta que tengo el siguiente problema y no se que pueda ser.

    mi pequeña pbx ya realiza llamadas al exterio e interior :).

    ahora lo que quiero realizar son llamadas desde extensiones exteriores
    es decir desde mi casa marcar a una extencion que estra en la oficina.
    ok. la llamada se realiza pero se escucha cortada como que hay retrazo
    en tre mensajes o no se hoye en ninguno de los extremos o se escuha nadamas
    en uno, y no se a que se deba. :S

    esto es llo que tengo en el sip.conf

    [general]
    language=es
    externip= mi.ip.
    fromdomain=midominio.com
    localnet=172.16.1.0/255.255.255.0
    qualify=yes

    y tengo abiertos los puertos 5060 y 4569 ¿¿ a caso me faltan mas puertos??
    si alguien me pueda ayudar
    se lo agradecere.

    saludos y gracias
     
  2. racanix

    Joined:
    Oct 26, 2009
    Messages:
    29
    Likes Received:
    0
    Hola amigos.

    Si me faltaban mas puertos por abrir en el ruter..
    abri del 10000 - 20000 y se puede establecer la llamada
    en ambos extremos :), pero la comunicacion se oye lenta


    Que puede estar pasando??

    Me falta algo?? :huh:

    espero y me puedan orientar saludos.
     
  3. EicheS

    Joined:
    Nov 13, 2009
    Messages:
    305
    Likes Received:
    0
    Saludos racanix

    el problema básicamente es de Codecs por lo que pude ver en la configuración no tienes definido ninguno Codec lo que indica que esta por defecto y el protocolo SIP utiliza g711(ulaw&alaw) y una llamada tiene un consumo entre 70.4 y 85.6 Kbps por llamada.

    No se si tengas 2 elastix y que troncal tengas creadas? o si solo tienes 1 solo? explica un poco mejor la arquitectura montada.

    ah y recuerda que se debe tener permisado los puertos 5056 para SIP, 10000 - 20000 para RTP, 4569 para IAX.
     
  4. racanix

    Joined:
    Oct 26, 2009
    Messages:
    29
    Likes Received:
    0
    Gracias por contestar EicheS

    Tengo solo un elastix V 1.5 y lo tengo configurado para un r2 en mexico
    linea con telmex.
    Tengo creada solo una troncal zap, y los codecs los agrege en
    el archivo sip_general_custom.conf:

    videosupport=yes
    allow=all
    allow=ulaw
    allow=alaw
    allow=gsm
    allow=g729
    allow=g723.1
    allow=g722
    allow=g711
    allow=h264
    allow=h261
    allow=h263
    allow=h263p

    Sobre permisos a los puertos que mensionas se dan en un archivo?? por que los abri en el router
    y nose si deban ir en otro archivo.

    saludos y gracias por contestar.
     
  5. arusnet

    Joined:
    Sep 11, 2008
    Messages:
    298
    Likes Received:
    0
    Tienes que entrar en la configuracion de las extensiones y en la seccion "device options" ---> "disallow" ahi pones "all". Y en "allow" tienes que poner "ulaw&alaw".
    Haz esto en todas las extensiones y prueba a ver que tal.
     
  6. EicheS

    Joined:
    Nov 13, 2009
    Messages:
    305
    Likes Received:
    0
    Saludos.

    Los puertos que mencione es para dejarlos pasar en el router nada mas.

    Retomando un poco el tema de inicio de este post, realice un diagrama segun lo que comentaste.

    pero tengo una duda las llamadas desde las extensiones internas a la lineas PSTN se escucha bien?

    segun los codoces que tienes deberia probar primero solo permitiendo G729 y G723.1 (claro esta si los tienes con licencias) ya que estos consumen menos ancho de banda. [​IMG]
     
  7. racanix

    Joined:
    Oct 26, 2009
    Messages:
    29
    Likes Received:
    0
    Saludos.

    Gracias a ambos por contestar

    sobre lo que comentaba EicheS sobre el ancho de vanda sobre la llamda,
    la extension externa cuenta con un ancho de 10kb quisas ese era el
    problema.

    Me comentan que se realizaron pruebas sobre otra extension pero con
    mayor ancho de banda y funciono bien.

    Esto me quedara como experiencia.

    Saludos y gracias por sus aportaciones, Y saber que en este
    foro siempre hay personas dispuestas a ayudar.

    gracias amigos.
     

Share This Page