Configuracion puertos fxs externos

Discussion in 'Elastix 2.x' started by pgomez, Aug 21, 2009.

  1. pgomez

    Joined:
    Aug 10, 2009
    Messages:
    25
    Likes Received:
    0
    Hola, quiero montar en elastix puertos externos fxs y a su vez colgando de ellos telefonos convencionales. Para ello tengo dos equipos para pruebas:

    1. Un router cisco 827-4v (este equipo contiene 4 puertos fxs)
    2. Un puerto externo (un puerto fxs)

    No encuentro ninguna documentacion de como poder unir a la central elastix, ¿ alguien puede facilitarme algun tipo de informacion?

    Gracias.
     
  2. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Puedes revisar la configuración de un cisco vg224, que es un equipo con 24 puertos FXS y puedes aplicar una configuración similar para el 827-4V

    Suerte,

    PD: si necesitas un IOS mas actual para el 827-4V, me indicas cuanta DRAM y FLASH tiene tu equipo
     
  3. pgomez

    Joined:
    Aug 10, 2009
    Messages:
    25
    Likes Received:
    0
    Gracias por contestar tan pronto, la version que tengo es c820-sv6y6-mz.123-7.t.rar es la ultima que he podido encontrar, si tienes alguna mas moderna te lo agradeceria, el link que me pusite lo tengo que comprobar creo que me vale, me puedes explicar que tengo que montar en el Elastix, un saludo
     
  4. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    El IOS que tienes es un IP VOICE/PLUS asi que deberia aceptar todos los comandos indicados en el link, donde tambien se indica la creación de un Trunk-SIP en elastix para la interconexion

    suerte,
     
  5. pgomez

    Joined:
    Aug 10, 2009
    Messages:
    25
    Likes Received:
    0
    Manzurek, quisiera que me dieras el link de donde esta la informacion para poder copiar el fichero del running-config, lo hice hace algun tiempo pero no recuerdo como. Ya tengo el fichero preparado, y si puede ser me gustaria que le echaras un vistazo por si crees que esta correcto.

    Un saludo y gracias.
     
  6. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Para copiar el running-config, debes tener un cliente tftp en tu PC y corres el siguiente comando en tu router:

    #copy running-config tftp: => del router a la PC

    #copy running-config flash: => de la PC al router

    Aqui en el foro, solo copia la configuración que sale con el comando #show run en tu router

    Saludos,
     
  7. pgomez

    Joined:
    Aug 10, 2009
    Messages:
    25
    Likes Received:
    0
    Utilizando el comando que me indicas, intento copiar la siguiente configuracion que tengo en un fichero:


    version 12.3
    no service pad
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    no service password-encryption
    !
    hostname vg224
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 16000
    enable password cisco
    !
    no aaa new-model
    clock timezone GMT -5
    !
    !
    ip source-route
    ip cef
    !
    !
    !
    !
    !
    !
    voice call send-alert
    voice rtp send-recv
    !
    voice service pots
    !
    voice service voip
    !
    voice class codec 1
    codec preference 1 g711ulaw
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    !
    application
    service dsapp
    param callWaiting TRUE
    !
    global
    service default dsapp
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.123.75 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.123.252
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 2/0
    mwi
    timeouts call-disconnect 5
    station-id name 1980
    station-id number 1980
    caller-id enable
    !
    voice-port 2/1
    mwi
    timeouts call-disconnect 5
    station-id name 1981
    station-id number 1981
    caller-id enable
    !
    voice-port 2/2
    mwi
    timeouts call-disconnect 5
    station-id name 1982
    station-id number 1982
    caller-id enable
    !
    voice-port 2/3
    mwi
    timeouts call-disconnect 5
    station-id name 1983
    station-id number 1983
    caller-id enable
    !
    !
    dial-peer voice 10 pots
    destination-pattern 1980
    port 2/0
    authentication username 1980 password 12345
    !
    dial-peer voice 11 pots
    destination-pattern 1981
    port 2/1
    authentication username 1981 password 12345
    !
    dial-peer voice 12 pots
    destination-pattern 1982
    port 2/2
    authentication username 1982 password 12345
    !
    dial-peer voice 13 pots
    destination-pattern 1983
    port 2/3
    authentication username 1983 password 12345
    !
    !
    dial-peer voice 100 voip
    destination-pattern 1...
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    dtmf-relay sip-notify rtp-nte
    no vad
    !
    sip-ua
    authentication username cisco password cisco123
    retry invite 3
    retry response 3
    retry bye 3
    retry cancel 3
    timers trying 1000
    mwi-server ipv4:192.168.123.80 expires 3600 port 5060 transport udp
    registrar ipv4:192.168.123.80:5060 expires 3600
    sip-server ipv4:192.168.123.80
    !
    .



    pero al hacer el show run obtengo lo siguiente:


    Current configuration : 898 bytes
    !
    version 12.3
    service config
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname vg224
    !
    enable secret 5 $1$D8c4$m42sTih96tCMXU2IoNUOC1
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip routing
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.123.75 255.255.255.0
    no ip route-cache
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip route-cache
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    ip classless
    ip http server
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !
    !
    voice-port 1
    !
    voice-port 2
    !
    voice-port 3
    !
    voice-port 4
    !
    !
    line con 0
    exec-timeout 0 0
    line vty 0 4
    exec-timeout 120 0
    password admin
    login
    length 0
    !
    scheduler max-task-time 5000
    !
    end


    Como ves, no consigo que tome los datos de el fichero que intento introducir, que es una modificacion de ips parecido al tuyo.

    saludos.
     
  8. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Lo que sucede es que no puedes simplemente copiar el archivo, ya que puede haber comandos que tu router no soporte :dry: y obviamente hay interfaces que no tiene, como por ejemplo:

    voice-port 2/0
    mwi
    timeouts call-disconnect 5
    station-id name 1980
    station-id number 1980
    caller-id enable


    no puedes pegar esto :S porque simplemente tu router no tiene esa interface (voice-port 2/0)

    Lo que te recomiendo es que metas la configuracion desde un telnet/consola, e ir probando uno a uno los comandos para ver si el IOS lo soporta

    La configuracion de tu rutedor seria algo como esto:

    Current configuration : 898 bytes
    !
    version 12.3
    service config
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 4vfxs
    !
    enable secret 5 $1$D8c4$m42sTih96tCMXU2IoNUOC1
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip routing
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.123.75 255.255.255.0
    no ip route-cache
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip route-cache
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    ip classless
    ip http server
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !
    !
    voice-port 1
    mwi
    timeouts call-disconnect 5
    station-id name 1980
    station-id number 1980
    caller-id enable
    !
    voice-port 2
    mwi
    timeouts call-disconnect 5
    station-id name 1981
    station-id number 1981
    caller-id enable
    !
    voice-port 3
    mwi
    timeouts call-disconnect 5
    station-id name 1982
    station-id number 1982
    caller-id enable
    !
    voice-port 4
    mwi
    timeouts call-disconnect 5
    station-id name 1983
    station-id number 1983
    caller-id enable
    !
    !
    dial-peer voice 10 pots
    destination-pattern 1980
    port 1
    authentication username 1980 password 12345
    !
    dial-peer voice 11 pots
    destination-pattern 1981
    port 2
    authentication username 1981 password 12345
    !
    dial-peer voice 12 pots
    destination-pattern 1982
    port 3
    authentication username 1982 password 12345
    !
    dial-peer voice 13 pots
    destination-pattern 1983
    port 4
    authentication username 1983 password 12345
    !
    !
    dial-peer voice 100 voip
    destination-pattern 1...
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    dtmf-relay sip-notify rtp-nte
    no vad
    !
    sip-ua
    authentication username cisco password cisco123
    retry invite 3
    retry response 3
    retry bye 3
    retry cancel 3
    timers trying 1000
    mwi-server ipv4:192.168.123.80 expires 3600 port 5060 transport udp
    registrar ipv4:192.168.123.80:5060 expires 3600
    sip-server ipv4:192.168.123.80
    !
    !
    line con 0
    exec-timeout 0 0
    line vty 0 4
    exec-timeout 120 0
    password admin
    login
    length 0
    !
    scheduler max-task-time 5000
    !
    end


    Suerte,
     
  9. pgomez

    Joined:
    Aug 10, 2009
    Messages:
    25
    Likes Received:
    0
    Lo he metido linea por linea, y he observado que el mwi no me lo coje y que el dial-peer voice no me deja meterle usuario y contraseña, me queda de la siguiente manera el fichero:

    Current configuration : 2118 bytes
    !
    version 12.3
    service config
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 4vfxs
    !
    enable secret 5 $1$D8c4$m42sTih96tCMXU2IoNUOC1
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip routing
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.123.75 255.255.255.0
    no ip route-cache
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip route-cache
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    ip classless
    ip http server
    !
    snmp-server community public RO
    snmp-server enable traps tty
    no cdp run
    !
    !
    voice-port 1
    timeouts call-disconnect 5
    threshold station-id name 1980
    threshold station-id number 1980
    threshold caller-id enable
    station-id name 1980
    station-id number 1980
    caller-id enable
    !
    voice-port 2
    timeouts call-disconnect 5
    threshold station-id name 1981
    threshold station-id number 1981
    threshold caller-id enable
    station-id name 1981
    station-id number 1981
    caller-id enable
    !
    voice-port 3
    timeouts call-disconnect 5
    threshold station-id name 1982
    threshold station-id number 1982
    threshold caller-id enable
    station-id name 1982
    station-id number 1982
    caller-id enable
    !
    voice-port 4
    timeouts call-disconnect 5
    threshold station-id name 1983
    threshold station-id number 1983
    threshold caller-id enable
    station-id name 1983
    station-id number 1983
    caller-id enable
    !
    dial-peer voice 10 pots
    destination-pattern 1980
    port 1
    !
    dial-peer voice 11 pots
    destination-pattern 1981
    port 2
    !
    dial-peer voice 12 pots
    destination-pattern 1982
    port 3
    !
    dial-peer voice 13 pots
    destination-pattern 1983
    port 4
    !
    dial-peer voice 100 voip
    destination-pattern 1...
    session protocol sipv2
    session target sip-server
    no vad
    !
    sip-ua
    retry invite 3
    retry response 3
    retry bye 3
    retry cancel 3
    timers trying 1000
    sip-server ipv4:192.168.123.80
    !
    !
    line con 0
    exec-timeout 0 0
    line vty 0 4
    exec-timeout 120 0
    password admin
    login
    length 0
    !
    scheduler max-task-time 5000
    !
    end



    te doy informacion de la IOS que tengo en el equipo:


    Cisco Internetwork Operating System Software
    IOS (tm) C820 Software (C820-SV6Y6-M), Version 12.3(2)XC2, EARLY DEPLOYMENT RELE
    ASE SOFTWARE (fc1)
    Synched to technology version 12.3(1.6)T
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2004 by cisco Systems, Inc.
    Compiled Wed 03-Mar-04 15:34 by ealyon
    Image text-base: 0x800131C0, data-base: 0x80DAAD20

    ROM: System Bootstrap, Version 12.2(1r)XE2, RELEASE SOFTWARE (fc1)
    ROM: C820 Software (C820-SV6Y6-M), Version 12.3(2)XC2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (fc1)

    4vfxs uptime is 5 minutes
    System returned to ROM by power-on
    System image file is "flash:c820-sv6y6-mz.123-2.XC2.bin"

    CISCO C827-4V (MPC855T) processor (revision 0x801) with 48128K/1024K bytes of me
    mory.
    Processor board ID JAD06490BQX (1415904157), with hardware revision 0000
    CPU rev number 5
    Bridging software.
    4 POTS Ports
    1 Ethernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    128K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)

    Configuration register is 0x2102


    Perdona, que te moleste tanto, pero es que voy muy perdido, tampoco se si la version de la ios es la correcta para hacer lo que deseo.


    Saludos.
     
  10. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Hola, indicame un correo donde pueda enviarte un IOS mas actual (tiene un tamaño aprox de 10M)
     
  11. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    mi querido amigo, me porias contar de donde consiges los IOS?????? es que son inexistentes en la web :(
     
  12. pgomez

    Joined:
    Aug 10, 2009
    Messages:
    25
    Likes Received:
    0
  13. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    pone el mail en una etiqueta bbcode, porque así te va a empezar a llegar spam en 2 horas, los bots barren todo y se llevan cualquier información que se te ocurra!

    gamba47
     
  14. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    aun asi esta protegida la liga de su correo, verificalo, copiando y pegando
     
  15. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    Es cierto, no me había dado cuenta.

    Pero será suficiente ?

    gamba47
     
  16. jcastellanos

    Joined:
    Feb 10, 2009
    Messages:
    2,404
    Likes Received:
    0
    pues no creo, pero ayuda mucho :D yo he puesto mi corro aqui y no ha pasado nada (hasta ahora)
     
  17. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Para poder descargar los firmwares/IOS de los productos Cisco, debes tener una cuenta registrada y con los permisos suficientes para realizar todas las descargas (incluyendo el software criptografico) desde su pagina web

    Saludos,
     

Share This Page