configs...

dberry

Joined
Nov 19, 2007
Messages
3
Likes
0
Points
0
#1
sorry in advance for the long post... I have tried setting it to from-pstn and from-trunk.

here is my sip.conf

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn't, try adding "nat=1" to each peer definition to
; solve translation problems.

[general]
#include sip_general_additional.conf

bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
nat=1
qualify=yes
externip=68.186.135.56
localnet=192.168.10.0/255.255.255.0
disallow=all
allow=ulaw
allow=alaw
; If you need to answer unauthenticated calls, you should change this
; next line to 'from-trunk', rather than 'from-sip-external'.
; You'll know this is happening if when you call in you get a message
; saying "The number you have dialed is not in service. Please check the
; number and try again."
context = from-pstn; Send unknown SIP callers to this context
callerid = Unknown
tos=0x68

; Reported as required for Asterisk 1.4
notifyringing=yes
notifyhold=yes
limitonpeers=yes

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
; jbenable=yes
; jbforce=yes

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf
#include sip_custom.conf
#include sip_additional.conf
I also tried using Aretta, here is my trunk info for Aretta.

Outgoing
Trunk Name: arettasip
allow=ulaw
canreinvite=no
context=from-trunk
disallow=all
dtmfmode=rfc2833
fromuser=******
host=sip.aretta.net
qualify=no
secret=******
sendrpid=yes
type=peer
username=******

Incoming
Trunk Name: arettasip_in
context=from-trunk
type=user

Registration String:
******:******@sip.aretta.net<br><br>Post edited by: dberry, at: 2007/11/21 15:35
 

CleveJ

Joined
Nov 12, 2007
Messages
100
Likes
0
Points
0
#2
dberry said:
sorry in advance for the long post... I have tried setting it to from-pstn and from-trunk.

here is my sip.conf

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn't, try adding "nat=1" to each peer definition to
; solve translation problems.

[general]
#include sip_general_additional.conf

bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
nat=1
qualify=yes
externip=68.186.135.56
localnet=192.168.10.0/255.255.255.0
disallow=all
allow=ulaw
allow=alaw
; If you need to answer unauthenticated calls, you should change this
; next line to 'from-trunk', rather than 'from-sip-external'.
; You'll know this is happening if when you call in you get a message
; saying "The number you have dialed is not in service. Please check the
; number and try again."
context = from-pstn; Send unknown SIP callers to this context
callerid = Unknown
tos=0x68

; Reported as required for Asterisk 1.4
notifyringing=yes
notifyhold=yes
limitonpeers=yes

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
; jbenable=yes
; jbforce=yes

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf
#include sip_custom.conf
#include sip_additional.conf
I also tried using Aretta, here is my trunk info for Aretta.

Outgoing
Trunk Name: arettasip
allow=ulaw
canreinvite=no
context=from-trunk
disallow=all
dtmfmode=rfc2833
fromuser=******
host=sip.aretta.net
qualify=no
secret=******
sendrpid=yes
type=peer
username=******

Incoming
Trunk Name: arettasip_in
context=from-trunk
type=user

Registration String:
******:******@sip.aretta.net<br><br>Post edited by: dberry, at: 2007/11/21 15:35
So what is your problem??
 

dberry

Joined
Nov 19, 2007
Messages
3
Likes
0
Points
0
#3
Sorry about that, i must have hit new topinc instead of reply, below is the original thread.

http://www.elastix.org/component/op...lastix_txt,Problem+wih+Inbound+Route/lang,en/

I can call a DID from a regular POTS phone if I configure it as a direct did to an extension,

I can call a DID configured to an inbound route to my IVR if i am using a UA connected to the server,

but I when it is configured as a DID to inbound route to IVR and i call from a POTS line, it rings busy and in the sip debug it says 404 Not Found.

I have tried setting the context = from-pstn and also from-trunk.

Again, I am so sorry about reposting, I meant to reply to the original topic.
 

Eham

Joined
Nov 16, 2007
Messages
42
Likes
0
Points
0
#4
You might want to keep the from-trunk, If you can make outgoing calls over the SIP trunk at that point you're almost there.

What I do is assign 3-digit extensions to my SIP devices then make sure I can register to the Elastix box with that. On the 3digit extension you've just built and registered to, add the 10-digit DID to the "Direct DID" on the extension. Leave everything else default for now on the extension. Can you make outgoing calls on the trunk? I didn't want my deployment to be used as a traditional PBX by dialing "9" for an outside line so I modified my outbound route on the SIP trunk with the dialplan:

1800NXXXXXX
1866NXXXXXX
1877NXXXXXX
1888NXXXXXX
1NXXNXXXXXX
NXXNXXXXXX
NXXXXXX


You might want to remove what you have for your inbound route and start over. This is what I've configured:

Add new incoming route. DO NOT add anything, do not change anything and submit. The any DID/any CID you've added will be treated to ring the DIDs you've assigned to your extensions previously. This works for me and I am using SIP trunking. I suppose your SIP trunking switch should be sending DIDs as 10digits, you might want to verify as this is something your ITSP controls.
 

Members online

No members online now.

Forum statistics

Threads
30,952
Messages
130,980
Members
17,654
Latest member
janko67
Top