Como cambio el formato de grabaciones de wav a GSM

Discussion in 'Elastix 2.x' started by cuauhtemocf, Feb 4, 2010.

  1. cuauhtemocf

    Joined:
    Feb 4, 2010
    Messages:
    2
    Likes Received:
    0
    hola,


    En la version Elastix 1.5.2-2.3 al cambiar el formato a WAV o gsm las grabaciones on demmand siguen en formato wav Alguien sabe de alguna solución? Anexo el codigo de extensions_additional.conf

    MIXMON_FORMAT = gsm

    [macro-record-enable]
    include => macro-record-enable-custom
    exten => s,1,GotoIf($["${BLINDTRANSFER}" = ""]?check)
    exten => s,n,ResetCDR(w)
    exten => s,n,StopMonitor()
    exten => s,n(check),AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,n,MacroExit()
    exten => s,1+998(record),MixMonitor(${MIXMON_DIR}${CALLFILENAME}.${MIXMON_FORMAT},,${MIXMON_POST})


    Gracias.

    Saludos,
     
  2. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Hola cuauhtemocf, bienvenido al foro.
    Para cambiar el modo a gsm, lo puedes hacer en PBX/PBX Configuration/General settings/Call recording format.
     
  3. cuauhtemocf

    Joined:
    Feb 4, 2010
    Messages:
    2
    Likes Received:
    0
    ramoncio


    Gracias por la pronto respuesta... Pero no funciona por alguna razón, no se si me falte algun codec o libreria en Centos.?



    Ese cambio lo probé con GSM y las grabaciones siguen saliendo en formato wav, incluso en el extensions_additional.conf tienen en el MIXMON_FORMAT = gsm y no funciona...


    Saludos,
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Prueba poner el debug y el verbose a 99 y mira en el log o en la consola, a ver si te da un error.
    Code:
    cat /var/log/asterisk/full |grep gsm
    
    A mi me funciona en Elastix 1.5 y 1.6. Pero me acabo de dar cuenta que los voicemails los mete en /var/spool/asterisk/monitor, en lugar de /var/spool/asterisk/voicemail
     

Share This Page